summaryrefslogtreecommitdiff
path: root/meta/recipes-devtools/intltool/intltool-0.40.6
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2011-08-31 11:26:58 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-08-31 18:06:37 +0100
commitb9fa8fd4f09b68cbcc12b557451a58a1f218d7f3 (patch)
treeecc5fa575e058f6e8cc89f59666cc3402b1bf224 /meta/recipes-devtools/intltool/intltool-0.40.6
parente5810439cc394d8ebfc264b05e1fbfad19e8fcd3 (diff)
downloadopenembedded-core-b9fa8fd4f09b68cbcc12b557451a58a1f218d7f3.tar.gz
openembedded-core-b9fa8fd4f09b68cbcc12b557451a58a1f218d7f3.tar.bz2
openembedded-core-b9fa8fd4f09b68cbcc12b557451a58a1f218d7f3.tar.xz
openembedded-core-b9fa8fd4f09b68cbcc12b557451a58a1f218d7f3.zip
intltool: Fix perl paths
Currently in the native case we have a path that can easily exceed the interpretor limit so use "env nativeperl" in that case. This patch also fixes up the target version's interpretor path but to do this we need to bypass the configure checks. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/intltool/intltool-0.40.6')
-rw-r--r--meta/recipes-devtools/intltool/intltool-0.40.6/noperlcheck.patch40
1 files changed, 40 insertions, 0 deletions
diff --git a/meta/recipes-devtools/intltool/intltool-0.40.6/noperlcheck.patch b/meta/recipes-devtools/intltool/intltool-0.40.6/noperlcheck.patch
new file mode 100644
index 000000000..3d8b591a4
--- /dev/null
+++ b/meta/recipes-devtools/intltool/intltool-0.40.6/noperlcheck.patch
@@ -0,0 +1,40 @@
+In the target case, we can't check if perl exists or try running it. If we
+don't patch the code, the native perl location would be used, not the target
+which is also incorrect. We therefore disable this code and rely on the
+correct value of PERL being passed in.
+
+RP 31/8/2011
+
+Upstream-Status: Inappropriate [OE specific]
+
+Index: intltool-0.40.6/configure.in
+===================================================================
+--- intltool-0.40.6.orig/configure.in 2011-08-31 11:21:13.061160535 +0100
++++ intltool-0.40.6/configure.in 2011-08-31 11:22:44.991160885 +0100
+@@ -9,24 +9,10 @@
+ aclocaldir='${datadir}'/aclocal
+ AC_SUBST(aclocaldir)
+
+-AC_PATH_PROG(PERL, perl)
+ if test -z "$PERL"; then
+- AC_MSG_ERROR([perl not found])
+-fi
+-AC_MSG_CHECKING([for perl >= 5.8.1])
+-$PERL -e "use 5.8.1;" > /dev/null 2>&1
+-if test $? -ne 0; then
+- AC_MSG_ERROR([perl 5.8.1 is required for intltool])
+-else
+- PERL_VERSION="`$PERL -e \"printf '%vd', $^V\"`"
+- AC_MSG_RESULT([$PERL_VERSION])
+-fi
+-AC_MSG_CHECKING([for XML::Parser])
+-if `$PERL -e "require XML::Parser" 2>/dev/null`; then
+- AC_MSG_RESULT([ok])
+-else
+- AC_MSG_ERROR([XML::Parser perl module is required for intltool])
++ AC_MSG_ERROR([PERL variable not set])
+ fi
++AC_SUBST(PERL)
+
+ AC_OUTPUT([
+ Makefile