summaryrefslogtreecommitdiff
path: root/meta/recipes-devtools/opkg/opkg_0.1.8.bb
diff options
context:
space:
mode:
authorGary Thomas <gary@mlbassoc.com>2011-04-18 08:23:27 -0600
committerSaul Wold <sgw@linux.intel.com>2011-04-22 22:03:56 -0700
commita46466893407d44dd16ab37ae70e1bee14bdde0a (patch)
treecab7368e9bc977c4cc112171c22a46279697247e /meta/recipes-devtools/opkg/opkg_0.1.8.bb
parenta0629aa0dc55829565b7ab1725875eac065ab2f1 (diff)
downloadopenembedded-core-a46466893407d44dd16ab37ae70e1bee14bdde0a.tar.gz
openembedded-core-a46466893407d44dd16ab37ae70e1bee14bdde0a.tar.bz2
openembedded-core-a46466893407d44dd16ab37ae70e1bee14bdde0a.tar.xz
openembedded-core-a46466893407d44dd16ab37ae70e1bee14bdde0a.zip
Control over when package init scripts are run
When a package is built, some installation scripts must be performed on the target. In the case of a complete image, these scripts are run by a separate step at init time, but only during the first boot (other package install scripts can just be run when the package is installed on the target). This patch lets the distribution (or user) decide when these postponed install scripts should run. The default is normally near the end of init, but there may be times when it's beneficial to run them earlier so the "when" can be overridden. Signed-off-by: Gary Thomas <gary@mlbassoc.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-devtools/opkg/opkg_0.1.8.bb')
-rw-r--r--meta/recipes-devtools/opkg/opkg_0.1.8.bb13
1 files changed, 4 insertions, 9 deletions
diff --git a/meta/recipes-devtools/opkg/opkg_0.1.8.bb b/meta/recipes-devtools/opkg/opkg_0.1.8.bb
index 681547420..18cf0428c 100644
--- a/meta/recipes-devtools/opkg/opkg_0.1.8.bb
+++ b/meta/recipes-devtools/opkg/opkg_0.1.8.bb
@@ -13,7 +13,7 @@ SRC_URI = "http://opkg.googlecode.com/files/opkg-${PV}.tar.gz \
file://headerfix.patch \
"
-PR = "r3"
+PR = "r4"
PACKAGES =+ "libopkg${PKGSUFFIX}-dev libopkg${PKGSUFFIX} update-alternatives-cworth${PKGSUFFIX}"
@@ -26,11 +26,6 @@ do_install_append() {
install -d ${D}${localstatedir}/lib/opkg
}
-# Define a variable to allow distros to run configure earlier.
-# (for example, to enable loading of ethernet kernel modules before networking starts)
-OPKG_INIT_POSITION = "98"
-OPKG_INIT_POSITION_slugos = "41"
-
pkg_postinst_${PN} () {
#!/bin/sh
if [ "x$D" != "x" ]; then
@@ -38,9 +33,9 @@ if [ "x$D" != "x" ]; then
# this happens at S98 where our good 'ole packages script used to run
echo "#!/bin/sh
opkg-cl configure
-rm -f /${sysconfdir}/rcS.d/S${OPKG_INIT_POSITION}configure
-" > $D${sysconfdir}/rcS.d/S${OPKG_INIT_POSITION}configure
- chmod 0755 $D${sysconfdir}/rcS.d/S${OPKG_INIT_POSITION}configure
+rm -f /${sysconfdir}/rcS.d/S${POSTINSTALL_INITPOSITION}configure
+" > $D${sysconfdir}/rcS.d/S${POSTINSTALL_INITPOSITION}configure
+ chmod 0755 $D${sysconfdir}/rcS.d/S${POSTINSTALL_INITPOSITION}configure
fi
update-alternatives --install ${bindir}/opkg opkg ${bindir}/opkg-cl 100