summaryrefslogtreecommitdiff
path: root/meta/recipes-devtools/perl/liburi-perl_1.56.bb
diff options
context:
space:
mode:
authorJingdong Lu <jingdong.lu@windriver.com>2011-01-21 17:20:46 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-01-25 12:25:45 +0000
commit562789455df668e20e87b008ea4a080ee42bd9f4 (patch)
treec49f87eeee1849d6295977b00ffb7d3a4bee98e5 /meta/recipes-devtools/perl/liburi-perl_1.56.bb
parent3b3711672861a82bf73d9ecbc20d07a8bb4aff2d (diff)
downloadopenembedded-core-562789455df668e20e87b008ea4a080ee42bd9f4.tar.gz
openembedded-core-562789455df668e20e87b008ea4a080ee42bd9f4.tar.bz2
openembedded-core-562789455df668e20e87b008ea4a080ee42bd9f4.tar.xz
openembedded-core-562789455df668e20e87b008ea4a080ee42bd9f4.zip
liburi-perl: Rename liburi-perl
Signed-off-by: Jingdong Lu <jingdong.lu@windriver.com>
Diffstat (limited to 'meta/recipes-devtools/perl/liburi-perl_1.56.bb')
-rw-r--r--meta/recipes-devtools/perl/liburi-perl_1.56.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta/recipes-devtools/perl/liburi-perl_1.56.bb b/meta/recipes-devtools/perl/liburi-perl_1.56.bb
new file mode 100644
index 000000000..76a123138
--- /dev/null
+++ b/meta/recipes-devtools/perl/liburi-perl_1.56.bb
@@ -0,0 +1,25 @@
+DESCRIPTION = "This package contains the URI.pm module with friends. \
+The module implements the URI class. URI objects can be used to access \
+and manipulate the various components that make up these strings."
+
+SECTION = "libs"
+LICENSE = "Artistic | GPLv1+"
+PR = "r0"
+
+LIC_FILES_CHKSUM = "file://README;beginline=26;endline=30;md5=6c33ae5c87fd1c4897714e122dd9c23d"
+
+DEPENDS += "perl"
+
+SRC_URI = "http://www.cpan.org/authors/id/G/GA/GAAS/URI-${PV}.tar.gz"
+
+S = "${WORKDIR}/URI-${PV}"
+
+EXTRA_CPANFLAGS = "EXPATLIBPATH=${STAGING_LIBDIR} EXPATINCPATH=${STAGING_INCDIR}"
+
+inherit cpan
+
+do_compile() {
+ export LIBC="$(find ${STAGING_DIR_TARGET}/${base_libdir}/ -name 'libc-*.so')"
+ cpan_do_compile
+}
+