summaryrefslogtreecommitdiff
path: root/meta/recipes-devtools/perl/liburi-perl_1.59.bb
diff options
context:
space:
mode:
authorKang Kai <kai.kang@windriver.com>2011-10-18 16:42:32 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-10-20 13:07:15 +0100
commitb3cbb5a8e8aeeb3a55649dba1aca73595305309e (patch)
tree2715c4c7b1e1206e00eb02737d907841155ce8dc /meta/recipes-devtools/perl/liburi-perl_1.59.bb
parente480beff01924f76422a4fd216b5a7fadb345ae0 (diff)
downloadopenembedded-core-b3cbb5a8e8aeeb3a55649dba1aca73595305309e.tar.gz
openembedded-core-b3cbb5a8e8aeeb3a55649dba1aca73595305309e.tar.bz2
openembedded-core-b3cbb5a8e8aeeb3a55649dba1aca73595305309e.tar.xz
openembedded-core-b3cbb5a8e8aeeb3a55649dba1aca73595305309e.zip
liburi-perl: update to 1.59
Update liburi-perl to 1.59 Signed-off-by: Kang Kai <kai.kang@windriver.com>
Diffstat (limited to 'meta/recipes-devtools/perl/liburi-perl_1.59.bb')
-rw-r--r--meta/recipes-devtools/perl/liburi-perl_1.59.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta/recipes-devtools/perl/liburi-perl_1.59.bb b/meta/recipes-devtools/perl/liburi-perl_1.59.bb
new file mode 100644
index 000000000..877b25212
--- /dev/null
+++ b/meta/recipes-devtools/perl/liburi-perl_1.59.bb
@@ -0,0 +1,28 @@
+DESCRIPTION = "This package contains the URI.pm module with friends. \
+The module implements the URI class. URI objects can be used to access \
+and manipulate the various components that make up these strings."
+
+SECTION = "libs"
+LICENSE = "Artistic | GPLv1+"
+PR = "r0"
+
+LIC_FILES_CHKSUM = "file://README;beginline=26;endline=30;md5=6c33ae5c87fd1c4897714e122dd9c23d"
+
+DEPENDS += "perl"
+
+SRC_URI = "http://www.cpan.org/authors/id/G/GA/GAAS/URI-${PV}.tar.gz"
+
+SRC_URI[md5sum] = "fecebf8fa20e2d26ea4a1649c095e96e"
+SRC_URI[sha256sum] = "cb88d29b589db8d2adbc4713fd082284cba77883488717375f011bbd13b5cac6"
+
+S = "${WORKDIR}/URI-${PV}"
+
+EXTRA_CPANFLAGS = "EXPATLIBPATH=${STAGING_LIBDIR} EXPATINCPATH=${STAGING_INCDIR}"
+
+inherit cpan
+
+do_compile() {
+ export LIBC="$(find ${STAGING_DIR_TARGET}/${base_libdir}/ -name 'libc-*.so')"
+ cpan_do_compile
+}
+