summaryrefslogtreecommitdiff
path: root/meta/recipes-devtools/perl/perl-5.12.2/debian/fixes/processPL.diff
diff options
context:
space:
mode:
authorNitin A Kamble <nitin.a.kamble@intel.com>2010-12-22 09:26:07 -0800
committerSaul Wold <sgw@linux.intel.com>2011-01-12 00:55:48 -0800
commitf57e9daf74d5fbab6c9a3f5e60e1320a0bf0642d (patch)
treef6b24ea8f39fd6c83a161f91117641a851c4a9c6 /meta/recipes-devtools/perl/perl-5.12.2/debian/fixes/processPL.diff
parentfde91acaf7849d80a2b9c908398bee2c3452004e (diff)
downloadopenembedded-core-f57e9daf74d5fbab6c9a3f5e60e1320a0bf0642d.tar.gz
openembedded-core-f57e9daf74d5fbab6c9a3f5e60e1320a0bf0642d.tar.bz2
openembedded-core-f57e9daf74d5fbab6c9a3f5e60e1320a0bf0642d.tar.xz
openembedded-core-f57e9daf74d5fbab6c9a3f5e60e1320a0bf0642d.zip
perl, perl-native: upgrade from 5.8.8 to 5.12.2
Deleted these patches as they are part of the upstream code now. deleted: files/perl-5.8.8-gcc-4.2.patch deleted: perl-5.12.2/makedepend-dash.patch deleted: perl-5.12.2/native-no-gdbminc.patch deleted: perl-5.12.2/54_debian_perldoc-r.patch And rebased these patches to the newer source code modified: files/letgcc-find-errno.patch modified: perl-5.12.2/Makefile.patch modified: perl-5.12.2/asm-pageh-fix.patch modified: perl-5.12.2/native-nopacklist.patch modified: perl-5.12.2/native-perlinc.patch modified: perl-5.12.2/Makefile.SH.patch modified: perl-5.12.2/installperl.patch modified: perl-5.12.2/perl-dynloader.patch modified: perl-5.12.2/09_fix_installperl.patch get patches from debian perl ver 5.12.2-2 the fakeroot.diff patch from debian is conflicting with our Makefile.SH.patch, hence disabling the fakeroot patch use newly created config files Created with current milestone branch on qemu machines modified: config.sh modified: config.sh-32 modified: config.sh-64 get some changes from oe's perl 5.10.1 recipe fix the Makefile.SH.patch use miniperl instead of perl import a OE 5.10.1 patch: uudmap_cross fix install issues add /usr in the destdir, so that perl gets installed in /usr/bin/perl and not in /bin/perl link /usr/lib/perl to /usr/lib/perl5 so that operations with /usr/lib/perl path in them keep on working. Fix/Improve perl packaging avoid perl-module-module-* kind of packages recreate perl-rdepends_5.12.2.inc file with new set of packages import from oe perl-rprovide_5.12.2.inc combine all unicore perl scripts in one package simplify perl-lib reduce no of perl recipe packages greatly. Add zlib to depedancy fix buildtime host contamination This also fixes [BUGID #384] Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com>
Diffstat (limited to 'meta/recipes-devtools/perl/perl-5.12.2/debian/fixes/processPL.diff')
-rw-r--r--meta/recipes-devtools/perl/perl-5.12.2/debian/fixes/processPL.diff43
1 files changed, 43 insertions, 0 deletions
diff --git a/meta/recipes-devtools/perl/perl-5.12.2/debian/fixes/processPL.diff b/meta/recipes-devtools/perl/perl-5.12.2/debian/fixes/processPL.diff
new file mode 100644
index 000000000..5a444e3f6
--- /dev/null
+++ b/meta/recipes-devtools/perl/perl-5.12.2/debian/fixes/processPL.diff
@@ -0,0 +1,43 @@
+Subject: Always use PERLRUNINST when building perl modules.
+Bug-Debian: http://bugs.debian.org/357264
+Bug: http://rt.cpan.org/Public/Bug/Display.html?id=17224
+
+Revert part of upstream change 24524 to always use PERLRUNINST when
+building perl modules: Some PDL demos expect blib to be implicitly
+searched.
+
+
+---
+ cpan/ExtUtils-MakeMaker/lib/ExtUtils/MM_Unix.pm | 5 +----
+ 1 files changed, 1 insertions(+), 4 deletions(-)
+
+diff --git a/cpan/ExtUtils-MakeMaker/lib/ExtUtils/MM_Unix.pm b/cpan/ExtUtils-MakeMaker/lib/ExtUtils/MM_Unix.pm
+index 239d6df..294d266 100644
+--- a/cpan/ExtUtils-MakeMaker/lib/ExtUtils/MM_Unix.pm
++++ b/cpan/ExtUtils-MakeMaker/lib/ExtUtils/MM_Unix.pm
+@@ -3043,14 +3043,11 @@ sub processPL {
+ # pm_to_blib depends on then it can't depend on pm_to_blib
+ # else we have a dependency loop.
+ my $pm_dep;
+- my $perlrun;
+ if( defined $self->{PM}{$target} ) {
+ $pm_dep = '';
+- $perlrun = 'PERLRUN';
+ }
+ else {
+ $pm_dep = 'pm_to_blib';
+- $perlrun = 'PERLRUNINST';
+ }
+
+ $m .= <<MAKE_FRAG;
+@@ -3059,7 +3056,7 @@ all :: $target
+ \$(NOECHO) \$(NOOP)
+
+ $target :: $plfile $pm_dep
+- \$($perlrun) $plfile $target
++ \$(PERLRUNINST) $plfile $target
+ MAKE_FRAG
+
+ }
+--
+tg: (c823880..) fixes/processPL (depends on: upstream)