summaryrefslogtreecommitdiff
path: root/meta/recipes-devtools/perl/perl-5.12.2
diff options
context:
space:
mode:
authorNitin A Kamble <nitin.a.kamble@intel.com>2011-02-16 16:39:21 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-02-17 23:19:39 +0000
commit265bd1ce61e3f7089e919a409e4923fcf062dae5 (patch)
treeab6d038995e06c808c55e844f238daa817ab64af /meta/recipes-devtools/perl/perl-5.12.2
parent27894c58b74fb01530aa7144b8e8c7a2298187b4 (diff)
downloadopenembedded-core-265bd1ce61e3f7089e919a409e4923fcf062dae5.tar.gz
openembedded-core-265bd1ce61e3f7089e919a409e4923fcf062dae5.tar.bz2
openembedded-core-265bd1ce61e3f7089e919a409e4923fcf062dae5.tar.xz
openembedded-core-265bd1ce61e3f7089e919a409e4923fcf062dae5.zip
perl-native: fix parallel build
perl native recipe was failing on 40-way system with the parallel build turned on. With this patch the parallel build on 40 way build system is not failing. Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com> Passed 31 clean/build cycles on the 40-way. Tested-by: Darren Hart <dvhart@linux.intel.com>
Diffstat (limited to 'meta/recipes-devtools/perl/perl-5.12.2')
-rw-r--r--meta/recipes-devtools/perl/perl-5.12.2/parallel_build_fix.patch18
1 files changed, 18 insertions, 0 deletions
diff --git a/meta/recipes-devtools/perl/perl-5.12.2/parallel_build_fix.patch b/meta/recipes-devtools/perl/perl-5.12.2/parallel_build_fix.patch
new file mode 100644
index 000000000..476577eb3
--- /dev/null
+++ b/meta/recipes-devtools/perl/perl-5.12.2/parallel_build_fix.patch
@@ -0,0 +1,18 @@
+This patch fixes the parallel make issue on a 40 way build system
+
+Nitin A Kamble <nitin.a.kamble@intel.com>
+2011-02-16
+
+Index: perl-5.12.2/Makefile.SH
+===================================================================
+--- perl-5.12.2.orig/Makefile.SH 2010-09-06 16:30:32.000000000 -0700
++++ perl-5.12.2/Makefile.SH 2011-02-16 16:21:30.744143773 -0800
+@@ -198,6 +198,8 @@
+ $this_target: uni.data" ;;
+ Text/ParseWords) extra_dep="$extra_dep
+ $this_target: lib/auto/Scalar/Util.$dlext" ;;
++ POSIX) extra_dep="$extra_dep
++$this_target: lib/auto/Cwd/Cwd.$dlext" ;;
+ esac
+ done
+