summaryrefslogtreecommitdiff
path: root/meta/recipes-devtools/python/python-dbus_0.84.0.bb
diff options
context:
space:
mode:
authorNitin A Kamble <nitin.a.kamble@intel.com>2011-09-28 13:52:40 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-10-20 13:07:14 +0100
commit95e9eb0d5a9c44c52d550b0796eef08f54925205 (patch)
treece5252fae2ccd01389d1752f4ab6c1374c187adc /meta/recipes-devtools/python/python-dbus_0.84.0.bb
parentbd34ca3f4912cf957fb3b46c31c757d284dfc4c7 (diff)
downloadopenembedded-core-95e9eb0d5a9c44c52d550b0796eef08f54925205.tar.gz
openembedded-core-95e9eb0d5a9c44c52d550b0796eef08f54925205.tar.bz2
openembedded-core-95e9eb0d5a9c44c52d550b0796eef08f54925205.tar.xz
openembedded-core-95e9eb0d5a9c44c52d550b0796eef08f54925205.zip
python-dbus: upgrade from 0.83.2 to 0.84.0
Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com>
Diffstat (limited to 'meta/recipes-devtools/python/python-dbus_0.84.0.bb')
-rw-r--r--meta/recipes-devtools/python/python-dbus_0.84.0.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python-dbus_0.84.0.bb b/meta/recipes-devtools/python/python-dbus_0.84.0.bb
new file mode 100644
index 000000000..fff864906
--- /dev/null
+++ b/meta/recipes-devtools/python/python-dbus_0.84.0.bb
@@ -0,0 +1,25 @@
+DESCRIPTION = "Python bindings for DBus, a socket-based message bus system for interprocess communication"
+SECTION = "devel/python"
+HOMEPAGE = "http://www.freedesktop.org/Software/dbus"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://COPYING;md5=f5612614133e9a2f2dad527d97554670"
+DEPENDS = "expat dbus dbus-glib virtual/libintl python-pyrex-native"
+PR = "r0"
+
+SRC_URI = "http://dbus.freedesktop.org/releases/dbus-python/dbus-python-${PV}.tar.gz"
+
+SRC_URI[md5sum] = "fe69a2613e824463e74f10913708c88a"
+SRC_URI[sha256sum] = "b85bc7aaf1a976627ca461b1ca7b0c4ddddff709f52fe44c9b2d1d7d8fac5906"
+S = "${WORKDIR}/dbus-python-${PV}"
+
+inherit distutils-base autotools pkgconfig
+
+export BUILD_SYS
+export HOST_SYS
+
+export STAGING_LIBDIR
+export STAGING_INCDIR
+
+RDEPENDS_${PN} = "python-io python-logging python-stringold python-threading python-xml"
+
+FILES_${PN}-dev += "${libdir}/pkgconfig