summaryrefslogtreecommitdiff
path: root/meta/recipes-devtools/python/python-imaging/path.patch
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2012-03-15 13:17:58 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-03-16 10:56:31 +0000
commit9950163c91412eb58c3475354cc7f87a7be33c2b (patch)
tree10599476c47f433edb08c495f57c80128c679117 /meta/recipes-devtools/python/python-imaging/path.patch
parent0038a030e605195284c98bc154f500a1343c252b (diff)
downloadopenembedded-core-9950163c91412eb58c3475354cc7f87a7be33c2b.tar.gz
openembedded-core-9950163c91412eb58c3475354cc7f87a7be33c2b.tar.bz2
openembedded-core-9950163c91412eb58c3475354cc7f87a7be33c2b.tar.xz
openembedded-core-9950163c91412eb58c3475354cc7f87a7be33c2b.zip
python-imaging: bring in fixes from meta-oe
This makes the following changes: * Replace the /usr/local/bin/python path in all scripts * Move RDEPENDS_${PN} to the end (but use += or we lose the python-core depencency). * Use PR = "r3" instead of "ml2". (Even without increasing the numeric part it is recognised as greater alphabetically.) * Bring in meta-oe version of the path patch which avoids the following warning: WARNING: python-imaging: The compile log indicates that host include and/or library paths were used. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Diffstat (limited to 'meta/recipes-devtools/python/python-imaging/path.patch')
-rw-r--r--meta/recipes-devtools/python/python-imaging/path.patch35
1 files changed, 0 insertions, 35 deletions
diff --git a/meta/recipes-devtools/python/python-imaging/path.patch b/meta/recipes-devtools/python/python-imaging/path.patch
deleted file mode 100644
index a5bba75ef..000000000
--- a/meta/recipes-devtools/python/python-imaging/path.patch
+++ /dev/null
@@ -1,35 +0,0 @@
-Upstream-Status: Inappropriate [embedded specific]
-
-Index: Imaging-1.1.7/setup.py
-===================================================================
---- Imaging-1.1.7.orig/setup.py
-+++ Imaging-1.1.7/setup.py
-@@ -34,10 +34,10 @@ def libinclude(root):
- # TIFF_ROOT = libinclude("/opt/tiff")
-
- TCL_ROOT = None
--JPEG_ROOT = None
--ZLIB_ROOT = None
-+JPEG_ROOT = os.environ['STAGING_LIBDIR']
-+ZLIB_ROOT = os.environ['STAGING_LIBDIR']
- TIFF_ROOT = None
--FREETYPE_ROOT = None
-+FREETYPE_ROOT = os.environ['STAGING_LIBDIR'], os.environ['STAGING_INCDIR']
- LCMS_ROOT = None
-
- # FIXME: add mechanism to explicitly *disable* the use of a library
-@@ -207,14 +207,6 @@ class pil_build_ext(build_ext):
- if os.path.isfile(os.path.join(tcl_dir, "tk.h")):
- add_directory(include_dirs, tcl_dir)
-
-- # standard locations
-- add_directory(library_dirs, "/usr/local/lib")
-- add_directory(include_dirs, "/usr/local/include")
--
-- add_directory(library_dirs, "/usr/lib")
-- add_directory(include_dirs, "/usr/include")
--
-- #
- # insert new dirs *before* default libs, to avoid conflicts
- # between Python PYD stub libs and real libraries
-