summaryrefslogtreecommitdiff
path: root/meta/recipes-devtools/python/python-native-2.6.5/nohostlibs.patch
diff options
context:
space:
mode:
authorNitin A Kamble <nitin.a.kamble@intel.com>2010-11-08 10:34:46 -0800
committerSaul Wold <sgw@linux.intel.com>2010-11-14 21:08:26 -0800
commit793bb465b3a6b0c883340621575b9944d7ccaf5a (patch)
treeb668cfadf3836b3d018dd76005f3bb65b4f8dd03 /meta/recipes-devtools/python/python-native-2.6.5/nohostlibs.patch
parenta7af5c516e547e669d92569dba21a9c1c790cf7f (diff)
downloadopenembedded-core-793bb465b3a6b0c883340621575b9944d7ccaf5a.tar.gz
openembedded-core-793bb465b3a6b0c883340621575b9944d7ccaf5a.tar.bz2
openembedded-core-793bb465b3a6b0c883340621575b9944d7ccaf5a.tar.xz
openembedded-core-793bb465b3a6b0c883340621575b9944d7ccaf5a.zip
python, python-native upgrade from 2.6.5 to 2.6.6
Removed these patch: python-native-2.6.5/00-fix-bindir-libdir-for-cross.patch python/00-fix-bindir-libdir-for-cross.patch The upstream code has changed, and it does not need the above 2 patches (fixes) anymore. Patches rebased to the newer code: python/01-use-proper-tools-for-cross-build.patch python/04-default-is-optimized.patch python/06-avoid_usr_lib_termcap_path_in_linking.patch python/99-ignore-optimization-flag.patch Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com>
Diffstat (limited to 'meta/recipes-devtools/python/python-native-2.6.5/nohostlibs.patch')
-rw-r--r--meta/recipes-devtools/python/python-native-2.6.5/nohostlibs.patch53
1 files changed, 0 insertions, 53 deletions
diff --git a/meta/recipes-devtools/python/python-native-2.6.5/nohostlibs.patch b/meta/recipes-devtools/python/python-native-2.6.5/nohostlibs.patch
deleted file mode 100644
index 7020f3c2a..000000000
--- a/meta/recipes-devtools/python/python-native-2.6.5/nohostlibs.patch
+++ /dev/null
@@ -1,53 +0,0 @@
-Index: Python-2.6.1/setup.py
-===================================================================
---- Python-2.6.1.orig/setup.py 2009-11-13 16:20:47.000000000 +0000
-+++ Python-2.6.1/setup.py 2009-11-13 16:28:00.000000000 +0000
-@@ -310,8 +310,8 @@
-
- def detect_modules(self):
- # Ensure that /usr/local is always used
-- add_dir_to_list(self.compiler.library_dirs, '/usr/local/lib')
-- add_dir_to_list(self.compiler.include_dirs, '/usr/local/include')
-+ #add_dir_to_list(self.compiler.library_dirs, '/usr/local/lib')
-+ #add_dir_to_list(self.compiler.include_dirs, '/usr/local/include')
-
- # Add paths specified in the environment variables LDFLAGS and
- # CPPFLAGS for header and library files.
-@@ -347,10 +347,10 @@
- for directory in reversed(options.dirs):
- add_dir_to_list(dir_list, directory)
-
-- if os.path.normpath(sys.prefix) != '/usr':
-- add_dir_to_list(self.compiler.library_dirs,
-+
-+ add_dir_to_list(self.compiler.library_dirs,
- sysconfig.get_config_var("LIBDIR"))
-- add_dir_to_list(self.compiler.include_dirs,
-+ add_dir_to_list(self.compiler.include_dirs,
- sysconfig.get_config_var("INCLUDEDIR"))
-
- try:
-@@ -361,11 +361,8 @@
- # lib_dirs and inc_dirs are used to search for files;
- # if a file is found in one of those directories, it can
- # be assumed that no additional -I,-L directives are needed.
-- lib_dirs = self.compiler.library_dirs + [
-- '/lib64', '/usr/lib64',
-- '/lib', '/usr/lib',
-- ]
-- inc_dirs = self.compiler.include_dirs + ['/usr/include']
-+ lib_dirs = self.compiler.library_dirs
-+ inc_dirs = self.compiler.include_dirs
- exts = []
- missing = []
-
-@@ -583,8 +580,7 @@
- readline_libs.append('ncurses')
- elif self.compiler.find_library_file(lib_dirs, 'curses'):
- readline_libs.append('curses')
-- elif self.compiler.find_library_file(lib_dirs +
-- ['/usr/lib/termcap'],
-+ elif self.compiler.find_library_file(lib_dirs,
- 'termcap'):
- readline_libs.append('termcap')
- exts.append( Extension('readline', ['readline.c'],