summaryrefslogtreecommitdiff
path: root/meta/recipes-devtools/python/python-native_2.6.6.bb
diff options
context:
space:
mode:
authorNitin A Kamble <nitin.a.kamble@intel.com>2011-10-14 07:06:13 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2011-10-31 18:01:55 +0100
commitb284e9a512860b8a8380be80f96cebce6b92ff80 (patch)
treebb994e1ebcd23f8d48efefaff559c361d0ebf0ed /meta/recipes-devtools/python/python-native_2.6.6.bb
parentff13e06892f102d915855cde50896349b07b3717 (diff)
downloadopenembedded-core-b284e9a512860b8a8380be80f96cebce6b92ff80.tar.gz
openembedded-core-b284e9a512860b8a8380be80f96cebce6b92ff80.tar.bz2
openembedded-core-b284e9a512860b8a8380be80f96cebce6b92ff80.tar.xz
openembedded-core-b284e9a512860b8a8380be80f96cebce6b92ff80.zip
python, python-native: upgrade from 2.6.6 to 2.7.2
Rebased these patches to the newer code modified: python-native/nohostlibs.patch modified: python/01-use-proper-tools-for-cross-build.patch modified: python/06-avoid_usr_lib_termcap_path_in_linking.patch modified: python/06-ctypes-libffi-fix-configure.patch modified: python/multilib.patch Deleted these patches are the are now upstream deleted: python/02-remove-test-for-cross.patch deleted: python/security_issue_2254_fix.patch Added this patch to python-native new file: python-native/multilib.patch Updated site config file for python modified: ../../site/common-linux : add ac_cv_have_long_long_format for python avoid this error in python: Include/pyport.h:243:13: error: #error "This platform's pyconfig.h needs to define PY_FORMAT_LONG_LONG" Updated default python version modified: ../../conf/distro/include/default-versions.inc Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta/recipes-devtools/python/python-native_2.6.6.bb')
-rw-r--r--meta/recipes-devtools/python/python-native_2.6.6.bb48
1 files changed, 0 insertions, 48 deletions
diff --git a/meta/recipes-devtools/python/python-native_2.6.6.bb b/meta/recipes-devtools/python/python-native_2.6.6.bb
deleted file mode 100644
index e0a4fb36d..000000000
--- a/meta/recipes-devtools/python/python-native_2.6.6.bb
+++ /dev/null
@@ -1,48 +0,0 @@
-require python.inc
-DEPENDS = "openssl-native bzip2-full-native zlib-native readline-native sqlite3-native"
-PR = "${INC_PR}.4"
-
-LIC_FILES_CHKSUM = "file://LICENSE;md5=38fdd546420fab09ac6bd3d8a1c83eb6"
-
-SRC_URI = "http://www.python.org/ftp/python/${PV}/Python-${PV}.tar.bz2 \
- file://04-default-is-optimized.patch \
- file://05-enable-ctypes-cross-build.patch \
- file://06-ctypes-libffi-fix-configure.patch \
- file://10-distutils-fix-swig-parameter.patch \
- file://11-distutils-never-modify-shebang-line.patch \
- file://12-distutils-prefix-is-inside-staging-area.patch \
- file://debug.patch \
- file://unixccompiler.patch \
- file://nohostlibs.patch"
-S = "${WORKDIR}/Python-${PV}"
-
-SRC_URI[md5sum] = "cf4e6881bb84a7ce6089e4a307f71f14"
-SRC_URI[sha256sum] = "134c5e0736bae2e5570d0b915693374f11108ded63c35a23a35d282737d2ce83"
-
-inherit native
-
-EXTRA_OEMAKE = '\
- BUILD_SYS="" \
- HOST_SYS="" \
- LIBC="" \
- STAGING_LIBDIR=${STAGING_LIBDIR_NATIVE} \
- STAGING_INCDIR=${STAGING_INCDIR_NATIVE} \
-'
-
-do_configure_prepend() {
- autoreconf --verbose --install --force --exclude=autopoint Modules/_ctypes/libffi || bbnote "_ctypes failed to autoreconf"
-}
-
-do_install() {
- oe_runmake 'DESTDIR=${D}' install
- install -d ${D}${bindir}/
- install -m 0755 Parser/pgen ${D}${bindir}/
-
- # Make sure we use /usr/bin/env python
- for PYTHSCRIPT in `grep -rIl ${bindir}/python ${D}${bindir}`; do
- sed -i -e '1s|^#!.*|#!/usr/bin/env python|' $PYTHSCRIPT
- done
-
- ln -sf python ${D}${bindir}/python2
-
-}