summaryrefslogtreecommitdiff
path: root/meta/recipes-devtools/python/python_2.7.2.bb
diff options
context:
space:
mode:
authorAndreas Oberritter <obi@opendreambox.org>2012-03-12 22:24:09 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-03-13 11:44:46 +0000
commit3bb9d027fff925a40c4dea9109df9464a76853b7 (patch)
tree79fee07c07fa0a0e8a0ebae1d6d482b4d95ab84f /meta/recipes-devtools/python/python_2.7.2.bb
parentaccb2b728ab10cae20be59253a56ac6410b8de10 (diff)
downloadopenembedded-core-3bb9d027fff925a40c4dea9109df9464a76853b7.tar.gz
openembedded-core-3bb9d027fff925a40c4dea9109df9464a76853b7.tar.bz2
openembedded-core-3bb9d027fff925a40c4dea9109df9464a76853b7.tar.xz
openembedded-core-3bb9d027fff925a40c4dea9109df9464a76853b7.zip
python: regenerate plat-linux2/*.py
* If plat-linux2/DLFCN.py was present, python was broken in our image, i.e. it was unable to load many modules. This was due to changed RTLD_* constants in dlfcn.h * Python includes a script, plat-linux2/regen, to regenerate the py source codes in this directory. * Do what plat-linux2/regen would do, but use files from STAGING_INCDIR. Signed-off-by: Andreas Oberritter <obi@opendreambox.org>
Diffstat (limited to 'meta/recipes-devtools/python/python_2.7.2.bb')
-rw-r--r--meta/recipes-devtools/python/python_2.7.2.bb11
1 files changed, 11 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python_2.7.2.bb b/meta/recipes-devtools/python/python_2.7.2.bb
index 5ad410904..0a8e53494 100644
--- a/meta/recipes-devtools/python/python_2.7.2.bb
+++ b/meta/recipes-devtools/python/python_2.7.2.bb
@@ -37,6 +37,17 @@ do_configure_prepend() {
}
do_compile() {
+ # regenerate platform specific files, because they depend on system headers
+ cd Lib/plat-linux2
+ include=${STAGING_INCDIR} ${STAGING_BINDIR_NATIVE}/python \
+ ${S}/Tools/scripts/h2py.py -i '(u_long)' \
+ ${STAGING_INCDIR}/dlfcn.h \
+ ${STAGING_INCDIR}/linux/cdrom.h \
+ ${STAGING_INCDIR}/netinet/in.h \
+ ${STAGING_INCDIR}/sys/types.h
+ sed -e 's,${STAGING_DIR_HOST},,g' -i *.py
+ cd -
+
#
# Copy config.h and an appropriate Makefile for distutils.sysconfig,
# which laters uses the information out of these to compile extensions