summaryrefslogtreecommitdiff
path: root/meta/recipes-devtools/python/python_2.7.2.bb
diff options
context:
space:
mode:
authorAndrei Gherzan <andrei@gherzan.ro>2012-04-05 23:54:21 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-04-25 00:02:27 +0100
commit4993f50744882ee384cb8fb106ad209f0d887b3f (patch)
tree4f280a3e71634e8970e7f7ba488b479a2aadc270 /meta/recipes-devtools/python/python_2.7.2.bb
parent7bd803c9535afe5933d41f92da5208ae773e2abb (diff)
downloadopenembedded-core-4993f50744882ee384cb8fb106ad209f0d887b3f.tar.gz
openembedded-core-4993f50744882ee384cb8fb106ad209f0d887b3f.tar.bz2
openembedded-core-4993f50744882ee384cb8fb106ad209f0d887b3f.tar.xz
openembedded-core-4993f50744882ee384cb8fb106ad209f0d887b3f.zip
python: Add patch for 64bit platform
This patch was added for 64bit host machines. In the compile process python is checking if platform is a 64bit platform using sys.maxint which is the host's value. The patch fixes this issue so that python would check if TARGET machine is 64bit not the HOST machine. In this way will have "dl" and "imageop" modules built if HOST machine is 64bit but the target machine is 32bit. [YOCTO #1937] Signed-off-by: Andrei Gherzan <andrei@gherzan.ro> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python_2.7.2.bb')
-rw-r--r--meta/recipes-devtools/python/python_2.7.2.bb3
1 files changed, 2 insertions, 1 deletions
diff --git a/meta/recipes-devtools/python/python_2.7.2.bb b/meta/recipes-devtools/python/python_2.7.2.bb
index 9ba561b18..bfe3ee02f 100644
--- a/meta/recipes-devtools/python/python_2.7.2.bb
+++ b/meta/recipes-devtools/python/python_2.7.2.bb
@@ -1,6 +1,6 @@
require python.inc
DEPENDS = "python-native bzip2 db gdbm openssl readline sqlite3 zlib"
-PR = "${INC_PR}.15"
+PR = "${INC_PR}.16"
DISTRO_SRC_URI ?= "file://sitecustomize.py"
DISTRO_SRC_URI_linuxstdbase = ""
@@ -22,6 +22,7 @@ SRC_URI += "\
file://sys_platform_is_now_always_linux2.patch \
file://fix_for_using_different_libdir.patch \
file://setuptweaks.patch \
+ file://check-if-target-is-64b-not-host.patch \
"
S = "${WORKDIR}/Python-${PV}"