summaryrefslogtreecommitdiff
path: root/meta/recipes-devtools/python/python_2.7.2.bb
diff options
context:
space:
mode:
authorNitin A Kamble <nitin.a.kamble@intel.com>2012-03-14 11:06:09 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-03-19 13:31:32 +0000
commitbf52e32e09423056c8c78760db22ca7497ec357d (patch)
tree2092549bf0149339140b418bd9a39ae374127684 /meta/recipes-devtools/python/python_2.7.2.bb
parent0b3f43c81bea71a5e8c240aba8d97999fcf560ab (diff)
downloadopenembedded-core-bf52e32e09423056c8c78760db22ca7497ec357d.tar.gz
openembedded-core-bf52e32e09423056c8c78760db22ca7497ec357d.tar.bz2
openembedded-core-bf52e32e09423056c8c78760db22ca7497ec357d.tar.xz
openembedded-core-bf52e32e09423056c8c78760db22ca7497ec357d.zip
python: fix install when libdir is not "lib"
This commit fixes python's install issue of not finding the native pythong binray modules. Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com>
Diffstat (limited to 'meta/recipes-devtools/python/python_2.7.2.bb')
-rw-r--r--meta/recipes-devtools/python/python_2.7.2.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python_2.7.2.bb b/meta/recipes-devtools/python/python_2.7.2.bb
index d2100be4a..cb0a1d5a4 100644
--- a/meta/recipes-devtools/python/python_2.7.2.bb
+++ b/meta/recipes-devtools/python/python_2.7.2.bb
@@ -21,6 +21,7 @@ SRC_URI += "\
file://add-md5module-support.patch \
file://host_include_contamination.patch \
file://sys_platform_is_now_always_linux2.patch \
+ file://fix_for_using_different_libdir.patch \
"
S = "${WORKDIR}/Python-${PV}"
@@ -99,6 +100,7 @@ do_install() {
oe_runmake HOSTPGEN=${STAGING_BINDIR_NATIVE}/pgen \
HOSTPYTHON=${STAGING_BINDIR_NATIVE}/python \
+ CROSSPYTHONPATH=${STAGING_LIBDIR_NATIVE}/python${PYTHON_MAJMIN}/lib-dynload/ \
STAGING_LIBDIR=${STAGING_LIBDIR} \
STAGING_INCDIR=${STAGING_INCDIR} \
BUILD_SYS=${BUILD_SYS} HOST_SYS=${HOST_SYS} \