summaryrefslogtreecommitdiff
path: root/meta/recipes-devtools/python/python_2.7.2.bb
diff options
context:
space:
mode:
authorGary Thomas <gary@mlbassoc.com>2012-03-23 13:28:16 -0600
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-03-26 12:06:30 +0100
commitc239564c768d0f305d8707103f4c59cf60431670 (patch)
tree29b05ec838e989badef81ce63b95e78788811e14 /meta/recipes-devtools/python/python_2.7.2.bb
parent602a0aede00ec961ffb008619cc8f6ee4ae51f58 (diff)
downloadopenembedded-core-c239564c768d0f305d8707103f4c59cf60431670.tar.gz
openembedded-core-c239564c768d0f305d8707103f4c59cf60431670.tar.bz2
openembedded-core-c239564c768d0f305d8707103f4c59cf60431670.tar.xz
openembedded-core-c239564c768d0f305d8707103f4c59cf60431670.zip
python: fix packaging dependencies on minimal systems
If you install the top-level python package only on a minimal system which has no other python packages installed then python is not functional at all. Without any extra packages installed this error is seen: # python Traceback (most recent call last): File "/usr/lib/python2.7/site.py", line 64, in <module> import traceback ImportError: No module named traceback Installing python-lang only partly fixes the problem as this error still exists: # python Traceback (most recent call last): File "/usr/lib/python2.7/site.py", line 569, in <module> main() File "/usr/lib/python2.7/site.py", line 551, in main known_paths = addusersitepackages(known_paths) File "/usr/lib/python2.7/site.py", line 278, in addusersitepackages user_site = getusersitepackages() File "/usr/lib/python2.7/site.py", line 253, in getusersitepackages user_base = getuserbase() # this will also set USER_BASE File "/usr/lib/python2.7/site.py", line 243, in getuserbase USER_BASE = get_config_var('userbase') File "/usr/lib/python2.7/sysconfig.py", line 520, in get_config_var return get_config_vars().get(name) File "/usr/lib/python2.7/sysconfig.py", line 400, in get_config_vars import re ImportError: No module named re Signed-off-by: Gary Thomas <gary@mlbassoc.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python_2.7.2.bb')
-rw-r--r--meta/recipes-devtools/python/python_2.7.2.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-devtools/python/python_2.7.2.bb b/meta/recipes-devtools/python/python_2.7.2.bb
index 8111b31e2..8cf45da5c 100644
--- a/meta/recipes-devtools/python/python_2.7.2.bb
+++ b/meta/recipes-devtools/python/python_2.7.2.bb
@@ -1,6 +1,6 @@
require python.inc
DEPENDS = "python-native bzip2 db gdbm openssl readline sqlite3 zlib"
-PR = "${INC_PR}.8"
+PR = "${INC_PR}.9"
DISTRO_SRC_URI ?= "file://sitecustomize.py"
DISTRO_SRC_URI_linuxstdbase = ""