summaryrefslogtreecommitdiff
path: root/meta/recipes-devtools/qemu/qemu-0.12.4/fix-nogl.patch
diff options
context:
space:
mode:
authorZhai Edwin <edwin.zhai@intel.com>2011-01-15 16:32:15 +0800
committerSaul Wold <sgw@linux.intel.com>2011-01-21 01:36:14 -0800
commit576e136d9d6d473ce6a7ffc7abadc75e1a218418 (patch)
tree1a3498eddb2ad99d0a864389d0d011b6c828fecc /meta/recipes-devtools/qemu/qemu-0.12.4/fix-nogl.patch
parent7d9a8fc931966012a9ddd50e607c6de1d94fe394 (diff)
downloadopenembedded-core-576e136d9d6d473ce6a7ffc7abadc75e1a218418.tar.gz
openembedded-core-576e136d9d6d473ce6a7ffc7abadc75e1a218418.tar.bz2
openembedded-core-576e136d9d6d473ce6a7ffc7abadc75e1a218418.tar.xz
openembedded-core-576e136d9d6d473ce6a7ffc7abadc75e1a218418.zip
qemu: Upgrade from 0.12.4 to 0.13.0
Patch status: -- Removed -- arm-cp15-fix.patch arm_timer-fix-oneshot-mode.patch arm_timer-reload-timer-when-enabled.patch cursor-shadow-fix.patch -- They are already in upstream or some new changes make them useless. -- Added -- parallel_make.patch: Fix "make -j(>=6)" failure wacom-tablet-fix.patch: Fix seg fault of usb tablet. port92_fix.patch: Fix boot failure on ppc due to port 0x92 conflict. Signed-off-by: Zhai Edwin <edwin.zhai@intel.com>
Diffstat (limited to 'meta/recipes-devtools/qemu/qemu-0.12.4/fix-nogl.patch')
-rw-r--r--meta/recipes-devtools/qemu/qemu-0.12.4/fix-nogl.patch96
1 files changed, 0 insertions, 96 deletions
diff --git a/meta/recipes-devtools/qemu/qemu-0.12.4/fix-nogl.patch b/meta/recipes-devtools/qemu/qemu-0.12.4/fix-nogl.patch
deleted file mode 100644
index 528b6f0d1..000000000
--- a/meta/recipes-devtools/qemu/qemu-0.12.4/fix-nogl.patch
+++ /dev/null
@@ -1,96 +0,0 @@
-Index: qemu-0.12.4/Makefile.target
-===================================================================
---- qemu-0.12.4.orig/Makefile.target 2010-06-24 07:59:15.669394205 +0100
-+++ qemu-0.12.4/Makefile.target 2010-06-24 08:07:38.739399512 +0100
-@@ -47,6 +47,10 @@
- libobj-y += op_helper.o helper.o
- libobj-$(CONFIG_NEED_MMU) += mmu.o
- libobj-$(TARGET_I386) += helper_opengl.o opengl_exec.o
-+libobj-$(TARGET_X86_64) += helper_opengl.o opengl_exec.o
-+libobj-$(TARGET_ARM) += dummygl.o
-+libobj-$(TARGET_MIPS) += dummygl.o
-+libobj-$(TARGET_PPC) += dummygl.o
- libobj-$(TARGET_ARM) += neon_helper.o iwmmxt_helper.o
- libobj-$(TARGET_ALPHA) += alpha_palcode.o
-
-Index: qemu-0.12.4/target-arm/dummygl.c
-===================================================================
---- /dev/null 1970-01-01 00:00:00.000000000 +0000
-+++ qemu-0.12.4/target-arm/dummygl.c 2010-06-24 07:59:15.899401748 +0100
-@@ -0,0 +1,22 @@
-+#include <string.h>
-+#include <stdlib.h>
-+#include <assert.h>
-+#include <stdint.h>
-+#include <X11/Xlib.h>
-+#include <X11/Xutil.h>
-+
-+void opengl_exec_set_parent_window(Display* _dpy, Window _parent_window)
-+{
-+
-+}
-+
-+void opengl_process_enable(void)
-+{
-+
-+}
-+
-+
-+void mem_opengl(uint64_t ptr)
-+{
-+
-+}
-Index: qemu-0.12.4/target-mips/dummygl.c
-===================================================================
---- /dev/null 1970-01-01 00:00:00.000000000 +0000
-+++ qemu-0.12.4/target-mips/dummygl.c 2010-06-24 07:59:15.899401748 +0100
-@@ -0,0 +1,22 @@
-+#include <string.h>
-+#include <stdlib.h>
-+#include <assert.h>
-+#include <stdint.h>
-+#include <X11/Xlib.h>
-+#include <X11/Xutil.h>
-+
-+void opengl_exec_set_parent_window(Display* _dpy, Window _parent_window)
-+{
-+
-+}
-+
-+void opengl_process_enable(void)
-+{
-+
-+}
-+
-+
-+void mem_opengl(uint64_t ptr)
-+{
-+
-+}
-Index: qemu-0.12.4/target-ppc/dummygl.c
-===================================================================
---- /dev/null 1970-01-01 00:00:00.000000000 +0000
-+++ qemu-0.12.4/target-ppc/dummygl.c 2010-06-24 08:07:59.070712946 +0100
-@@ -0,0 +1,22 @@
-+#include <string.h>
-+#include <stdlib.h>
-+#include <assert.h>
-+#include <stdint.h>
-+#include <X11/Xlib.h>
-+#include <X11/Xutil.h>
-+
-+void opengl_exec_set_parent_window(Display* _dpy, Window _parent_window)
-+{
-+
-+}
-+
-+void opengl_process_enable(void)
-+{
-+
-+}
-+
-+
-+void mem_opengl(uint64_t ptr)
-+{
-+
-+}