summaryrefslogtreecommitdiff
path: root/meta/recipes-devtools/qemu/qemu-0.12.4
diff options
context:
space:
mode:
authorZhai Edwin <edwin.zhai@intel.com>2010-08-31 16:34:09 +0800
committerRichard Purdie <rpurdie@linux.intel.com>2010-08-31 16:48:53 +0100
commit09bffb70def83bbca575e4f5b78b3fc949ebf517 (patch)
tree81931295d913d229620daf6fed175b97f2025419 /meta/recipes-devtools/qemu/qemu-0.12.4
parent1f0ba7c2b0429909ead5ae8fc015a827b08edf85 (diff)
downloadopenembedded-core-09bffb70def83bbca575e4f5b78b3fc949ebf517.tar.gz
openembedded-core-09bffb70def83bbca575e4f5b78b3fc949ebf517.tar.bz2
openembedded-core-09bffb70def83bbca575e4f5b78b3fc949ebf517.tar.xz
openembedded-core-09bffb70def83bbca575e4f5b78b3fc949ebf517.zip
Add qemu-i386 in qemu-native, required by eglibc
Adding i386-linux-user in target-list is enough in theory, but our gl stuff is not friendly to linux-user code. So disable it when compiling linux-user. [BUGID #218] fixed by this. Signed-off-by: Zhai Edwin <edwin.zhai@intel.com>
Diffstat (limited to 'meta/recipes-devtools/qemu/qemu-0.12.4')
-rw-r--r--meta/recipes-devtools/qemu/qemu-0.12.4/enable-i386-linux-user.patch53
1 files changed, 53 insertions, 0 deletions
diff --git a/meta/recipes-devtools/qemu/qemu-0.12.4/enable-i386-linux-user.patch b/meta/recipes-devtools/qemu/qemu-0.12.4/enable-i386-linux-user.patch
new file mode 100644
index 000000000..550d48b13
--- /dev/null
+++ b/meta/recipes-devtools/qemu/qemu-0.12.4/enable-i386-linux-user.patch
@@ -0,0 +1,53 @@
+Enable i386-linux-user
+
+Signed-off-by: Zhai Edwin <edwin.zhai@intel.com>
+
+Index: qemu-0.12.4/Makefile.target
+===================================================================
+--- qemu-0.12.4.orig/Makefile.target 2010-08-31 13:57:01.000000000 +0800
++++ qemu-0.12.4/Makefile.target 2010-08-31 14:03:06.000000000 +0800
+@@ -46,8 +46,13 @@
+ libobj-$(CONFIG_NOSOFTFLOAT) += fpu/softfloat-native.o
+ libobj-y += op_helper.o helper.o
+ libobj-$(CONFIG_NEED_MMU) += mmu.o
++ifndef CONFIG_LINUX_USER
+ libobj-$(TARGET_I386) += helper_opengl.o opengl_exec.o
+ libobj-$(TARGET_X86_64) += helper_opengl.o opengl_exec.o
++else
++libobj-$(TARGET_I386) += dummygl.o
++libobj-$(TARGET_X86_64) += dummygl.o
++endif #CONFIG_LINUX_USER
+ libobj-$(TARGET_ARM) += dummygl.o
+ libobj-$(TARGET_MIPS) += dummygl.o
+ libobj-$(TARGET_PPC) += dummygl.o
+Index: qemu-0.12.4/target-i386/dummygl.c
+===================================================================
+--- /dev/null 1970-01-01 00:00:00.000000000 +0000
++++ qemu-0.12.4/target-i386/dummygl.c 2010-08-31 15:25:25.000000000 +0800
+@@ -0,0 +1,26 @@
++#include <string.h>
++#include <stdlib.h>
++#include <assert.h>
++#include <stdint.h>
++#include <X11/Xlib.h>
++#include <X11/Xutil.h>
++
++void opengl_exec_set_parent_window(Display* _dpy, Window _parent_window)
++{
++
++}
++
++void opengl_process_enable(void)
++{
++
++}
++
++
++void mem_opengl(uint64_t ptr)
++{
++
++}
++
++void helper_opengl(void)
++{
++}