summaryrefslogtreecommitdiff
path: root/meta/recipes-devtools/qemu/qemu-0.13.0/fix-nogl.patch
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2011-03-16 17:40:36 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-03-25 13:31:51 +0000
commit97fbdfdbfb15de325fd148bcecc9187d0f778db5 (patch)
treee51451abb1c77c5083e07006b9f3aefcbb93cb64 /meta/recipes-devtools/qemu/qemu-0.13.0/fix-nogl.patch
parent073f162529e5b84f12d348ae49edccc377ec5f7e (diff)
downloadopenembedded-core-97fbdfdbfb15de325fd148bcecc9187d0f778db5.tar.gz
openembedded-core-97fbdfdbfb15de325fd148bcecc9187d0f778db5.tar.bz2
openembedded-core-97fbdfdbfb15de325fd148bcecc9187d0f778db5.tar.xz
openembedded-core-97fbdfdbfb15de325fd148bcecc9187d0f778db5.zip
qemu: Upgrade 0.13.0 -> 0.14.0
* ppc-hack patch is dropped. * Other patches which were direct backports or has been merged upstream in 0.14.0 are also dropped Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta/recipes-devtools/qemu/qemu-0.13.0/fix-nogl.patch')
-rw-r--r--meta/recipes-devtools/qemu/qemu-0.13.0/fix-nogl.patch96
1 files changed, 0 insertions, 96 deletions
diff --git a/meta/recipes-devtools/qemu/qemu-0.13.0/fix-nogl.patch b/meta/recipes-devtools/qemu/qemu-0.13.0/fix-nogl.patch
deleted file mode 100644
index fa518abbf..000000000
--- a/meta/recipes-devtools/qemu/qemu-0.13.0/fix-nogl.patch
+++ /dev/null
@@ -1,96 +0,0 @@
-Index: qemu-0.13.0/Makefile.target
-===================================================================
---- qemu-0.13.0.orig/Makefile.target 2011-01-17 16:53:08.000000000 +0800
-+++ qemu-0.13.0/Makefile.target 2011-01-17 16:53:11.000000000 +0800
-@@ -55,6 +55,10 @@
- endif
- libobj-$(CONFIG_NEED_MMU) += mmu.o
- libobj-$(TARGET_I386) += helper_opengl.o opengl_exec.o
-+libobj-$(TARGET_X86_64) += helper_opengl.o opengl_exec.o
-+libobj-$(TARGET_ARM) += dummygl.o
-+libobj-$(TARGET_MIPS) += dummygl.o
-+libobj-$(TARGET_PPC) += dummygl.o
- libobj-$(TARGET_ARM) += neon_helper.o iwmmxt_helper.o
-
- libobj-y += disas.o
-Index: qemu-0.13.0/target-arm/dummygl.c
-===================================================================
---- /dev/null 1970-01-01 00:00:00.000000000 +0000
-+++ qemu-0.13.0/target-arm/dummygl.c 2011-01-17 16:53:11.000000000 +0800
-@@ -0,0 +1,22 @@
-+#include <string.h>
-+#include <stdlib.h>
-+#include <assert.h>
-+#include <stdint.h>
-+#include <X11/Xlib.h>
-+#include <X11/Xutil.h>
-+
-+void opengl_exec_set_parent_window(Display* _dpy, Window _parent_window)
-+{
-+
-+}
-+
-+void opengl_process_enable(void)
-+{
-+
-+}
-+
-+
-+void mem_opengl(uint64_t ptr)
-+{
-+
-+}
-Index: qemu-0.13.0/target-mips/dummygl.c
-===================================================================
---- /dev/null 1970-01-01 00:00:00.000000000 +0000
-+++ qemu-0.13.0/target-mips/dummygl.c 2011-01-17 16:53:11.000000000 +0800
-@@ -0,0 +1,22 @@
-+#include <string.h>
-+#include <stdlib.h>
-+#include <assert.h>
-+#include <stdint.h>
-+#include <X11/Xlib.h>
-+#include <X11/Xutil.h>
-+
-+void opengl_exec_set_parent_window(Display* _dpy, Window _parent_window)
-+{
-+
-+}
-+
-+void opengl_process_enable(void)
-+{
-+
-+}
-+
-+
-+void mem_opengl(uint64_t ptr)
-+{
-+
-+}
-Index: qemu-0.13.0/target-ppc/dummygl.c
-===================================================================
---- /dev/null 1970-01-01 00:00:00.000000000 +0000
-+++ qemu-0.13.0/target-ppc/dummygl.c 2011-01-17 16:53:11.000000000 +0800
-@@ -0,0 +1,22 @@
-+#include <string.h>
-+#include <stdlib.h>
-+#include <assert.h>
-+#include <stdint.h>
-+#include <X11/Xlib.h>
-+#include <X11/Xutil.h>
-+
-+void opengl_exec_set_parent_window(Display* _dpy, Window _parent_window)
-+{
-+
-+}
-+
-+void opengl_process_enable(void)
-+{
-+
-+}
-+
-+
-+void mem_opengl(uint64_t ptr)
-+{
-+
-+}