summaryrefslogtreecommitdiff
path: root/meta/recipes-devtools/qemu/qemu-0.13.0/parallel_make.patch
diff options
context:
space:
mode:
authorZhai Edwin <edwin.zhai@intel.com>2011-01-15 16:32:15 +0800
committerSaul Wold <sgw@linux.intel.com>2011-01-21 01:36:14 -0800
commit576e136d9d6d473ce6a7ffc7abadc75e1a218418 (patch)
tree1a3498eddb2ad99d0a864389d0d011b6c828fecc /meta/recipes-devtools/qemu/qemu-0.13.0/parallel_make.patch
parent7d9a8fc931966012a9ddd50e607c6de1d94fe394 (diff)
downloadopenembedded-core-576e136d9d6d473ce6a7ffc7abadc75e1a218418.tar.gz
openembedded-core-576e136d9d6d473ce6a7ffc7abadc75e1a218418.tar.bz2
openembedded-core-576e136d9d6d473ce6a7ffc7abadc75e1a218418.tar.xz
openembedded-core-576e136d9d6d473ce6a7ffc7abadc75e1a218418.zip
qemu: Upgrade from 0.12.4 to 0.13.0
Patch status: -- Removed -- arm-cp15-fix.patch arm_timer-fix-oneshot-mode.patch arm_timer-reload-timer-when-enabled.patch cursor-shadow-fix.patch -- They are already in upstream or some new changes make them useless. -- Added -- parallel_make.patch: Fix "make -j(>=6)" failure wacom-tablet-fix.patch: Fix seg fault of usb tablet. port92_fix.patch: Fix boot failure on ppc due to port 0x92 conflict. Signed-off-by: Zhai Edwin <edwin.zhai@intel.com>
Diffstat (limited to 'meta/recipes-devtools/qemu/qemu-0.13.0/parallel_make.patch')
-rw-r--r--meta/recipes-devtools/qemu/qemu-0.13.0/parallel_make.patch34
1 files changed, 34 insertions, 0 deletions
diff --git a/meta/recipes-devtools/qemu/qemu-0.13.0/parallel_make.patch b/meta/recipes-devtools/qemu/qemu-0.13.0/parallel_make.patch
new file mode 100644
index 000000000..278b1a759
--- /dev/null
+++ b/meta/recipes-devtools/qemu/qemu-0.13.0/parallel_make.patch
@@ -0,0 +1,34 @@
+Make -j(>=6) always fail as some job depends on config-host.h. Added following
+patch in upstream to resolve it.
+
+Could remove it in next upgrade if necessary.
+
+Signed-off-by: Zhai Edwin <edwin.zhai@intel.com>
+
+commit f0acb38015409024683911380daa94cc974e4e0e
+Author: Paul Brook <paul@codesourcery.com>
+Date: Fri Nov 26 18:46:03 2010 +0000
+
+ Add missing dependency.
+
+ Teach Makefile that cmd.o depends on a generated header (specifically
+ config-host.h).
+
+ Signed-off-by: Paul Brook <paul@codesourcery.com>
+ (cherry picked from commit 6e14404aab26f74a448747d1e793ac16bde8a92b)
+
+ Signed-off-by: Aurelien Jarno <aurelien@aurel32.net>
+
+Index: qemu-0.13.0/Makefile
+===================================================================
+--- qemu-0.13.0.orig/Makefile 2011-01-18 09:45:45.000000000 +0800
++++ qemu-0.13.0/Makefile 2011-01-18 09:45:45.000000000 +0800
+@@ -107,7 +107,7 @@
+ ######################################################################
+
+ qemu-img.o: qemu-img-cmds.h
+-qemu-img.o qemu-tool.o qemu-nbd.o qemu-io.o: $(GENERATED_HEADERS)
++qemu-img.o qemu-tool.o qemu-nbd.o qemu-io.o cmd.o: $(GENERATED_HEADERS)
+
+ qemu-img$(EXESUF): qemu-img.o qemu-tool.o qemu-error.o $(block-obj-y) $(qobject-obj-y)
+