summaryrefslogtreecommitdiff
path: root/meta/recipes-devtools/qemu/qemu-0.14.0
diff options
context:
space:
mode:
authorSaul Wold <sgw@linux.intel.com>2011-04-26 21:43:17 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-04-28 09:52:31 +0100
commit4b3e39a9dd491a8a6996fce8ed0d05074ea920f5 (patch)
tree195a9ccb571ee9d4ddc1bc4add9850a575dbf239 /meta/recipes-devtools/qemu/qemu-0.14.0
parente0ed7caa65c9b6667d311d3eb26ff99dd778173d (diff)
downloadopenembedded-core-4b3e39a9dd491a8a6996fce8ed0d05074ea920f5.tar.gz
openembedded-core-4b3e39a9dd491a8a6996fce8ed0d05074ea920f5.tar.bz2
openembedded-core-4b3e39a9dd491a8a6996fce8ed0d05074ea920f5.tar.xz
openembedded-core-4b3e39a9dd491a8a6996fce8ed0d05074ea920f5.zip
qemu: Fix non-sdl/opengl build
Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-devtools/qemu/qemu-0.14.0')
-rw-r--r--meta/recipes-devtools/qemu/qemu-0.14.0/opengl-sdl-fix.patch41
1 files changed, 41 insertions, 0 deletions
diff --git a/meta/recipes-devtools/qemu/qemu-0.14.0/opengl-sdl-fix.patch b/meta/recipes-devtools/qemu/qemu-0.14.0/opengl-sdl-fix.patch
new file mode 100644
index 000000000..1f34f0775
--- /dev/null
+++ b/meta/recipes-devtools/qemu/qemu-0.14.0/opengl-sdl-fix.patch
@@ -0,0 +1,41 @@
+diff -u -r qemu-0.14.0/Makefile.target qemu-0.14.0-fixed/Makefile.target
+--- qemu-0.14.0/Makefile.target 2011-04-26 21:22:17.627637741 -0700
++++ qemu-0.14.0-fixed/Makefile.target 2011-04-26 21:23:02.767637747 -0700
+@@ -82,8 +82,10 @@
+ libobj-$(TARGET_I386) += helper_opengl.o opengl_exec.o
+ libobj-$(TARGET_X86_64) += helper_opengl.o opengl_exec.o
+ else
++ifdef CONFIG_SDL
+ libobj-$(TARGET_I386) += dummygl.o
+ libobj-$(TARGET_X86_64) += dummygl.o
++endif
+ endif #CONFIG_LINUX_USER
+ libobj-$(TARGET_ARM) += dummygl.o
+ libobj-$(TARGET_MIPS) += dummygl.o
+Only in qemu-0.14.0-fixed: config.log
+diff -u -r qemu-0.14.0/target-i386/helper.h qemu-0.14.0-fixed/target-i386/helper.h
+--- qemu-0.14.0/target-i386/helper.h 2011-04-26 21:22:11.418637742 -0700
++++ qemu-0.14.0-fixed/target-i386/helper.h 2011-04-26 21:23:02.539637747 -0700
+@@ -217,6 +217,9 @@
+ DEF_HELPER_2(rcrq, tl, tl, tl)
+ #endif
+
++#ifdef CONFIG_SDL
+ DEF_HELPER_0(opengl, void)
++#endif
++
+
+ #include "def-helper.h"
+diff -u -r qemu-0.14.0/target-i386/translate.c qemu-0.14.0-fixed/target-i386/translate.c
+--- qemu-0.14.0/target-i386/translate.c 2011-04-26 21:22:21.600637743 -0700
++++ qemu-0.14.0-fixed/target-i386/translate.c 2011-04-26 21:23:02.538637747 -0700
+@@ -2659,7 +2659,7 @@
+ static void gen_interrupt(DisasContext *s, int intno,
+ target_ulong cur_eip, target_ulong next_eip)
+ {
+-#if !defined(CONFIG_USER_ONLY)
++#if !defined(CONFIG_USER_ONLY) && defined(CONFIG_SDL)
+ if (enable_gl && intno == 0x99) {
+ gen_helper_opengl();
+ return;
+