summaryrefslogtreecommitdiff
path: root/meta/recipes-devtools/qemu/qemu-git/enable-i386-linux-user.patch
diff options
context:
space:
mode:
authorZhai Edwin <edwin.zhai@intel.com>2011-05-10 14:02:35 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-05-11 16:48:05 +0100
commit9b80846152931bed018f33baaaf1ba253e756867 (patch)
treec2e872e000182926bcb1d1f6445d1d2b74b06e6f /meta/recipes-devtools/qemu/qemu-git/enable-i386-linux-user.patch
parent7aca3963e9c326e07b58240c3e5c9e2cc6eaf99e (diff)
downloadopenembedded-core-9b80846152931bed018f33baaaf1ba253e756867.tar.gz
openembedded-core-9b80846152931bed018f33baaaf1ba253e756867.tar.bz2
openembedded-core-9b80846152931bed018f33baaaf1ba253e756867.tar.xz
openembedded-core-9b80846152931bed018f33baaaf1ba253e756867.zip
qemu: Upgrade qemu git to the latest 0.14 branch
Also add missing patch to build qemu-git [YOCTO #1013] got fixed Signed-off-by: Zhai Edwin <edwin.zhai@intel.com>
Diffstat (limited to 'meta/recipes-devtools/qemu/qemu-git/enable-i386-linux-user.patch')
-rw-r--r--meta/recipes-devtools/qemu/qemu-git/enable-i386-linux-user.patch53
1 files changed, 53 insertions, 0 deletions
diff --git a/meta/recipes-devtools/qemu/qemu-git/enable-i386-linux-user.patch b/meta/recipes-devtools/qemu/qemu-git/enable-i386-linux-user.patch
new file mode 100644
index 000000000..3cf0953f1
--- /dev/null
+++ b/meta/recipes-devtools/qemu/qemu-git/enable-i386-linux-user.patch
@@ -0,0 +1,53 @@
+Enable i386-linux-user
+
+Signed-off-by: Zhai Edwin <edwin.zhai@intel.com>
+
+Index: qemu-0.14.0/Makefile.target
+===================================================================
+--- qemu-0.14.0.orig/Makefile.target
++++ qemu-0.14.0/Makefile.target
+@@ -78,8 +78,13 @@ ifeq ($(TARGET_BASE_ARCH), i386)
+ libobj-y += cpuid.o
+ endif
+ libobj-$(CONFIG_NEED_MMU) += mmu.o
++ifndef CONFIG_LINUX_USER
+ libobj-$(TARGET_I386) += helper_opengl.o opengl_exec.o
+ libobj-$(TARGET_X86_64) += helper_opengl.o opengl_exec.o
++else
++libobj-$(TARGET_I386) += dummygl.o
++libobj-$(TARGET_X86_64) += dummygl.o
++endif #CONFIG_LINUX_USER
+ libobj-$(TARGET_ARM) += dummygl.o
+ libobj-$(TARGET_MIPS) += dummygl.o
+ libobj-$(TARGET_PPC) += dummygl.o
+Index: qemu-0.14.0/target-i386/dummygl.c
+===================================================================
+--- /dev/null
++++ qemu-0.14.0/target-i386/dummygl.c
+@@ -0,0 +1,26 @@
++#include <string.h>
++#include <stdlib.h>
++#include <assert.h>
++#include <stdint.h>
++#include <X11/Xlib.h>
++#include <X11/Xutil.h>
++
++void opengl_exec_set_parent_window(Display* _dpy, Window _parent_window)
++{
++
++}
++
++void opengl_process_enable(void)
++{
++
++}
++
++
++void mem_opengl(uint64_t ptr)
++{
++
++}
++
++void helper_opengl(void)
++{
++}