summaryrefslogtreecommitdiff
path: root/meta/recipes-devtools/subversion/subversion_1.6.13.bb
diff options
context:
space:
mode:
authorNitin A Kamble <nitin.a.kamble@intel.com>2010-11-18 14:52:03 -0800
committerRichard Purdie <rpurdie@linux.intel.com>2010-12-06 22:02:26 +0000
commitbc02b535edb2125a35230e74ffb4f26d91a766ca (patch)
tree59c76a5a0a0d7265984ac89c2109d803e741db83 /meta/recipes-devtools/subversion/subversion_1.6.13.bb
parentf20cb303aca07d83f510c00c74da3aeb9ef91c85 (diff)
downloadopenembedded-core-bc02b535edb2125a35230e74ffb4f26d91a766ca.tar.gz
openembedded-core-bc02b535edb2125a35230e74ffb4f26d91a766ca.tar.bz2
openembedded-core-bc02b535edb2125a35230e74ffb4f26d91a766ca.tar.xz
openembedded-core-bc02b535edb2125a35230e74ffb4f26d91a766ca.zip
subversion: upgrade from 1.5.5 to 1.6.13
And update recipe checksums rebased neon-detection.patch: upstream code has some of the changes similar to the changes in the patch. Removing the duplicate changes from the patch file. subversion: update LIC_CHKSUM_FILES field Noticed this change in the COPYING file: $ diff -u COPYING /tmp/COPYING --- COPYING 2006-05-28 07:41:18.000000000 -0700 +++ /tmp/COPYING 2010-12-03 11:16:15.000000000 -0800 @@ -10,7 +10,7 @@ on), you may use a newer version instead, at your option. ================================================================ -Copyright (c) 2000-2006 CollabNet. All rights reserved. +Copyright (c) 2000-2009 CollabNet. All rights reserved. Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com>
Diffstat (limited to 'meta/recipes-devtools/subversion/subversion_1.6.13.bb')
-rw-r--r--meta/recipes-devtools/subversion/subversion_1.6.13.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/meta/recipes-devtools/subversion/subversion_1.6.13.bb b/meta/recipes-devtools/subversion/subversion_1.6.13.bb
new file mode 100644
index 000000000..bcdb6c22e
--- /dev/null
+++ b/meta/recipes-devtools/subversion/subversion_1.6.13.bb
@@ -0,0 +1,35 @@
+DESCRIPTION = "The Subversion (svn) client"
+SECTION = "console/network"
+DEPENDS = "apr-util neon"
+RDEPENDS = "neon"
+LICENSE = "Apache BSD"
+HOMEPAGE = "http://subversion.tigris.org"
+
+PR = "r0"
+
+SRC_URI = "http://subversion.tigris.org/downloads/${P}.tar.bz2 \
+ file://disable-revision-install.patch;patch=1 \
+ file://neon-detection.patch;patch=1 \
+ file://libtool2.patch;patch=1"
+
+SRC_URI[md5sum] = "7ae1c827689f21cf975804005be30aeb"
+SRC_URI[sha256sum] = "3a30327bdb04109f369586196ee4a6993cdab2cfa85c3134549f02c229bf0d15"
+
+LIC_FILES_CHKSUM = "file://COPYING;md5=2a69fef414e2cb907b4544298569300b"
+
+EXTRA_OECONF = "--with-neon=${STAGING_EXECPREFIXDIR} \
+ --without-berkeley-db --without-apxs --without-apache \
+ --without-swig --with-apr=${STAGING_BINDIR_CROSS} \
+ --with-apr-util=${STAGING_BINDIR_CROSS}"
+
+inherit autotools
+
+export LDFLAGS += " -L${STAGING_LIBDIR} "
+
+acpaths = "-I build/ -I build/ac-macros/"
+
+do_configure_prepend () {
+ rm -f ${S}/libtool
+ rm -f ${S}/build/libtool.m4
+ sed -i -e 's:with_sasl="/usr/local":with_sasl="${STAGING_DIR}":' ${S}/build/ac-macros/sasl.m4
+}