summaryrefslogtreecommitdiff
path: root/meta/recipes-devtools/update-alternatives
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2011-11-14 17:43:45 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-11-15 11:54:43 +0000
commitfad496c759066d53bebf9b8cebc63e6478c91d19 (patch)
treedef0f70a9e752c741ad8b1da2284e80c8db98c6a /meta/recipes-devtools/update-alternatives
parent77ab0f09546c5f6217a8e2f1bc30cf3d4306e3fa (diff)
downloadopenembedded-core-fad496c759066d53bebf9b8cebc63e6478c91d19.tar.gz
openembedded-core-fad496c759066d53bebf9b8cebc63e6478c91d19.tar.bz2
openembedded-core-fad496c759066d53bebf9b8cebc63e6478c91d19.tar.xz
openembedded-core-fad496c759066d53bebf9b8cebc63e6478c91d19.zip
dpkg/update-alternatives: Fix dpkg version of update-alternatives to be usable
The version of dpkg the updates-alternatives-dpkg recipe pointed at no longer used a perl script but a compiled binary. This meant the "all" architecture field was invalid, as as the sed operation during do_patch. All things considered the separate recipe was pretty pointless. This patch moves update-alternatives back to being built as part of the dpkg recipe. It also moves various functionalty to the .inc file which it belongs and fixes building and packaging of the dpkg perl modules. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/update-alternatives')
-rw-r--r--meta/recipes-devtools/update-alternatives/update-alternatives-dpkg.inc43
-rw-r--r--meta/recipes-devtools/update-alternatives/update-alternatives-dpkg_1.16.0.3.bb8
2 files changed, 0 insertions, 51 deletions
diff --git a/meta/recipes-devtools/update-alternatives/update-alternatives-dpkg.inc b/meta/recipes-devtools/update-alternatives/update-alternatives-dpkg.inc
deleted file mode 100644
index c881ae021..000000000
--- a/meta/recipes-devtools/update-alternatives/update-alternatives-dpkg.inc
+++ /dev/null
@@ -1,43 +0,0 @@
-SUMMARY = "Manage alternatives"
-DESCRIPTION = "update-alternatives creates, removes, maintains and displays information about the symbolic links \
-comprising the Debian alternatives system. The Debian alternatives system attempts solve the problem of several \
-programs fulfilling the same or similar functions and how they can be installed onto a single system at the same \
-time."
-LICENSE = "GPL"
-SECTION = "base"
-SRC_URI = "${DEBIAN_MIRROR}/main/d/dpkg/dpkg_${PV}.tar.bz2"
-S = "${WORKDIR}/dpkg-${PV}"
-PACKAGE_ARCH = "all"
-INC_PR = "r3"
-
-inherit gettext
-
-do_patch () {
- cat ${S}/scripts/update-alternatives.pl | \
- sed -n -e '
- /^\$admindir=.*staging/{
- x
- s/^.*$/$D=$ENV{"D"} || ""\;/;
- p;
- x;
- s,^\$admindir=.*staging.*$,$admindir="$D${localstatedir}/lib/dpkg"\;,;
- };
- s,^\$altdir=.*$,$altdir="$D${sysconfdir}/alternatives"\;,;
- p;' > ${S}/scripts/update-alternatives
-}
-
-do_install () {
- install -d ${D}${sbindir} \
- ${D}${localstatedir}/lib/dpkg/alternatives \
- ${D}${sysconfdir}/alternatives
-
- install -m 0755 scripts/update-alternatives ${D}${sbindir}/update-alternatives
-}
-
-PROVIDES += "virtual/update-alternatives"
-RPROVIDES_${PN} += "update-alternatives"
-EXTRA_RDEPENDS = "perl dpkg"
-EXTRA_RDEPENDS_virtclass-native = ""
-RDEPENDS_${PN} += "${EXTRA_RDEPENDS}"
-
-BBCLASSEXTEND = "native"
diff --git a/meta/recipes-devtools/update-alternatives/update-alternatives-dpkg_1.16.0.3.bb b/meta/recipes-devtools/update-alternatives/update-alternatives-dpkg_1.16.0.3.bb
deleted file mode 100644
index f2931773b..000000000
--- a/meta/recipes-devtools/update-alternatives/update-alternatives-dpkg_1.16.0.3.bb
+++ /dev/null
@@ -1,8 +0,0 @@
-require update-alternatives-dpkg.inc
-
-PR = "${INC_PR}.0"
-
-LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
-
-SRC_URI[md5sum] = "0266b06ef9da8278cea008d21e17e5f6"
-SRC_URI[sha256sum] = "69669720020e67629d70aa5325e3c20c05cae7a9fc2d8abd442672c7b29e31d3"