summaryrefslogtreecommitdiff
path: root/meta/recipes-extended/at/at-3.1.12
diff options
context:
space:
mode:
authorNitin A Kamble <nitin.a.kamble@intel.com>2010-08-31 21:12:31 -0700
committerRichard Purdie <rpurdie@linux.intel.com>2010-09-02 09:50:49 +0100
commit2c54c5574eacabc4efe4069721dd83c1df8a65cb (patch)
tree6cefad8628fbcb10330e6f051ffd3f6e4471deb2 /meta/recipes-extended/at/at-3.1.12
parente384d62afaa17f8cd2124cb0785b18130c690e64 (diff)
downloadopenembedded-core-2c54c5574eacabc4efe4069721dd83c1df8a65cb.tar.gz
openembedded-core-2c54c5574eacabc4efe4069721dd83c1df8a65cb.tar.bz2
openembedded-core-2c54c5574eacabc4efe4069721dd83c1df8a65cb.tar.xz
openembedded-core-2c54c5574eacabc4efe4069721dd83c1df8a65cb.zip
at: gplv2 recipe at version 3.1.12
Took the 3.1.10.2 version of the gplv2 recipe from the master branch, and upgraded it to 3.1.12 version and then replaced the gplv3 files viz posixtm.[ch] by gplv2 files to make the recipe gplv2. Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com>
Diffstat (limited to 'meta/recipes-extended/at/at-3.1.12')
-rw-r--r--meta/recipes-extended/at/at-3.1.12/configure.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta/recipes-extended/at/at-3.1.12/configure.patch b/meta/recipes-extended/at/at-3.1.12/configure.patch
new file mode 100644
index 000000000..2458ef357
--- /dev/null
+++ b/meta/recipes-extended/at/at-3.1.12/configure.patch
@@ -0,0 +1,24 @@
+# Fix cross-compilation issues in configure.ac
+# Derived from an OE patch for at-3.1.8
+
+Index: at-3.1.12/configure.ac
+===================================================================
+--- at-3.1.12.orig/configure.ac
++++ at-3.1.12/configure.ac
+@@ -38,12 +38,11 @@ case "$host" in
+ AC_MSG_RESULT(no)
+ ;;
+ esac
++if [ X"${cross_compiling}" = Xno ]; then
+ AC_MSG_CHECKING(Trying to compile a trivial ANSI C program)
+-AC_TRY_RUN([ main(int ac, char **av) { return 0; } ],
+- AC_MSG_RESULT(yes),
+- AC_MSG_RESULT(no)
+- AC_MSG_ERROR(Could not compile and run even a trivial ANSI C program - check CC.),
+- AC_MSG_ERROR(Could not compile and run even a trivial ANSI C program - check CC.))
++AC_RUN_IFELSE([AC_LANG_SOURCE([[ main(int ac, char **av) { return 0; } ]])],[AC_MSG_RESULT(yes)],[AC_MSG_RESULT(no)
++ AC_MSG_ERROR(Could not compile and run even a trivial ANSI C program - check CC.)],[AC_MSG_ERROR(Could not compile and run even a trivial ANSI C program - check CC.)])
++fi
+
+ AC_MSG_CHECKING(__attribute__((noreturn)))
+ AC_TRY_COMPILE([], [void __attribute__((noreturn)) panic(void);],