summaryrefslogtreecommitdiff
path: root/meta/recipes-extended/at/at-3.1.12
diff options
context:
space:
mode:
authorWenzong Fan <wenzong.fan@windriver.com>2011-07-20 10:29:22 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-07-27 11:54:51 +0100
commiteabf5a639c94a016316bfd6707ee6e5bd676d85d (patch)
treedbebe117a0b08dbc4201c616b1818dea00bf4e8c /meta/recipes-extended/at/at-3.1.12
parent10e6fdd7e8fed5733f65a504148bba54bccb3c48 (diff)
downloadopenembedded-core-eabf5a639c94a016316bfd6707ee6e5bd676d85d.tar.gz
openembedded-core-eabf5a639c94a016316bfd6707ee6e5bd676d85d.tar.bz2
openembedded-core-eabf5a639c94a016316bfd6707ee6e5bd676d85d.tar.xz
openembedded-core-eabf5a639c94a016316bfd6707ee6e5bd676d85d.zip
at: enable pam support
add patches to make at enable pam support Signed-off-by: Wenzong Fan <wenzong.fan@windriver.com>
Diffstat (limited to 'meta/recipes-extended/at/at-3.1.12')
-rw-r--r--meta/recipes-extended/at/at-3.1.12/configure-add-enable-pam.patch23
-rw-r--r--meta/recipes-extended/at/at-3.1.12/pam.conf.patch21
2 files changed, 44 insertions, 0 deletions
diff --git a/meta/recipes-extended/at/at-3.1.12/configure-add-enable-pam.patch b/meta/recipes-extended/at/at-3.1.12/configure-add-enable-pam.patch
new file mode 100644
index 000000000..1f73cdd07
--- /dev/null
+++ b/meta/recipes-extended/at/at-3.1.12/configure-add-enable-pam.patch
@@ -0,0 +1,23 @@
+--- at-3.1.12/configure.ac 2011-06-23 14:51:03.653572945 +0800
++++ at-3.1.12/configure.ac.new 2011-06-27 16:12:14.903572945 +0800
+@@ -81,10 +81,18 @@
+ AC_FUNC_VPRINTF
+ AC_FUNC_GETLOADAVG
+ AC_CHECK_FUNCS(getcwd mktime strftime setreuid setresuid sigaction waitpid)
++
++AC_ARG_WITH([pam],
++ [AS_HELP_STRING([--without-pam], [without PAM support])])
++
++if test "x$with_pam" != xno; then
+ AC_CHECK_HEADERS(security/pam_appl.h, [
+ PAMLIB="-lpam"
+- AC_DEFINE(HAVE_PAM, 1, [Define to 1 for PAM support])
+-])
++ AC_DEFINE(HAVE_PAM, 1, [Define to 1 for PAM support])],
++ [if test "x$with_pam" = xyes; then
++ AC_MSG_ERROR([PAM selected but security/pam_misc.h not found])
++ fi])
++fi
+
+ dnl Checking for programs
+
diff --git a/meta/recipes-extended/at/at-3.1.12/pam.conf.patch b/meta/recipes-extended/at/at-3.1.12/pam.conf.patch
new file mode 100644
index 000000000..dfe76d748
--- /dev/null
+++ b/meta/recipes-extended/at/at-3.1.12/pam.conf.patch
@@ -0,0 +1,21 @@
+oe doesn't support "@include", use the concrete directive instead.
+
+Upstream-Status: Pending
+
+Signed-off-by: Wenzong Fan <wenzong.fan@windriver.com>
+--- at-3.1.12/pam.conf.orig 2009-11-23 23:11:52.000000000 +0800
++++ at-3.1.12/pam.conf 2011-07-15 11:14:04.132818950 +0800
+@@ -2,8 +2,8 @@
+ # The PAM configuration file for the at daemon
+ #
+
+-auth required pam_env.so
+-@include common-auth
+-@include common-account
+-@include common-session-noninteractive
+-session required pam_limits.so
++auth required pam_env.so
++auth include common-auth
++account include common-account
++session include common-session-noninteractive
++session required pam_limits.so