summaryrefslogtreecommitdiff
path: root/meta/recipes-extended/at/at_3.1.12.bb
diff options
context:
space:
mode:
authorNitin A Kamble <nitin.a.kamble@intel.com>2010-09-02 10:04:19 -0700
committerRichard Purdie <rpurdie@linux.intel.com>2010-09-02 22:17:11 +0100
commit2eeb0943ac5b3d8f942ae7f9cf655c12827483ae (patch)
treea9851783ca24013d11b34c76d8f0bf73cf1840eb /meta/recipes-extended/at/at_3.1.12.bb
parent558ef570975f6f83a1878a41ecd984ef07a1a443 (diff)
downloadopenembedded-core-2eeb0943ac5b3d8f942ae7f9cf655c12827483ae.tar.gz
openembedded-core-2eeb0943ac5b3d8f942ae7f9cf655c12827483ae.tar.bz2
openembedded-core-2eeb0943ac5b3d8f942ae7f9cf655c12827483ae.tar.xz
openembedded-core-2eeb0943ac5b3d8f942ae7f9cf655c12827483ae.zip
at: fix for parallel build issue & bug #180
parallel build was failing inconsistently due to missing dependancy specification in the make file. Fixed it with a new patch. Bug 180 reported this issue: | arm-poky-linux-gnueabi-gcc -march=armv5te -mtune=arm926ej-s -c -I. -fexpensive-optimizations -fomit-frame-pointer -frename-registers -O2 -ggdb -feliminate-unused-debug-types -DHAVE_CONFIG_H -DVERSION=\"3.1.12\" -DETCDIR=\"/etc\" -DLOADAVG_MX=0.8 -DDAEMON_USERNAME=\"daemon\" -DDAEMON_GROUPNAME=\"daemon\" -DLFILE=\"/var/spool/cron/atjobs/.SEQ\" -Wall atd.c | atd.c:511:2: error: #error "No mail command specified." | make: *** [atd.o] Error 1 Fixed it with the recommended solution of defining SENDMAIL as /bin/true Fixes [BUGID #180] Reorganized the recipe file for cleanlyness. Add the init script for at As per Scott's wiki instructions added the this init script for at: http://git.buildroot.net/buildroot/tree/package/at/S99at add libpam to dependancy And bumped PR. Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com>
Diffstat (limited to 'meta/recipes-extended/at/at_3.1.12.bb')
-rw-r--r--meta/recipes-extended/at/at_3.1.12.bb32
1 files changed, 26 insertions, 6 deletions
diff --git a/meta/recipes-extended/at/at_3.1.12.bb b/meta/recipes-extended/at/at_3.1.12.bb
index 605179b21..bec09b695 100644
--- a/meta/recipes-extended/at/at_3.1.12.bb
+++ b/meta/recipes-extended/at/at_3.1.12.bb
@@ -1,19 +1,39 @@
-require at.inc
-
+DESCRIPTION = "Delayed job execution and batch processing"
+SECTION = "base"
LICENSE="GPLv2+"
LIC_FILES_CHKSUM = "file://COPYING;md5=4325afd396febcb659c36b49533135d4"
-
-PR = "r1"
+DEPENDS = "flex libpam initscripts"
+RCONFLICTS_${PN} = "atd"
+RREPLACES_${PN} = "atd"
+PR = "r2"
SRC_URI = "${DEBIAN_MIRROR}/main/a/at/at_${PV}.orig.tar.gz \
file://configure.patch \
file://nonrootinstall.patch \
file://use-ldflags.patch \
+ file://fix_parallel_build_error.patch \
file://posixtm.c \
file://posixtm.h \
- file://file_replacement_with_gplv2.patch"
+ file://file_replacement_with_gplv2.patch \
+ file://S99at"
+
+EXTRA_OECONF += "ac_cv_path_SENDMAIL=/bin/true \
+ --with-daemon_username=root \
+ --with-daemon_groupname=root \
+ --with-jobdir=/var/spool/cron/atjobs \
+ --with-atspool=/var/spool/cron/atspool"
+
+inherit autotools
do_compile_prepend () {
- mv ${WORKDIR}/posixtm.[ch] ${S}
+ cp -f ${WORKDIR}/posixtm.[ch] ${S}
}
+do_install () {
+ oe_runmake "IROOT=${D}" install
+
+ install -d ${D}${sysconfdir}/init.d
+ install -d ${D}${sysconfdir}/rcS.d
+ install -m 0755 ${WORKDIR}/S99at ${D}${sysconfdir}/init.d/at
+ ln -sf ../init.d/at ${D}${sysconfdir}/rcS.d/S99at
+}