summaryrefslogtreecommitdiff
path: root/meta/recipes-extended/at/files/configure.patch
diff options
context:
space:
mode:
authorScott Garman <scott.a.garman@intel.com>2012-03-14 16:39:08 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-03-19 13:36:53 +0000
commit768eb8e8590e3b9cc033d8544a01ae34d3ed16b1 (patch)
treea79cf8f811dbf6a267d9a02a748721378cd8cfa8 /meta/recipes-extended/at/files/configure.patch
parent4bdd31625ba9d4f9f0e9dc7775ad650d53dd221a (diff)
downloadopenembedded-core-768eb8e8590e3b9cc033d8544a01ae34d3ed16b1.tar.gz
openembedded-core-768eb8e8590e3b9cc033d8544a01ae34d3ed16b1.tar.bz2
openembedded-core-768eb8e8590e3b9cc033d8544a01ae34d3ed16b1.tar.xz
openembedded-core-768eb8e8590e3b9cc033d8544a01ae34d3ed16b1.zip
at: upgrade to 3.1.13
Moved patches into a common directory. Added SOB to use-ldflags.patch. Removed nonstripbinaries patch which was included in this release. Minor formatting cleanups. Signed-off-by: Scott Garman <scott.a.garman@intel.com>
Diffstat (limited to 'meta/recipes-extended/at/files/configure.patch')
-rw-r--r--meta/recipes-extended/at/files/configure.patch29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta/recipes-extended/at/files/configure.patch b/meta/recipes-extended/at/files/configure.patch
new file mode 100644
index 000000000..14310e335
--- /dev/null
+++ b/meta/recipes-extended/at/files/configure.patch
@@ -0,0 +1,29 @@
+
+Fix cross-compilation issues in configure.ac
+Derived from an OE patch for at-3.1.8
+
+Upstream-Status: Pending
+
+Signed-off-by: Scott Garman <scott.a.garman@intel.com>
+
+Index: at-3.1.12/configure.ac
+===================================================================
+--- at-3.1.12.orig/configure.ac
++++ at-3.1.12/configure.ac
+@@ -38,12 +38,11 @@ case "$host" in
+ AC_MSG_RESULT(no)
+ ;;
+ esac
++if [ X"${cross_compiling}" = Xno ]; then
+ AC_MSG_CHECKING(Trying to compile a trivial ANSI C program)
+-AC_TRY_RUN([ main(int ac, char **av) { return 0; } ],
+- AC_MSG_RESULT(yes),
+- AC_MSG_RESULT(no)
+- AC_MSG_ERROR(Could not compile and run even a trivial ANSI C program - check CC.),
+- AC_MSG_ERROR(Could not compile and run even a trivial ANSI C program - check CC.))
++AC_RUN_IFELSE([AC_LANG_SOURCE([[ main(int ac, char **av) { return 0; } ]])],[AC_MSG_RESULT(yes)],[AC_MSG_RESULT(no)
++ AC_MSG_ERROR(Could not compile and run even a trivial ANSI C program - check CC.)],[AC_MSG_ERROR(Could not compile and run even a trivial ANSI C program - check CC.)])
++fi
+
+ AC_MSG_CHECKING(__attribute__((noreturn)))
+ AC_TRY_COMPILE([], [void __attribute__((noreturn)) panic(void);],