summaryrefslogtreecommitdiff
path: root/meta/recipes-extended/procps/procps_3.2.8.bb
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2011-09-21 10:19:42 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-09-22 03:11:30 +0100
commit80650bf4bce83e4e8d785e9a69eac0abbcdc6844 (patch)
tree9b6ac21a02126505aa8c40d0cf8c730b7542ff1b /meta/recipes-extended/procps/procps_3.2.8.bb
parentd86acde7c6c57bd848feb1875c10df9b1de1201d (diff)
downloadopenembedded-core-80650bf4bce83e4e8d785e9a69eac0abbcdc6844.tar.gz
openembedded-core-80650bf4bce83e4e8d785e9a69eac0abbcdc6844.tar.bz2
openembedded-core-80650bf4bce83e4e8d785e9a69eac0abbcdc6844.tar.xz
openembedded-core-80650bf4bce83e4e8d785e9a69eac0abbcdc6844.zip
procps 3.2.8: remove initscript
Sysctl is managed by other initscripts in the sysV world and by systemd itself in the systemd world, so drop it from the procps recipe. This also fixes some style issues and a global FILES assignenment. Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta/recipes-extended/procps/procps_3.2.8.bb')
-rw-r--r--meta/recipes-extended/procps/procps_3.2.8.bb27
1 files changed, 8 insertions, 19 deletions
diff --git a/meta/recipes-extended/procps/procps_3.2.8.bb b/meta/recipes-extended/procps/procps_3.2.8.bb
index a38077eae..d989955f6 100644
--- a/meta/recipes-extended/procps/procps_3.2.8.bb
+++ b/meta/recipes-extended/procps/procps_3.2.8.bb
@@ -1,11 +1,8 @@
require procps.inc
-PR = "r2"
+PR = "r3"
-inherit update-rc.d update-alternatives
-
-INITSCRIPT_NAME = "procps.sh"
-INITSCRIPT_PARAMS = "start 30 S ."
+inherit update-alternatives
ALTERNATIVE_LINKS = "${bindir}/top ${bindir}/uptime ${bindir}/free ${bindir}/pkill ${bindir}/pmap \
${base_bindir}/kill ${base_sbindir}/sysctl ${base_bindir}/ps"
@@ -13,22 +10,14 @@ ALTERNATIVE_PRIORITY = "90"
SRC_URI += "file://procmodule.patch \
file://psmodule.patch \
- file://linux-limits.patch \
- file://sysctl.conf \
- file://procps.init \
- file://procps-3.2.8+gmake-3.82.patch \
- "
+ file://linux-limits.patch \
+ file://sysctl.conf \
+ file://procps-3.2.8+gmake-3.82.patch \
+ "
SRC_URI[md5sum] = "9532714b6846013ca9898984ba4cd7e0"
SRC_URI[sha256sum] = "11ed68d8a4433b91cd833deb714a3aa849c02aea738c42e6b4557982419c1535"
-FILES = "${bindir}/top.${BPN} ${base_bindir}/ps.${BPN} ${bindir}/uptime.${BPN} ${base_bindir}/kill.${BPN} \
- ${bindir}/free.${BPN} ${bindir}/w ${bindir}/watch ${bindir}/pgrep ${bindir}/pmap ${bindir}/pwdx \
- ${bindir}/snice ${bindir}/vmstat ${bindir}/slabtop ${bindir}/pkill ${bindir}/skill ${bindir}/tload \
- ${base_sbindir}/sysctl.${BPN}"
-
-CONFFILES_${PN} = "${sysconfdir}/sysctl.conf"
-
EXTRA_OEMAKE = "CFLAGS=-I${STAGING_INCDIR} \
CPPFLAGS=-I${STAGING_INCDIR} \
LDFLAGS="${LDFLAGS}" \
@@ -39,6 +28,6 @@ EXTRA_OEMAKE = "CFLAGS=-I${STAGING_INCDIR} \
do_install_append () {
install -d ${D}${sysconfdir}
install -m 0644 ${WORKDIR}/sysctl.conf ${D}${sysconfdir}/sysctl.conf
- install -d ${D}${sysconfdir}/init.d
- install -m 0755 ${WORKDIR}/procps.init ${D}${sysconfdir}/init.d/procps.sh
}
+
+CONFFILES_${PN} = "${sysconfdir}/sysctl.conf"