summaryrefslogtreecommitdiff
path: root/meta/recipes-extended/sat-solver/sat-solver
diff options
context:
space:
mode:
authorQing He <qing.he@intel.com>2011-03-10 18:28:55 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-03-14 20:45:42 +0000
commitca758fa404fa447689ff205ee3b4b76bd3f1068a (patch)
tree41f07bc74d6823e741b4816d107fb33311c530a7 /meta/recipes-extended/sat-solver/sat-solver
parent2956705bb0dad88b5ad7d42490c345ccb1d9d478 (diff)
downloadopenembedded-core-ca758fa404fa447689ff205ee3b4b76bd3f1068a.tar.gz
openembedded-core-ca758fa404fa447689ff205ee3b4b76bd3f1068a.tar.bz2
openembedded-core-ca758fa404fa447689ff205ee3b4b76bd3f1068a.tar.xz
openembedded-core-ca758fa404fa447689ff205ee3b4b76bd3f1068a.zip
sat-solver: add machine arch support
Signed-off-by: Qing He <qing.he@intel.com>
Diffstat (limited to 'meta/recipes-extended/sat-solver/sat-solver')
-rw-r--r--meta/recipes-extended/sat-solver/sat-solver/builtin-arch.patch28
-rw-r--r--meta/recipes-extended/sat-solver/sat-solver/no-builtin-arch.patch29
2 files changed, 57 insertions, 0 deletions
diff --git a/meta/recipes-extended/sat-solver/sat-solver/builtin-arch.patch b/meta/recipes-extended/sat-solver/sat-solver/builtin-arch.patch
new file mode 100644
index 000000000..c228c36e4
--- /dev/null
+++ b/meta/recipes-extended/sat-solver/sat-solver/builtin-arch.patch
@@ -0,0 +1,28 @@
+This patch adds the ${MACHINE_ARCH} and ${PACKAGE_ARCH} to
+sat-solver available archs, see do_archpatch in .bb for more
+details, this is the version for ${BASE_PACKAGE_ARCH} already
+recognized in sat-sovler.
+
+Signed-off-by: Qing He <qing.he@intel.com>
+
+diff --git a/src/poolarch.c b/src/poolarch.c
+index 34a14a3..660959b 100644
+--- a/src/poolarch.c
++++ b/src/poolarch.c
+@@ -21,6 +21,7 @@
+ #include "util.h"
+
+ const char *archpolicies[] = {
++ "@MACHINE_ARCH@", "@MACHINE_ARCH@:@PKG_ARCH_TAIL@",
+ "x86_64", "x86_64:i686:i586:i486:i386",
+ "i686", "i686:i586:i486:i386",
+ "i586", "i586:i486:i386",
+@@ -72,7 +74,7 @@ pool_setarch(Pool *pool, const char *arch)
+ return;
+ }
+ #ifndef DEBIAN_SEMANTICS
+- id = ARCH_NOARCH;
++ id = ARCH_ALL;
+ #else
+ id = ARCH_ALL;
+ #endif
diff --git a/meta/recipes-extended/sat-solver/sat-solver/no-builtin-arch.patch b/meta/recipes-extended/sat-solver/sat-solver/no-builtin-arch.patch
new file mode 100644
index 000000000..225fbfe15
--- /dev/null
+++ b/meta/recipes-extended/sat-solver/sat-solver/no-builtin-arch.patch
@@ -0,0 +1,29 @@
+This patch adds the ${MACHINE_ARCH} and ${PACKAGE_ARCH} to
+sat-solver available archs, see do_archpatch in .bb for more
+details, this is the version for ${BASE_PACKAGE_ARCH} not
+recognized in sat-sovler.
+
+Signed-off-by: Qing He <qing.he@intel.com>
+
+diff --git a/src/poolarch.c b/src/poolarch.c
+index 34a14a3..36367ba 100644
+--- a/src/poolarch.c
++++ b/src/poolarch.c
+@@ -21,6 +21,8 @@
+ #include "util.h"
+
+ const char *archpolicies[] = {
++ "@MACHINE_ARCH@", "@MACHINE_ARCH@:@PKG_ARCH@",
++ "@PKG_ARCH@", "@PKG_ARCH@",
+ "x86_64", "x86_64:i686:i586:i486:i386",
+ "i686", "i686:i586:i486:i386",
+ "i586", "i586:i486:i386",
+@@ -72,7 +74,7 @@ pool_setarch(Pool *pool, const char *arch)
+ return;
+ }
+ #ifndef DEBIAN_SEMANTICS
+- id = ARCH_NOARCH;
++ id = ARCH_ALL;
+ #else
+ id = ARCH_ALL;
+ #endif