summaryrefslogtreecommitdiff
path: root/meta/recipes-extended/sat-solver/sat-solver_git.bb
diff options
context:
space:
mode:
authorQing He <qing.he@intel.com>2011-04-13 16:59:22 +0800
committerSaul Wold <sgw@linux.intel.com>2011-04-26 23:51:24 -0700
commitbd0798120559a8aca726db8e962bbbafb80c2a54 (patch)
tree236a998e488ade177dfd254fac0337cce2609400 /meta/recipes-extended/sat-solver/sat-solver_git.bb
parent2d19f07fa5b1021c4210b28a2d6225e50c721580 (diff)
downloadopenembedded-core-bd0798120559a8aca726db8e962bbbafb80c2a54.tar.gz
openembedded-core-bd0798120559a8aca726db8e962bbbafb80c2a54.tar.bz2
openembedded-core-bd0798120559a8aca726db8e962bbbafb80c2a54.tar.xz
openembedded-core-bd0798120559a8aca726db8e962bbbafb80c2a54.zip
sat-solver: fix arch=all packages
add a new options to set noarch archs as all so platform independent packages can be recognized and installed. fixes [YOCTO #993] Signed-off-by: Qing He <qing.he@intel.com>
Diffstat (limited to 'meta/recipes-extended/sat-solver/sat-solver_git.bb')
-rw-r--r--meta/recipes-extended/sat-solver/sat-solver_git.bb16
1 files changed, 8 insertions, 8 deletions
diff --git a/meta/recipes-extended/sat-solver/sat-solver_git.bb b/meta/recipes-extended/sat-solver/sat-solver_git.bb
index a6937763c..2d4d29932 100644
--- a/meta/recipes-extended/sat-solver/sat-solver_git.bb
+++ b/meta/recipes-extended/sat-solver/sat-solver_git.bb
@@ -7,19 +7,19 @@ LIC_FILES_CHKSUM = "file://LICENSE.BSD;md5=62272bd11c97396d4aaf1c41bc11f7d8"
DEPENDS = "libcheck rpm zlib expat db"
PV = "0.0-git${SRCPV}"
-PR = "r8"
+PR = "r9"
SRC_URI = "git://gitorious.org/opensuse/sat-solver.git;protocol=git \
file://sat-solver_rpm5.patch \
file://sat-solver_obsolete.patch \
file://cmake.patch \
file://db5.patch \
- file://sat-solver_poky.patch \
+ file://sat-solver_core.patch \
"
S = "${WORKDIR}/git"
-EXTRA_OECMAKE += "-DLIB=lib -DRPM5=RPM5"
+EXTRA_OECMAKE += "-DLIB=lib -DRPM5=RPM5 -DOE_CORE=OE_CORE"
inherit cmake pkgconfig
@@ -38,18 +38,18 @@ do_archgen () {
INSTALL_PLATFORM_ARCHS="$each_arch $INSTALL_PLATFORM_ARCHS"
done
- echo "/* Automatically generated by the sat-solver recipe */" > src/poky-arch.h
- echo "const char *archpolicies[] = {" >> src/poky-arch.h
+ echo "/* Automatically generated by the sat-solver recipe */" > src/core-arch.h
+ echo "const char *archpolicies[] = {" >> src/core-arch.h
set -- $INSTALL_PLATFORM_ARCHS
save_IFS=$IFS
IFS=:
- while [ $# -gt 0 ]; do echo " \"$1\", "\""$*"\", >> src/poky-arch.h ; shift; done
+ while [ $# -gt 0 ]; do echo " \"$1\", "\""$*"\", >> src/core-arch.h ; shift; done
IFS=$save_IFS
- echo " 0" >> src/poky-arch.h
- echo "};" >> src/poky-arch.h
+ echo " 0" >> src/core-arch.h
+ echo "};" >> src/core-arch.h
}
addtask archgen before do_configure after do_patch