summaryrefslogtreecommitdiff
path: root/meta/recipes-extended/texinfo/texinfo_4.13a.bb
diff options
context:
space:
mode:
authorSaul Wold <sgw@linux.intel.com>2011-12-10 12:22:38 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-12-12 21:50:07 +0000
commit9fa98de54a73465f06484ba863eccf1e07cc1e2a (patch)
tree9db898113c766a450edea17fcd997be60d6d92dd /meta/recipes-extended/texinfo/texinfo_4.13a.bb
parent8899f4840787ef043d952f8ea2ce5d78e5cc41ab (diff)
downloadopenembedded-core-9fa98de54a73465f06484ba863eccf1e07cc1e2a.tar.gz
openembedded-core-9fa98de54a73465f06484ba863eccf1e07cc1e2a.tar.bz2
openembedded-core-9fa98de54a73465f06484ba863eccf1e07cc1e2a.tar.xz
openembedded-core-9fa98de54a73465f06484ba863eccf1e07cc1e2a.zip
texinfo: fix compile failure due target makedoc binary being used
Need to have the texinfo-native build and install a host sysroot makedoc binary and then patch the target build to use this binary. This requires that we don't ASSUME_PROVIDED texinfo-native any longer since we need to install this makedoc tool which is not part of the normal distrubtion. [YOCTO #1664] Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-extended/texinfo/texinfo_4.13a.bb')
-rw-r--r--meta/recipes-extended/texinfo/texinfo_4.13a.bb11
1 files changed, 9 insertions, 2 deletions
diff --git a/meta/recipes-extended/texinfo/texinfo_4.13a.bb b/meta/recipes-extended/texinfo/texinfo_4.13a.bb
index 9f1c04ace..f205d4e04 100644
--- a/meta/recipes-extended/texinfo/texinfo_4.13a.bb
+++ b/meta/recipes-extended/texinfo/texinfo_4.13a.bb
@@ -6,11 +6,14 @@ HOMEPAGE = "http://www.gnu.org/software/texinfo/"
SECTION = "console/utils"
LICENSE = "GPLv3+"
LIC_FILES_CHKSUM = "file://COPYING;md5=adefda309052235aa5d1e99ce7557010"
-PR = "r1"
+PR = "r2"
DEPENDS = "zlib ncurses texinfo-native"
DEPENDS_virtclass-native = "zlib-native ncurses-native"
+TARGET_PATCH = "file://use_host_makedoc.patch"
+TARGET_PATCH_virtclass-native = ""
+
SRC_URI = "${GNU_MIRROR}/texinfo/texinfo-${PV}.tar.gz \
file://texinfo-4.12-zlib.patch \
file://texinfo-4.13a-data_types.patch \
@@ -19,7 +22,8 @@ SRC_URI = "${GNU_MIRROR}/texinfo/texinfo-${PV}.tar.gz \
file://texinfo-4.13a-help-index-segfault.patch \
file://disable-native-tools.patch \
file://link-zip.patch \
- file://gettext-macros.patch"
+ file://gettext-macros.patch \
+ ${TARGET_PATCH}"
SRC_URI[md5sum] = "71ba711519209b5fb583fed2b3d86fcb"
SRC_URI[sha256sum] = "1303e91a1c752b69a32666a407e9fbdd6e936def4b09bc7de30f416301530d68"
@@ -39,6 +43,9 @@ do_install_append() {
mkdir -p ${D}${datadir}/${tex_texinfo}
install -p -m644 doc/texinfo.tex doc/txi-??.tex ${D}${datadir}/${tex_texinfo}
}
+do_install_append_virtclass-native() {
+ install -m 755 info/makedoc ${D}${bindir}
+}
PACKAGES += "info info-doc"