summaryrefslogtreecommitdiff
path: root/meta/recipes-graphics/clutter/clutter-box2d/fix-disable-introspection.patch
diff options
context:
space:
mode:
authorJoshua Lock <josh@linux.intel.com>2011-03-28 13:14:37 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-03-29 14:09:36 +0100
commit8d26abb57e901f58b5c8782c110c52a437accb51 (patch)
treecaf109ead977eedc2d0ba46603ccfaeece6a75a8 /meta/recipes-graphics/clutter/clutter-box2d/fix-disable-introspection.patch
parent9768214eef2d6d8ad37a535877cae1eb0f044c2b (diff)
downloadopenembedded-core-8d26abb57e901f58b5c8782c110c52a437accb51.tar.gz
openembedded-core-8d26abb57e901f58b5c8782c110c52a437accb51.tar.bz2
openembedded-core-8d26abb57e901f58b5c8782c110c52a437accb51.tar.xz
openembedded-core-8d26abb57e901f58b5c8782c110c52a437accb51.zip
clutter-box2d: add version 0.10.0 for use with clutter 1.6
Don't specificy dependant clutter version in inc file, this enables the inc file to be re-used accross Clutter versions. Signed-off-by: Joshua Lock <josh@linux.intel.com>
Diffstat (limited to 'meta/recipes-graphics/clutter/clutter-box2d/fix-disable-introspection.patch')
-rw-r--r--meta/recipes-graphics/clutter/clutter-box2d/fix-disable-introspection.patch28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta/recipes-graphics/clutter/clutter-box2d/fix-disable-introspection.patch b/meta/recipes-graphics/clutter/clutter-box2d/fix-disable-introspection.patch
new file mode 100644
index 000000000..cfb50dc70
--- /dev/null
+++ b/meta/recipes-graphics/clutter/clutter-box2d/fix-disable-introspection.patch
@@ -0,0 +1,28 @@
+Even with introspection disabled clutter-box2d would try to install the gir
+files.
+This patch ignored the while introspection related section of the Makefile if
+introspection is disabled.
+
+JL 28/03/11
+josh@linux.intel.com
+
+Index: clutter-box2d-0.10.0/clutter-box2d/Makefile.am
+===================================================================
+--- clutter-box2d-0.10.0.orig/clutter-box2d/Makefile.am
++++ clutter-box2d-0.10.0/clutter-box2d/Makefile.am
+@@ -41,6 +41,8 @@ EXTRA_DIST = \
+
+ BUILT_GIRSOURCES =
+
++if HAVE_INTROSPECTION
++
+ ClutterBox2D-@CLUTTER_BOX2D_API_VERSION@.gir: $(INTROSPECTION_SCANNER) libclutter-box2d-@CLUTTER_BOX2D_API_VERSION@.la
+ $(QUIET_GEN)$(INTROSPECTION_SCANNER) -v \
+ --namespace ClutterBox2D --nsversion=@CLUTTER_BOX2D_API_VERSION@ \
+@@ -70,3 +72,5 @@ typelibs_DATA = $(BUILT_GIRSOURCES:.gir=
+
+ CLEANFILES=
+ CLEANFILES += $(BUILT_GIRSOURCES) $(typelibs_DATA)
++
++endif
+\ No newline at end of file