summaryrefslogtreecommitdiff
path: root/meta/recipes-graphics/mesa/mesa-xlib_7.11.bb
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2011-10-12 22:51:33 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-10-12 22:58:28 +0100
commitb2252d16b46bc18ff0aa06efaf58dd337682f587 (patch)
tree520c7d774d5dddb579a6bf6dbd3f5d605d04c873 /meta/recipes-graphics/mesa/mesa-xlib_7.11.bb
parent72c010af2c0fe967a5cacc7fbdba75c3ea3e5c3a (diff)
downloadopenembedded-core-b2252d16b46bc18ff0aa06efaf58dd337682f587.tar.gz
openembedded-core-b2252d16b46bc18ff0aa06efaf58dd337682f587.tar.bz2
openembedded-core-b2252d16b46bc18ff0aa06efaf58dd337682f587.tar.xz
openembedded-core-b2252d16b46bc18ff0aa06efaf58dd337682f587.zip
mesa: Update 7.8.2 -> 7.11
Pieces of this taken from patches from Martin Jansa <martin.jansa@gmail.com> and likely from meta-oe. It includes just enough changes to get the newer version to build. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics/mesa/mesa-xlib_7.11.bb')
-rw-r--r--meta/recipes-graphics/mesa/mesa-xlib_7.11.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta/recipes-graphics/mesa/mesa-xlib_7.11.bb b/meta/recipes-graphics/mesa/mesa-xlib_7.11.bb
new file mode 100644
index 000000000..ea4acc629
--- /dev/null
+++ b/meta/recipes-graphics/mesa/mesa-xlib_7.11.bb
@@ -0,0 +1,30 @@
+include mesa-common.inc
+
+FILESPATH =. "${FILE_DIRNAME}/mesa-dri:"
+
+SRC_URI = "ftp://ftp.freedesktop.org/pub/mesa/${PV}/MesaLib-${PV}.tar.bz2 \
+ file://uclibc.patch \
+ "
+
+SRC_URI[md5sum] = "ff03aca82d0560009a076a87c888cf13"
+SRC_URI[sha256sum] = "f8bf37a00882840a3e3d327576bc26a79ae7f4e18fe1f7d5f17a5b1c80dd7acf"
+
+LIC_FILES_CHKSUM = "file://docs/license.html;md5=7a3373c039b6b925c427755a4f779c1d"
+
+PROTO_DEPS = "xf86driproto glproto"
+LIB_DEPS = "virtual/libx11 libxext libxxf86vm libxdamage libxfixes libxml2-native"
+
+DEPENDS = "${PROTO_DEPS} ${LIB_DEPS} makedepend-native"
+
+PE = "1"
+PR = "r1"
+
+EXTRA_OECONF += "--with-driver=xlib --without-gallium-drivers"
+
+do_configure_prepend() {
+ #check for python not python2, because python-native does not stage python2 binary/link
+ sed -i 's/AC_CHECK_PROGS(\[PYTHON2\], \[python2 python\])/AC_CHECK_PROGS(\[PYTHON2\], \[python python\])/g' ${S}/configure.ac
+ # We need builtin_compiler built for buildhost arch instead of target (is provided by mesa-dri-glsl-native)"
+ sed -i "s#\./builtin_compiler#${STAGING_BINDIR_NATIVE}/glsl/builtin_compiler#g" ${S}/src/glsl/Makefile
+}
+