summaryrefslogtreecommitdiff
path: root/meta/recipes-kernel/hello-mod/files/Makefile
diff options
context:
space:
mode:
authorDarren Hart <dvhart@linux.intel.com>2011-03-01 14:18:32 -0800
committerSaul Wold <sgw@linux.intel.com>2011-03-04 11:37:08 -0800
commitd4765569d51448e8918bb15e7ab342983344074a (patch)
treef5555936dfc7daa5f92974c8f913e7591fdc990b /meta/recipes-kernel/hello-mod/files/Makefile
parente807fc977770cb64a217768672c18437ea8f3057 (diff)
downloadopenembedded-core-d4765569d51448e8918bb15e7ab342983344074a.tar.gz
openembedded-core-d4765569d51448e8918bb15e7ab342983344074a.tar.bz2
openembedded-core-d4765569d51448e8918bb15e7ab342983344074a.tar.xz
openembedded-core-d4765569d51448e8918bb15e7ab342983344074a.zip
hello-mod: add a module for testing module.bbclass
The following patch creates a hello-mod recipe for building a trivial out-of-tree kernel module, hello-mod.ko. This demonstrates the hostprogs build modifications added to module.bbclass. When loaded and unloaded, the module prints a simple string to the console to demonstrate it was compiled correctly. Tested on qemux86 poky-image-sato and beagleboard poky-image-minimal (after adding hello-mod to the images). Signed-off-by: Darren Hart <dvhart@linux.intel.com> CC: Gary Thomas <gary@mlbassoc.com>
Diffstat (limited to 'meta/recipes-kernel/hello-mod/files/Makefile')
-rw-r--r--meta/recipes-kernel/hello-mod/files/Makefile14
1 files changed, 14 insertions, 0 deletions
diff --git a/meta/recipes-kernel/hello-mod/files/Makefile b/meta/recipes-kernel/hello-mod/files/Makefile
new file mode 100644
index 000000000..4ded35fbc
--- /dev/null
+++ b/meta/recipes-kernel/hello-mod/files/Makefile
@@ -0,0 +1,14 @@
+obj-m := hello.o
+
+SRC := $(shell pwd)
+
+all:
+ $(MAKE) -C $(KERNEL_SRC) M=$(SRC)
+
+modules_install:
+ $(MAKE) -C $(KERNEL_SRC) M=$(SRC) modules_install
+
+clean:
+ rm -f *.o *~ core .depend .*.cmd *.ko *.mod.c
+ rm -f Module.markers Module.symvers modules.order
+ rm -rf .tmp_versions Modules.symvers