summaryrefslogtreecommitdiff
path: root/meta/recipes-kernel/linux/linux-omap-2.6.29/musb/0024-USB-otg-adding-nop-usb-transceiver.patch
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2011-02-18 15:32:57 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-02-18 15:36:06 +0000
commit673abd92f999829bdd67d0273c43570a62123a63 (patch)
tree63132d1ffc1cb5bf50d244b184ca8d58a9cbc85c /meta/recipes-kernel/linux/linux-omap-2.6.29/musb/0024-USB-otg-adding-nop-usb-transceiver.patch
parentfed61beb31c47e2d96af905a7047fe78d64c9bd0 (diff)
downloadopenembedded-core-673abd92f999829bdd67d0273c43570a62123a63.tar.gz
openembedded-core-673abd92f999829bdd67d0273c43570a62123a63.tar.bz2
openembedded-core-673abd92f999829bdd67d0273c43570a62123a63.tar.xz
openembedded-core-673abd92f999829bdd67d0273c43570a62123a63.zip
conf/machine: Drop older machines with no recent updates
These are all moving to meta-extras. Ideally in the future machines such as these will be maintained to topic specific layers as we move to a more layer oriented model. If this causes a problem for anyone please discuss it on the mailing list. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/linux/linux-omap-2.6.29/musb/0024-USB-otg-adding-nop-usb-transceiver.patch')
-rw-r--r--meta/recipes-kernel/linux/linux-omap-2.6.29/musb/0024-USB-otg-adding-nop-usb-transceiver.patch259
1 files changed, 0 insertions, 259 deletions
diff --git a/meta/recipes-kernel/linux/linux-omap-2.6.29/musb/0024-USB-otg-adding-nop-usb-transceiver.patch b/meta/recipes-kernel/linux/linux-omap-2.6.29/musb/0024-USB-otg-adding-nop-usb-transceiver.patch
deleted file mode 100644
index 67004d7ec..000000000
--- a/meta/recipes-kernel/linux/linux-omap-2.6.29/musb/0024-USB-otg-adding-nop-usb-transceiver.patch
+++ /dev/null
@@ -1,259 +0,0 @@
-From de835357b3597af5304742cbd89771d70533292a Mon Sep 17 00:00:00 2001
-From: Ajay Kumar Gupta <ajay.gupta@ti.com>
-Date: Fri, 6 Feb 2009 17:32:35 +0530
-Subject: [PATCH] USB: otg: adding nop usb transceiver
-
-NOP transceiver is used by all the usb transceiver which are mostly
-autonomous and doesn't require any programming or which are built
-into the usb ip itself.NOP transceiver only allocates the memory
-for struct xceiv and calls otg_set_transceiver() so function call
-to otg_get_transceiver() will return a valid transceiver.
-
-NOP transceiver device should be registered by calling
-usb_nop_xceiv_register() from platform files.
-
-Signed-off-by: Ajay Kumar Gupta <ajay.gupta@ti.com>
-Cc: Felipe Balbi <felipe.balbi@nokia.com>
-Cc: David Brownell <dbrownell@users.sourceforge.net>
-Signed-off-by: Greg Kroah-Hartman <gregkh@suse.de>
----
- drivers/usb/otg/Kconfig | 8 ++
- drivers/usb/otg/Makefile | 1 +
- drivers/usb/otg/nop-usb-xceiv.c | 180 +++++++++++++++++++++++++++++++++++++++
- include/linux/usb/otg.h | 4 +
- 4 files changed, 193 insertions(+), 0 deletions(-)
- create mode 100644 drivers/usb/otg/nop-usb-xceiv.c
-
-diff --git a/drivers/usb/otg/Kconfig b/drivers/usb/otg/Kconfig
-index 5790a5b..aa884d0 100644
---- a/drivers/usb/otg/Kconfig
-+++ b/drivers/usb/otg/Kconfig
-@@ -51,4 +51,12 @@ config TWL4030_USB
- This transceiver supports high and full speed devices plus,
- in host mode, low speed.
-
-+config NOP_USB_XCEIV
-+ tristate "NOP USB Transceiver Driver"
-+ select USB_OTG_UTILS
-+ help
-+ this driver is to be used by all the usb transceiver which are either
-+ built-in with usb ip or which are autonomous and doesn't require any
-+ phy programming such as ISP1x04 etc.
-+
- endif # USB || OTG
-diff --git a/drivers/usb/otg/Makefile b/drivers/usb/otg/Makefile
-index d73c7cf..2081678 100644
---- a/drivers/usb/otg/Makefile
-+++ b/drivers/usb/otg/Makefile
-@@ -9,6 +9,7 @@ obj-$(CONFIG_USB_OTG_UTILS) += otg.o
- obj-$(CONFIG_USB_GPIO_VBUS) += gpio_vbus.o
- obj-$(CONFIG_ISP1301_OMAP) += isp1301_omap.o
- obj-$(CONFIG_TWL4030_USB) += twl4030-usb.o
-+obj-$(CONFIG_NOP_USB_XCEIV) += nop-usb-xceiv.o
-
- ccflags-$(CONFIG_USB_DEBUG) += -DDEBUG
- ccflags-$(CONFIG_USB_GADGET_DEBUG) += -DDEBUG
-diff --git a/drivers/usb/otg/nop-usb-xceiv.c b/drivers/usb/otg/nop-usb-xceiv.c
-new file mode 100644
-index 0000000..4b933f6
---- /dev/null
-+++ b/drivers/usb/otg/nop-usb-xceiv.c
-@@ -0,0 +1,180 @@
-+/*
-+ * drivers/usb/otg/nop-usb-xceiv.c
-+ *
-+ * NOP USB transceiver for all USB transceiver which are either built-in
-+ * into USB IP or which are mostly autonomous.
-+ *
-+ * Copyright (C) 2009 Texas Instruments Inc
-+ * Author: Ajay Kumar Gupta <ajay.gupta@ti.com>
-+ *
-+ * This program is free software; you can redistribute it and/or modify
-+ * it under the terms of the GNU General Public License as published by
-+ * the Free Software Foundation; either version 2 of the License, or
-+ * (at your option) any later version.
-+ *
-+ * This program is distributed in the hope that it will be useful,
-+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
-+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-+ * GNU General Public License for more details.
-+ *
-+ * You should have received a copy of the GNU General Public License
-+ * along with this program; if not, write to the Free Software
-+ * Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
-+ *
-+ * Current status:
-+ * this is to add "nop" transceiver for all those phy which is
-+ * autonomous such as isp1504 etc.
-+ */
-+
-+#include <linux/module.h>
-+#include <linux/platform_device.h>
-+#include <linux/dma-mapping.h>
-+#include <linux/usb/otg.h>
-+
-+struct nop_usb_xceiv {
-+ struct otg_transceiver otg;
-+ struct device *dev;
-+};
-+
-+static u64 nop_xceiv_dmamask = DMA_32BIT_MASK;
-+
-+static struct platform_device nop_xceiv_device = {
-+ .name = "nop_usb_xceiv",
-+ .id = -1,
-+ .dev = {
-+ .dma_mask = &nop_xceiv_dmamask,
-+ .coherent_dma_mask = DMA_32BIT_MASK,
-+ .platform_data = NULL,
-+ },
-+};
-+
-+void usb_nop_xceiv_register(void)
-+{
-+ if (platform_device_register(&nop_xceiv_device) < 0) {
-+ printk(KERN_ERR "Unable to register usb nop transceiver\n");
-+ return;
-+ }
-+}
-+
-+void usb_nop_xceiv_unregister(void)
-+{
-+ platform_device_unregister(&nop_xceiv_device);
-+}
-+
-+static inline struct nop_usb_xceiv *xceiv_to_nop(struct otg_transceiver *x)
-+{
-+ return container_of(x, struct nop_usb_xceiv, otg);
-+}
-+
-+static int nop_set_suspend(struct otg_transceiver *x, int suspend)
-+{
-+ return 0;
-+}
-+
-+static int nop_set_peripheral(struct otg_transceiver *x,
-+ struct usb_gadget *gadget)
-+{
-+ struct nop_usb_xceiv *nop;
-+
-+ if (!x)
-+ return -ENODEV;
-+
-+ nop = xceiv_to_nop(x);
-+
-+ if (!gadget) {
-+ nop->otg.gadget = NULL;
-+ return -ENODEV;
-+ }
-+
-+ nop->otg.gadget = gadget;
-+ nop->otg.state = OTG_STATE_B_IDLE;
-+ return 0;
-+}
-+
-+static int nop_set_host(struct otg_transceiver *x, struct usb_bus *host)
-+{
-+ struct nop_usb_xceiv *nop;
-+
-+ if (!x)
-+ return -ENODEV;
-+
-+ nop = xceiv_to_nop(x);
-+
-+ if (!host) {
-+ nop->otg.host = NULL;
-+ return -ENODEV;
-+ }
-+
-+ nop->otg.host = host;
-+ return 0;
-+}
-+
-+static int __devinit nop_usb_xceiv_probe(struct platform_device *pdev)
-+{
-+ struct nop_usb_xceiv *nop;
-+ int err;
-+
-+ nop = kzalloc(sizeof *nop, GFP_KERNEL);
-+ if (!nop)
-+ return -ENOMEM;
-+
-+ nop->dev = &pdev->dev;
-+ nop->otg.dev = nop->dev;
-+ nop->otg.label = "nop-xceiv";
-+ nop->otg.state = OTG_STATE_UNDEFINED;
-+ nop->otg.set_host = nop_set_host;
-+ nop->otg.set_peripheral = nop_set_peripheral;
-+ nop->otg.set_suspend = nop_set_suspend;
-+
-+ err = otg_set_transceiver(&nop->otg);
-+ if (err) {
-+ dev_err(&pdev->dev, "can't register transceiver, err: %d\n",
-+ err);
-+ goto exit;
-+ }
-+
-+ platform_set_drvdata(pdev, nop);
-+
-+ return 0;
-+exit:
-+ kfree(nop);
-+ return err;
-+}
-+
-+static int __devexit nop_usb_xceiv_remove(struct platform_device *pdev)
-+{
-+ struct nop_usb_xceiv *nop = platform_get_drvdata(pdev);
-+
-+ otg_set_transceiver(NULL);
-+
-+ platform_set_drvdata(pdev, NULL);
-+ kfree(nop);
-+
-+ return 0;
-+}
-+
-+static struct platform_driver nop_usb_xceiv_driver = {
-+ .probe = nop_usb_xceiv_probe,
-+ .remove = __devexit_p(nop_usb_xceiv_remove),
-+ .driver = {
-+ .name = "nop_usb_xceiv",
-+ .owner = THIS_MODULE,
-+ },
-+};
-+
-+static int __init nop_usb_xceiv_init(void)
-+{
-+ return platform_driver_register(&nop_usb_xceiv_driver);
-+}
-+subsys_initcall(nop_usb_xceiv_init);
-+
-+static void __exit nop_usb_xceiv_exit(void)
-+{
-+ platform_driver_unregister(&nop_usb_xceiv_driver);
-+}
-+module_exit(nop_usb_xceiv_exit);
-+
-+MODULE_ALIAS("platform:nop_usb_xceiv");
-+MODULE_AUTHOR("Texas Instruments Inc");
-+MODULE_DESCRIPTION("NOP USB Transceiver driver");
-+MODULE_LICENSE("GPL");
-diff --git a/include/linux/usb/otg.h b/include/linux/usb/otg.h
-index 94df4fe..54f2424 100644
---- a/include/linux/usb/otg.h
-+++ b/include/linux/usb/otg.h
-@@ -80,6 +80,10 @@ struct otg_transceiver {
-
- /* for board-specific init logic */
- extern int otg_set_transceiver(struct otg_transceiver *);
-+#ifdef CONFIG_NOP_USB_XCEIV
-+extern void usb_nop_xceiv_register(void);
-+extern void usb_nop_xceiv_unregister(void);
-+#endif
-
-
- /* for usb host and peripheral controller drivers */
---
-1.6.0.4
-