summaryrefslogtreecommitdiff
path: root/meta/recipes-kernel/linux/linux-omap3-pm_git.bb
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2011-02-18 15:32:57 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-02-18 15:36:06 +0000
commit673abd92f999829bdd67d0273c43570a62123a63 (patch)
tree63132d1ffc1cb5bf50d244b184ca8d58a9cbc85c /meta/recipes-kernel/linux/linux-omap3-pm_git.bb
parentfed61beb31c47e2d96af905a7047fe78d64c9bd0 (diff)
downloadopenembedded-core-673abd92f999829bdd67d0273c43570a62123a63.tar.gz
openembedded-core-673abd92f999829bdd67d0273c43570a62123a63.tar.bz2
openembedded-core-673abd92f999829bdd67d0273c43570a62123a63.tar.xz
openembedded-core-673abd92f999829bdd67d0273c43570a62123a63.zip
conf/machine: Drop older machines with no recent updates
These are all moving to meta-extras. Ideally in the future machines such as these will be maintained to topic specific layers as we move to a more layer oriented model. If this causes a problem for anyone please discuss it on the mailing list. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/linux/linux-omap3-pm_git.bb')
-rw-r--r--meta/recipes-kernel/linux/linux-omap3-pm_git.bb65
1 files changed, 0 insertions, 65 deletions
diff --git a/meta/recipes-kernel/linux/linux-omap3-pm_git.bb b/meta/recipes-kernel/linux/linux-omap3-pm_git.bb
deleted file mode 100644
index d65ca5041..000000000
--- a/meta/recipes-kernel/linux/linux-omap3-pm_git.bb
+++ /dev/null
@@ -1,65 +0,0 @@
-DESCRIPTION = "Linux Kernel"
-SECTION = "kernel"
-LICENSE = "GPL"
-
-inherit kernel
-
-FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/${PN}-git/${MACHINE}"
-
-PV = "2.6.31-rc7+pm+${PR}+git${SRCPV}"
-PR = "r3"
-
-SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/khilman/linux-omap-pm.git;branch=pm;protocol=git"
-
-SRC_URI_append_zoom2 = " \
- file://0001-OMAP1-2-3-4-DEBUG_LL-cleanup.patch;patch=1 \
- file://0002-OMAP1-2-3-4-Adapt-board-files-for-cleand-DEBUG_LL-in.patch;patch=1 \
- file://0003-OMAP-Zoom2-Add-DEBUG_LL-interface-using-external-Qua.patch;patch=1 \
- "
-
-COMPATIBLE_MACHINE = "beagleboard|omap-3430sdp|omap3evm|overo|rx51|zoom2"
-
-S = "${WORKDIR}/git"
-
-do_configure_prepend() {
- # logo support: if you supply logo_linux_clut224.ppm in SRC_URI,
- # then it's going to be used instead of "Tux" in the kernel sources
- if [ -e ${WORKDIR}/logo_linux_clut224.ppm ]; then
- install -m 0644 ${WORKDIR}/logo_linux_clut224.ppm \
- drivers/video/logo/logo_linux_clut224.ppm
- fi
-
- # use the externally-supplied ${MACHINE}_external_defconfig if present,
- # else use omap3_pm_defconfig from the sources
- if [ -e ${WORKDIR}/${MACHINE}_external_defconfig ]; then
- cp ${WORKDIR}/${MACHINE}_external_defconfig ${S}/arch/arm/configs/
- yes '' | oe_runmake ${MACHINE}_external_defconfig
- else
- case ${MACHINE} in
- omap-3430sdp | omap3evm)
- # works out of the box
- yes '' | oe_runmake omap3_pm_defconfig
- ;;
- beagleboard | overo | rx51)
- # adjust LL_DEBUG console for these boards
- yes '' | oe_runmake omap3_pm_defconfig
- sed -e "s/CONFIG_OMAP_LL_DEBUG_UART1=y/# CONFIG_OMAP_LL_DEBUG_UART1 is not set/" \
- -e "s/# CONFIG_OMAP_LL_DEBUG_UART3 is not set/CONFIG_OMAP_LL_DEBUG_UART3=y/" \
- -e "s/CONFIG_MMC_BLOCK=m/CONFIG_MMC_BLOCK=y/" \
- -e "s/CONFIG_MMC_OMAP_HS=m/CONFIG_MMC_OMAP_HS=y/" \
- -i ${S}/.config
- ;;
- zoom2)
- # adjust LL_DEBUG console for this board
- yes '' | oe_runmake omap3_pm_defconfig
- sed -e "s/CONFIG_OMAP_LL_DEBUG_UART1=y/# CONFIG_OMAP_LL_DEBUG_UART1 is not set/" \
- -i ${S}/.config
- echo "CONFIG_OMAP_LL_DEBUG_UART_EXT=y" >> ${S}/.config
- ;;
- *)
- # its worth a try...
- yes '' | oe_runmake ${MACHINE}_defconfig
- ;;
- esac
- fi
-}