summaryrefslogtreecommitdiff
path: root/meta/recipes-kernel/linux/linux-yocto-rt_3.2.bb
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2012-01-27 15:41:20 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-02-01 14:58:46 +0000
commit72264df07d7e57ba8232aae90b76ab220fdb2d22 (patch)
tree77ebebc7c308b45154fdea8a33aa2484b030cd15 /meta/recipes-kernel/linux/linux-yocto-rt_3.2.bb
parent5a3759f4b23361dd2c1968ce51e5c3695a661972 (diff)
downloadopenembedded-core-72264df07d7e57ba8232aae90b76ab220fdb2d22.tar.gz
openembedded-core-72264df07d7e57ba8232aae90b76ab220fdb2d22.tar.bz2
openembedded-core-72264df07d7e57ba8232aae90b76ab220fdb2d22.tar.xz
openembedded-core-72264df07d7e57ba8232aae90b76ab220fdb2d22.zip
linux-yocto: add kernel 3.2.2 support
Adding initial support for the linux 3.2 kernel. Although the branching and naming has changed slightly, the same BSPs and features exist in this tree as have existed in previous linux-yocto versions. Notable features of this update are: - streamlined branch naming - configuration and functionality split in the standard kernel - creation of the 'tiny' kernel type branch - audited kernel configurations with optional features documented in the meta branch - feature and BSP refreshes - 3.2-rt support refresh - qemu ppc graphics support Build and boot testing has been performed on all emulated targets (sato and core). Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta/recipes-kernel/linux/linux-yocto-rt_3.2.bb')
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-rt_3.2.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto-rt_3.2.bb b/meta/recipes-kernel/linux/linux-yocto-rt_3.2.bb
new file mode 100644
index 000000000..9b0c1bf98
--- /dev/null
+++ b/meta/recipes-kernel/linux/linux-yocto-rt_3.2.bb
@@ -0,0 +1,37 @@
+inherit kernel
+require recipes-kernel/linux/linux-yocto.inc
+
+KMACHINE = "common-pc"
+KMACHINE_qemux86 = "common-pc"
+KMACHINE_qemux86-64 = "common-pc-64"
+KMACHINE_qemuarm = "arm-versatile-926ejs"
+KMACHINE_qemuppc = "qemu-ppc32"
+KMACHINE_qemumips = "mti-malta32-be"
+
+KBRANCH = "standard/preempt-rt/base"
+KBRANCH_qemuppc = "standard/preempt-rt/qemu-ppc32"
+
+LINUX_VERSION ?= "3.2.2"
+LINUX_KERNEL_TYPE = "preempt-rt"
+
+SRCREV_machine ?= "415af017cf163c63d7b1e6e929e4a9c9baf5ba6d"
+SRCREV_machine_qemuppc ?= "38345c1e41b15c49308a9adbdde95167eeaa05fa"
+SRCREV_meta ?= "138bf5b502607fe40315c0d76822318d77d97e01"
+
+PR = "r0"
+PV = "${LINUX_VERSION}+git${SRCPV}"
+
+SRC_URI = "git://git.yoctoproject.org/linux-yocto-3.2.git;protocol=git;nocheckout=1;branch=${KBRANCH},meta;name=machine,meta"
+
+# Omit broken machines from COMPATIBLE_MACHINE
+# qemuppc hangs at boot
+# qemumips panics at boot
+COMPATIBLE_MACHINE = "(qemux86|qemux86-64|qemuarm)"
+
+# Functionality flags
+KERNEL_FEATURES=features/netfilter
+KERNEL_FEATURES_append=" features/taskstats"
+KERNEL_FEATURES_append_qemux86=" cfg/sound"
+KERNEL_FEATURES_append_qemux86-64=" cfg/sound"
+
+require recipes-kernel/linux/linux-tools.inc