summaryrefslogtreecommitdiff
path: root/meta/recipes-kernel/linux/linux-yocto-tiny_3.0.bb
diff options
context:
space:
mode:
authorDarren Hart <dvhart@linux.intel.com>2011-12-14 15:13:57 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-01-03 12:10:45 +0000
commit8a76f80cabb8df5959707ee708f2c00b28a784e7 (patch)
tree66b35267a2986ffb222136c803be980de6c52f71 /meta/recipes-kernel/linux/linux-yocto-tiny_3.0.bb
parent08b2bb292ec9da38e399fe4fe00da5cc0ee0ea4c (diff)
downloadopenembedded-core-8a76f80cabb8df5959707ee708f2c00b28a784e7.tar.gz
openembedded-core-8a76f80cabb8df5959707ee708f2c00b28a784e7.tar.bz2
openembedded-core-8a76f80cabb8df5959707ee708f2c00b28a784e7.tar.xz
openembedded-core-8a76f80cabb8df5959707ee708f2c00b28a784e7.zip
linux-yocto-tiny: New kernel recipe for tiny distros
linux-yocto-tiny drops the linux-tools and sets the KMACHINE branch to standard/tiny. Signed-off-by: Darren Hart <dvhart@linux.intel.com>
Diffstat (limited to 'meta/recipes-kernel/linux/linux-yocto-tiny_3.0.bb')
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-tiny_3.0.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto-tiny_3.0.bb b/meta/recipes-kernel/linux/linux-yocto-tiny_3.0.bb
new file mode 100644
index 000000000..c5855a357
--- /dev/null
+++ b/meta/recipes-kernel/linux/linux-yocto-tiny_3.0.bb
@@ -0,0 +1,36 @@
+inherit kernel
+require recipes-kernel/linux/linux-yocto.inc
+
+#KMACHINE = "yocto/standard/tiny/base"
+KMACHINE = "yocto/standard/base"
+KBRANCH = ${KMACHINE}
+
+LINUX_VERSION ?= "3.0.12"
+
+SRCREV_machine ?= "f389d310965a56091f688b28ea8be6d9cbb7fbbe"
+SRCREV_meta ?= "04a52a32cbdf0972033b97b83eaa83eb275dfdc9"
+
+PR = "r1"
+PV = "${LINUX_VERSION}+git${SRCPV}"
+
+SRC_URI = "git://git.yoctoproject.org/linux-yocto-3.0;protocol=git;nocheckout=1;branch=${KBRANCH},meta;name=machine,meta \
+ file://core.cfg \
+ file://serial.cfg \
+ file://ext2.cfg \
+ file://rtc-pc.cfg \
+ file://ramfs.cfg \
+ file://devtmpfs.cfg \
+ file://net.cfg \
+ file://debug.cfg \
+ file://lzma.cfg \
+ "
+
+
+# Enable qemux86 specific emulated options
+SRC_URI_append_qemux86 = " file://defconfig file://ata.cfg file://e1000.cfg"
+
+#COMPATIBLE_MACHINE = "(qemuarm|qemux86|qemuppc|qemumips|qemux86-64)"
+COMPATIBLE_MACHINE = "(qemux86)"
+
+# Functionality flags
+KERNEL_FEATURES=""