summaryrefslogtreecommitdiff
path: root/meta/recipes-kernel/linux/linux-yocto-tiny_3.2.bb
diff options
context:
space:
mode:
authorDarren Hart <dvhart@linux.intel.com>2012-04-01 00:19:58 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-04-02 04:35:28 +0100
commit44c556f5300b1d811a1ae71f501320d1a6b0fb2e (patch)
tree9aed3e95ef8974ada0b912bd3928ba459c9f5cc0 /meta/recipes-kernel/linux/linux-yocto-tiny_3.2.bb
parentdf3b8f716cc9203251cd4d4b5e673d7ecab5111b (diff)
downloadopenembedded-core-44c556f5300b1d811a1ae71f501320d1a6b0fb2e.tar.gz
openembedded-core-44c556f5300b1d811a1ae71f501320d1a6b0fb2e.tar.bz2
openembedded-core-44c556f5300b1d811a1ae71f501320d1a6b0fb2e.tar.xz
openembedded-core-44c556f5300b1d811a1ae71f501320d1a6b0fb2e.zip
tiny: Update linux-yocto-tiny to 3.2
Migrate linux-yocto-tiny from 3.0 to 3.2. The 3.0 recipe was based entirely on recipe-space fragments and was only a proof of concept. The 3.2 linux-yocto meta-data now has a proper tiny KTYPE defined. By default this recipe supports only the qemux86 machine, which builds the common-pc support (including networking, sound, USB, VGA and serial consoles, etc.). New machines can be added and will use the tiny KTYPE, but will need to add any desired hardware support as the base config is very minimal. No filesystems are supported by default, only the initramfs. Signed-off-by: Darren Hart <dvhart@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/linux/linux-yocto-tiny_3.2.bb')
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-tiny_3.2.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto-tiny_3.2.bb b/meta/recipes-kernel/linux/linux-yocto-tiny_3.2.bb
new file mode 100644
index 000000000..d2c8bf7ed
--- /dev/null
+++ b/meta/recipes-kernel/linux/linux-yocto-tiny_3.2.bb
@@ -0,0 +1,25 @@
+inherit kernel
+require recipes-kernel/linux/linux-yocto.inc
+
+# We need lzma (as CONFIG_KERNEL_LZMA=y)
+DEPENDS += "xz-native"
+
+KMACHINE = "common-pc"
+KBRANCH = "standard/tiny"
+LINUX_KERNEL_TYPE = "tiny"
+KCONFIG_MODE = "--allnoconfig"
+
+LINUX_VERSION ?= "3.2.11"
+
+SRCREV_machine ?= "ec236058dc254183dbfb3744bf21f110c37af30b"
+SRCREV_meta ?= "59f350ec3794e19fa806c1b73749d851f8ebf364"
+
+PR = "r0"
+PV = "${LINUX_VERSION}+git${SRCPV}"
+
+SRC_URI = "git://git.yoctoproject.org/linux-yocto-3.2;protocol=git;bareclone=1;branch=${KBRANCH},meta;name=machine,meta"
+
+COMPATIBLE_MACHINE = "(qemux86)"
+
+# Functionality flags
+KERNEL_FEATURES = ""