summaryrefslogtreecommitdiff
path: root/meta/recipes-kernel/linux/linux-yocto_2.6.34.bb
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2011-11-20 00:30:02 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-12-02 15:19:45 +0000
commitbd5f38b0bb063b2fb2e46abc5d7ffaed4b6b502c (patch)
tree849655f16f53aaf12f03ae331a93e5c581cdf667 /meta/recipes-kernel/linux/linux-yocto_2.6.34.bb
parent644f2e525b910b9ff8d9aaa33f11eba3fefa7c85 (diff)
downloadopenembedded-core-bd5f38b0bb063b2fb2e46abc5d7ffaed4b6b502c.tar.gz
openembedded-core-bd5f38b0bb063b2fb2e46abc5d7ffaed4b6b502c.tar.bz2
openembedded-core-bd5f38b0bb063b2fb2e46abc5d7ffaed4b6b502c.tar.xz
openembedded-core-bd5f38b0bb063b2fb2e46abc5d7ffaed4b6b502c.zip
linux-yocto: remove 2.6.34 recipes
To limit the number of active recipes in master to 3 (v2.6.37, v3.0 and -dev), the 2.6.34 recipe can now be removed. It is available in the previous release branches and will continue to work, but won't be updated as part of ongoing dev efforts. Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta/recipes-kernel/linux/linux-yocto_2.6.34.bb')
-rw-r--r--meta/recipes-kernel/linux/linux-yocto_2.6.34.bb49
1 files changed, 0 insertions, 49 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto_2.6.34.bb b/meta/recipes-kernel/linux/linux-yocto_2.6.34.bb
deleted file mode 100644
index cbcfa56fe..000000000
--- a/meta/recipes-kernel/linux/linux-yocto_2.6.34.bb
+++ /dev/null
@@ -1,49 +0,0 @@
-inherit kernel
-require linux-yocto.inc
-
-KMACHINE = "common_pc"
-KMACHINE_qemux86 = "common_pc"
-KMACHINE_qemux86-64 = "common_pc_64"
-KMACHINE_qemuppc = "qemu_ppc32"
-KMACHINE_qemumips = "mti_malta32_be"
-KMACHINE_qemuarm = "arm_versatile_926ejs"
-
-LINUX_VERSION ?= "2.6.34"
-LINUX_VERSION_EXTENSION ?= "-yocto-${LINUX_KERNEL_TYPE_EXTENSION}"
-
-KMETA = wrs_meta
-KBRANCH = ${KMACHINE}-${LINUX_KERNEL_TYPE_EXTENSION}
-
-SRCREV_machine_qemuarm = "a2fb081b44d6368eff8d28e2fdb991c61b1f428e"
-SRCREV_machine_qemumips = "c32d40f960e3c89d07f079bec4c96dcbfc749f0b"
-SRCREV_machine_qemuppc = "96d6bc31d3caaf62a966255479cc5cee0e76b1e9"
-SRCREV_machine_qemux86 = "72ca49ab08b8eb475cec82a10049503602325791"
-SRCREV_machine_qemux86-64 = "72ca49ab08b8eb475cec82a10049503602325791"
-SRCREV_machine = "72ca49ab08b8eb475cec82a10049503602325791"
-SRCREV_meta = "ec26387cb168e9e0976999b528b5a9dd62e3157a"
-
-PR = "r2"
-PV = "${LINUX_VERSION}+git${SRCPV}"
-SRCREV_FORMAT = "meta_machine"
-
-COMPATIBLE_MACHINE = "(qemuarm|qemux86|qemuppc|qemumips|qemux86-64)"
-
-# this performs a fixup on historical kernel types with embedded _'s
-python __anonymous () {
- import bb, re, string
-
- kerntype = string.replace(bb.data.expand("${LINUX_KERNEL_TYPE}", d), "_", "-")
- d.setVar("LINUX_KERNEL_TYPE_EXTENSION", kerntype)
-}
-
-SRC_URI = "git://git.yoctoproject.org/linux-yocto-2.6.34.git;protocol=git;nocheckout=1;branch=${KBRANCH},wrs_meta;name=machine,meta"
-
-# Functionality flags
-KERNEL_REVISION_CHECKING ?= "t"
-KERNEL_FEATURES=features/netfilter
-
-# extra tasks
-addtask kernel_link_vmlinux after do_compile before do_install
-addtask validate_branches before do_patch after do_kernel_checkout
-
-require linux-tools.inc