summaryrefslogtreecommitdiff
path: root/meta/recipes-kernel/linux/linux-yocto_2.6.37.bb
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2011-09-09 18:27:46 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-09-15 11:20:52 +0100
commita1ab7c5e03df97e630dfee470ff7959d3143bf41 (patch)
treebab99c72f06fa0290905bc6d82dfffcd08d1d39f /meta/recipes-kernel/linux/linux-yocto_2.6.37.bb
parent07407baafb728c5ae1bb283f5b02a2ac773360bc (diff)
downloadopenembedded-core-a1ab7c5e03df97e630dfee470ff7959d3143bf41.tar.gz
openembedded-core-a1ab7c5e03df97e630dfee470ff7959d3143bf41.tar.bz2
openembedded-core-a1ab7c5e03df97e630dfee470ff7959d3143bf41.tar.xz
openembedded-core-a1ab7c5e03df97e630dfee470ff7959d3143bf41.zip
linux-yocto: move common tasks to a common location
During the initial development of the linux-yocto recipes there were several additional tasks that needed to be run in any inheriting recipe. At that time, they didn't seem to fire if they were in the include file versus the recipes themselves. As it turns out, these tasks do work fine if placed in the linux-yocto.inc file, and the rest of the recipes can be simplified as a result. Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta/recipes-kernel/linux/linux-yocto_2.6.37.bb')
-rw-r--r--meta/recipes-kernel/linux/linux-yocto_2.6.37.bb13
1 files changed, 1 insertions, 12 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto_2.6.37.bb b/meta/recipes-kernel/linux/linux-yocto_2.6.37.bb
index 419913728..34e563cff 100644
--- a/meta/recipes-kernel/linux/linux-yocto_2.6.37.bb
+++ b/meta/recipes-kernel/linux/linux-yocto_2.6.37.bb
@@ -9,10 +9,8 @@ KMACHINE_qemumips = "yocto/standard/mti-malta32-be"
KMACHINE_qemuarm = "yocto/standard/arm-versatile-926ejs"
KBRANCH = ${KMACHINE}
-KMETA = meta
LINUX_VERSION ?= "2.6.37"
-LINUX_VERSION_EXTENSION ?= "-yocto-${LINUX_KERNEL_TYPE}"
SRCREV_machine_qemuarm = "b3e53a090eaa23aa82e64fa0a563a93a2b4dbb5d"
SRCREV_machine_qemumips = "91f2eb4a3b447476b36aac8e6e198d08c98e0680"
@@ -22,26 +20,17 @@ SRCREV_machine_qemux86-64 = "af2bfbe5f757361b5b027a24d67a93bfdfaaf33c"
SRCREV_machine = "4ae8f8605c81c39b959948e23f7123294a5dfb3f"
SRCREV_meta = "aeea99683c7283f1f3320bf2ee7085ee252d4e7e"
-PR = "r20"
+PR = "r21"
PV = "${LINUX_VERSION}+git${SRCPV}"
-SRCREV_FORMAT = "meta_machine"
SRC_URI = "git://git.yoctoproject.org/linux-yocto-2.6.37;protocol=git;nocheckout=1;branch=${KBRANCH},meta;name=machine,meta"
COMPATIBLE_MACHINE = "(qemuarm|qemux86|qemuppc|qemumips|qemux86-64)"
# Functionality flags
-KERNEL_REVISION_CHECKING ?= "t"
KERNEL_FEATURES="features/netfilter"
KERNEL_FEATURES_append=" features/taskstats"
KERNEL_FEATURES_append_qemux86=" cfg/sound"
KERNEL_FEATURES_append_qemux86-64=" cfg/sound"
-YOCTO_KERNEL_META_DATA=t
-
-# extra tasks
-addtask kernel_link_vmlinux after do_compile before do_install
-addtask validate_branches before do_patch after do_kernel_checkout
-addtask kernel_configcheck after do_configure before do_compile
-
require linux-tools.inc