summaryrefslogtreecommitdiff
path: root/meta/recipes-kernel
diff options
context:
space:
mode:
authorTom Zanussi <tom.zanussi@intel.com>2012-04-13 14:56:02 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-04-14 09:26:33 +0100
commit6ef7112e339bb5c03dee862bc56c10fdf677be78 (patch)
tree02f3e6219b34f6b5df967ab90da129aaf890e325 /meta/recipes-kernel
parent08c368b9980716e459d846dd7183940a5bf8bea4 (diff)
downloadopenembedded-core-6ef7112e339bb5c03dee862bc56c10fdf677be78.tar.gz
openembedded-core-6ef7112e339bb5c03dee862bc56c10fdf677be78.tar.bz2
openembedded-core-6ef7112e339bb5c03dee862bc56c10fdf677be78.tar.xz
openembedded-core-6ef7112e339bb5c03dee862bc56c10fdf677be78.zip
systemtap: fix docproc build error
When building docs in systemtap, docproc is used to generate the tapset documentation, but it gets built for the target, while it needs to be build for the host instead. This change causes that to happen. Fixes [YOCTO #2193]. Signed-off-by: Tom Zanussi <tom.zanussi@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel')
-rw-r--r--meta/recipes-kernel/systemtap/systemtap/docproc-build-fix.patch19
-rw-r--r--meta/recipes-kernel/systemtap/systemtap_git.bb6
-rw-r--r--meta/recipes-kernel/systemtap/systemtap_git.inc4
3 files changed, 27 insertions, 2 deletions
diff --git a/meta/recipes-kernel/systemtap/systemtap/docproc-build-fix.patch b/meta/recipes-kernel/systemtap/systemtap/docproc-build-fix.patch
new file mode 100644
index 000000000..33a89940a
--- /dev/null
+++ b/meta/recipes-kernel/systemtap/systemtap/docproc-build-fix.patch
@@ -0,0 +1,19 @@
+Upstream-Status: Inappropriate [configuration]
+
+Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
+
+Index: git/doc/SystemTap_Tapset_Reference/Makefile.am
+===================================================================
+--- git.orig/doc/SystemTap_Tapset_Reference/Makefile.am 2012-04-13 08:43:46.263339003 -0500
++++ git/doc/SystemTap_Tapset_Reference/Makefile.am 2012-04-13 09:31:22.470083915 -0500
+@@ -27,6 +27,10 @@
+ noinst_PROGRAMS = docproc
+ SRCTREE=$(abs_top_srcdir)/
+ DOCPROC=$(abs_builddir)/docproc
++docproc_LINK = $(CC_FOR_BUILD) $(LDFLAGS_FOR_BUILD) -o $@
++
++docproc.o: $(srcdir)/docproc.c
++ $(CC_FOR_BUILD) -c $(CFLAGS_FOR_BUILD) -o $@ $(srcdir)/docproc.c
+
+ all: $(PDFDOCS) stamp-htmldocs stamp-mandocs
+ tapsets.xml: docproc $(shell find $(SRCTREE)/tapset -name '*.stp')
diff --git a/meta/recipes-kernel/systemtap/systemtap_git.bb b/meta/recipes-kernel/systemtap/systemtap_git.bb
index c4a9d87df..1d2c9f35e 100644
--- a/meta/recipes-kernel/systemtap/systemtap_git.bb
+++ b/meta/recipes-kernel/systemtap/systemtap_git.bb
@@ -6,7 +6,11 @@ DEPENDS = "elfutils sqlite3 systemtap-native"
DEPENDS_virtclass-native = "elfutils-native sqlite3-native gettext-native"
DEPENDS_virtclass-nativesdk = "elfutils-nativesdk sqlite3-nativesdk gettext-nativesdk"
-PR = "r2"
+PR = "r3"
+
+export CC_FOR_BUILD = "${BUILD_CC}"
+export CFLAGS_FOR_BUILD = "${BUILD_CFLAGS}"
+export LDFLAGS_FOR_BUILD = "${BUILD_LDFLAGS}"
EXTRA_OECONF += "--with-libelf=${STAGING_DIR_TARGET} --without-rpm \
ac_cv_file__usr_include_nss=no \
diff --git a/meta/recipes-kernel/systemtap/systemtap_git.inc b/meta/recipes-kernel/systemtap/systemtap_git.inc
index cc250ff79..c4d6e3483 100644
--- a/meta/recipes-kernel/systemtap/systemtap_git.inc
+++ b/meta/recipes-kernel/systemtap/systemtap_git.inc
@@ -4,7 +4,9 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
SRCREV = "83bd2699d8cff2f2d6b9eaf5ea254e4cb6b33e81"
PV = "1.7+git${SRCPV}"
-SRC_URI = "git://sources.redhat.com/git/systemtap.git;protocol=git"
+SRC_URI = "git://sources.redhat.com/git/systemtap.git;protocol=git \
+ file://docproc-build-fix.patch \
+ "
SRC_URI[md5sum] = "cb202866ed704c44a876d041f788bdee"
SRC_URI[sha256sum] = "8ffe35caec0d937bd23fd78a3a8d94b58907cc0de0330b35e38f9f764815c459"