summaryrefslogtreecommitdiff
path: root/meta/recipes-support/apr/apr-util_1.3.12.bb
diff options
context:
space:
mode:
authorZhai Edwin <edwin.zhai@intel.com>2011-07-28 14:42:47 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-08-04 15:01:17 +0100
commit51a6c43f6658032d67ddea349f66ddcaafe6bbce (patch)
tree98623b48d3d088d285035be1452fa83a95193f2e /meta/recipes-support/apr/apr-util_1.3.12.bb
parente66e0886412b2f1a564babbaa83095c86e5ec65c (diff)
downloadopenembedded-core-51a6c43f6658032d67ddea349f66ddcaafe6bbce.tar.gz
openembedded-core-51a6c43f6658032d67ddea349f66ddcaafe6bbce.tar.bz2
openembedded-core-51a6c43f6658032d67ddea349f66ddcaafe6bbce.tar.xz
openembedded-core-51a6c43f6658032d67ddea349f66ddcaafe6bbce.zip
apr-util: Upgrade to 1.3.12
Signed-off-by: Zhai Edwin <edwin.zhai@intel.com> Merged with ${BPN} change Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-support/apr/apr-util_1.3.12.bb')
-rw-r--r--meta/recipes-support/apr/apr-util_1.3.12.bb39
1 files changed, 39 insertions, 0 deletions
diff --git a/meta/recipes-support/apr/apr-util_1.3.12.bb b/meta/recipes-support/apr/apr-util_1.3.12.bb
new file mode 100644
index 000000000..6635202da
--- /dev/null
+++ b/meta/recipes-support/apr/apr-util_1.3.12.bb
@@ -0,0 +1,39 @@
+DESCRIPTION = "Apache Portable Runtime (APR) companion library"
+HOMEPAGE = "http://apr.apache.org/"
+SECTION = "libs"
+DEPENDS = "apr expat gdbm"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=519e0a18e03f7c023070568c14b077bb \
+ file://include/apu_version.h;endline=17;md5=806685a84e71f10c80144c48eb35df42"
+
+PR = "r0"
+
+SRC_URI = "${APACHE_MIRROR}/apr/${BPN}-${PV}.tar.gz \
+ file://configfix.patch \
+ file://configure_fixes.patch"
+
+SRC_URI[md5sum] = "d1977289889592ef998e3f777f68efe4"
+SRC_URI[sha256sum] = "815b6fc82950f61050a5e711a7f3c20fd9b6ffcc7a4cacfe9f291fb241210cd8"
+
+EXTRA_OECONF = "--with-apr=${STAGING_BINDIR_CROSS}/apr-1-config \
+ --without-odbc \
+ --with-dbm=gdbm \
+ --with-gdbm=${STAGING_DIR_HOST}${prefix} \
+ --without-sqlite2 \
+ --without-sqlite3 \
+ --with-expat=${STAGING_DIR_HOST}${prefix}"
+
+
+inherit autotools lib_package binconfig
+
+OE_BINCONFIG_EXTRA_MANGLE = " -e 's:location=source:location=installed:'"
+
+do_configure_prepend() {
+ cp ${STAGING_DATADIR}/apr/apr_rules.mk ${S}/build/rules.mk
+}
+
+FILES_${PN} += "${libdir}/apr-util-1/apr_dbm_gdbm-1.so"
+FILES_${PN}-dev += "${libdir}/aprutil.exp ${libdir}/apr-util-1/apr_dbm_gdbm.*"
+FILES_${PN}-dbg += "${libdir}/apr-util-1/.debug/*"
+