summaryrefslogtreecommitdiff
path: root/meta/recipes-support/gnutls/gnutls-2.12.11
diff options
context:
space:
mode:
authorSaul Wold <sgw@linux.intel.com>2011-10-04 17:52:16 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-10-06 22:58:10 +0100
commitc30c193d79437261ea4e2184f200c33cfd554e9e (patch)
tree0db6a1bc029d335f077089a888393a508d4b692e /meta/recipes-support/gnutls/gnutls-2.12.11
parent447ea27c510df73e94351fac9adf4f37d6cd44b9 (diff)
downloadopenembedded-core-c30c193d79437261ea4e2184f200c33cfd554e9e.tar.gz
openembedded-core-c30c193d79437261ea4e2184f200c33cfd554e9e.tar.bz2
openembedded-core-c30c193d79437261ea4e2184f200c33cfd554e9e.tar.xz
openembedded-core-c30c193d79437261ea4e2184f200c33cfd554e9e.zip
gnutls: Update to 2.12.11
Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-support/gnutls/gnutls-2.12.11')
-rw-r--r--meta/recipes-support/gnutls/gnutls-2.12.11/configure-fix.patch65
-rw-r--r--meta/recipes-support/gnutls/gnutls-2.12.11/gnutls-openssl.patch126
-rw-r--r--meta/recipes-support/gnutls/gnutls-2.12.11/gnutls-texinfo-euro.patch18
3 files changed, 209 insertions, 0 deletions
diff --git a/meta/recipes-support/gnutls/gnutls-2.12.11/configure-fix.patch b/meta/recipes-support/gnutls/gnutls-2.12.11/configure-fix.patch
new file mode 100644
index 000000000..14f87e03d
--- /dev/null
+++ b/meta/recipes-support/gnutls/gnutls-2.12.11/configure-fix.patch
@@ -0,0 +1,65 @@
+Upstream-Status: Inappropriate [distribution]
+
+rebased from original configure_madness.patch
+
+libtasn1 provides an .pc file in upstream,
+and a libgcrypt.pc is added in libgcrypt recipe,
+so use Requires.private for these two.
+
+against 2.8.6
+
+07/02/2010 - qhe
+
+---
+Index: gnutls-2.12.11/lib/configure.ac
+===================================================================
+--- gnutls-2.12.11.orig/lib/configure.ac
++++ gnutls-2.12.11/lib/configure.ac
+@@ -126,8 +126,8 @@ lgl_INIT
+ AC_CHECK_FUNCS(getrusage,,)
+ AC_LIB_HAVE_LINKFLAGS(pthread,, [#include <pthread.h>], [pthread_mutex_lock (0);])
+
+-LIBGNUTLS_LIBS="-L${libdir} -lgnutls $LIBS"
+-LIBGNUTLS_CFLAGS="-I${includedir}"
++LIBGNUTLS_LIBS="-lgnutls $LIBS"
++LIBGNUTLS_CFLAGS=""
+ AC_SUBST(LIBGNUTLS_LIBS)
+ AC_SUBST(LIBGNUTLS_CFLAGS)
+
+Index: gnutls-2.12.11/lib/gnutls.pc.in
+===================================================================
+--- gnutls-2.12.11.orig/lib/gnutls.pc.in
++++ gnutls-2.12.11/lib/gnutls.pc.in
+@@ -20,6 +20,4 @@ Description: Transport Security Layer im
+ URL: http://www.gnu.org/software/gnutls/
+ Version: @VERSION@
+ Libs: -L${libdir} -lgnutls
+-Libs.private: @LTLIBGCRYPT@ @LTLIBNETTLE@ @NETTLE_LIBS@ @GNUTLS_ZLIB_LIBS_PRIVATE@
+-@GNUTLS_REQUIRES_PRIVATE@
+ Cflags: -I${includedir}
+Index: gnutls-2.12.11/libextra/configure.ac
+===================================================================
+--- gnutls-2.12.11.orig/libextra/configure.ac
++++ gnutls-2.12.11/libextra/configure.ac
+@@ -41,8 +41,8 @@ LIBGNUTLS_EXTRA_HOOKS
+
+ xgl_INIT
+
+-LIBGNUTLS_EXTRA_LIBS="-L${libdir} -lgnutls-extra $LZO_LIBS $LIBGNUTLS_LIBS"
+-LIBGNUTLS_EXTRA_CFLAGS="-I${includedir}"
++LIBGNUTLS_EXTRA_LIBS="-lgnutls-extra $LZO_LIBS $LIBGNUTLS_LIBS"
++LIBGNUTLS_EXTRA_CFLAGS=""
+ AC_SUBST(LIBGNUTLS_EXTRA_LIBS)
+ AC_SUBST(LIBGNUTLS_EXTRA_CFLAGS)
+
+Index: gnutls-2.12.11/libextra/gnutls-extra.pc.in
+===================================================================
+--- gnutls-2.12.11.orig/libextra/gnutls-extra.pc.in
++++ gnutls-2.12.11/libextra/gnutls-extra.pc.in
+@@ -22,5 +22,5 @@ URL: http://www.gnu.org/software/gnutls/
+ Requires: gnutls
+ Version: @VERSION@
+ Libs: -L${libdir} -lgnutls-extra
+-Libs.private: @LIBGNUTLS_EXTRA_LIBS@
++Libs.private: -llzo2
+ Cflags: -I${includedir}
diff --git a/meta/recipes-support/gnutls/gnutls-2.12.11/gnutls-openssl.patch b/meta/recipes-support/gnutls/gnutls-2.12.11/gnutls-openssl.patch
new file mode 100644
index 000000000..ef7067488
--- /dev/null
+++ b/meta/recipes-support/gnutls/gnutls-2.12.11/gnutls-openssl.patch
@@ -0,0 +1,126 @@
+Upstream-Status: Backport
+
+Index: gnutls-1.6.0/libextra/gnutls_openssl.c
+===================================================================
+--- gnutls-1.6.0.orig/libextra/gnutls_openssl.c 2006-08-13 22:34:09.000000000 +0200
++++ gnutls-1.6.0/libextra/gnutls_openssl.c 2006-12-12 15:07:59.002227000 +0100
+@@ -256,12 +256,17 @@
+ ssl->rfd = (gnutls_transport_ptr_t) - 1;
+ ssl->wfd = (gnutls_transport_ptr_t) - 1;
+
++ ssl->ssl_peek_buffer = NULL;
++ ssl->ssl_peek_buffer_size = ssl->ssl_peek_avail = 0;
++
+ return ssl;
+ }
+
+ void
+ SSL_free (SSL * ssl)
+ {
++ if (ssl->ssl_peek_buffer)
++ free(ssl->ssl_peek_buffer);
+ gnutls_certificate_free_credentials (ssl->gnutls_cred);
+ gnutls_deinit (ssl->gnutls_state);
+ free (ssl);
+@@ -285,6 +290,7 @@
+ SSL_set_fd (SSL * ssl, int fd)
+ {
+ gnutls_transport_set_ptr (ssl->gnutls_state, GNUTLS_INT_TO_POINTER (fd));
++ ssl->rfd = ssl->wfd = fd;
+ return 1;
+ }
+
+@@ -310,6 +316,17 @@
+ return 1;
+ }
+
++int SSL_get_rfd(SSL *ssl)
++{
++ return ssl->rfd;
++}
++
++int SSL_get_wfd(SSL *ssl)
++{
++ return ssl->wfd;
++}
++
++
+ void
+ SSL_set_bio (SSL * ssl, BIO * rbio, BIO * wbio)
+ {
+@@ -325,6 +342,8 @@
+ int
+ SSL_pending (SSL * ssl)
+ {
++ if (ssl->ssl_peek_avail)
++ return ssl->ssl_peek_avail;
+ return gnutls_record_check_pending (ssl->gnutls_state);
+ }
+
+@@ -480,11 +499,50 @@
+ return 1;
+ }
+
++int SSL_peek(SSL *ssl, void *buf, int len)
++{
++ if (len > ssl->ssl_peek_buffer_size) {
++ ssl->ssl_peek_buffer = realloc (ssl->ssl_peek_buffer, len);
++ ssl->ssl_peek_buffer_size = len;
++ }
++
++ if (ssl->ssl_peek_avail == 0) {
++
++ int ret;
++
++ ret = gnutls_record_recv(ssl->gnutls_state, ssl->ssl_peek_buffer, len);
++ ssl->last_error = ret;
++
++ if (ret > 0)
++ ssl->ssl_peek_avail += ret;
++ }
++
++ if (len > ssl->ssl_peek_avail)
++ len = ssl->ssl_peek_avail;
++
++ memcpy (buf, ssl->ssl_peek_buffer, len);
++
++ return len;
++}
++
+ int
+ SSL_read (SSL * ssl, void *buf, int len)
+ {
+ int ret;
+
++ if (ssl->ssl_peek_avail) {
++ int n = (ssl->ssl_peek_avail > len) ? len : ssl->ssl_peek_avail;
++
++ memcpy (buf, ssl->ssl_peek_buffer, n);
++
++ if (ssl->ssl_peek_avail > n)
++ memmove (ssl->ssl_peek_buffer, ssl->ssl_peek_buffer + n, ssl->ssl_peek_avail - n);
++
++ ssl->ssl_peek_avail -= n;
++
++ return n;
++ }
++
+ ret = gnutls_record_recv (ssl->gnutls_state, buf, len);
+ ssl->last_error = ret;
+
+Index: gnutls-1.6.0/includes/gnutls/openssl.h
+===================================================================
+--- gnutls-1.6.0.orig/libextra/includes/gnutls/openssl.h 2006-03-08 11:44:58.000000000 +0100
++++ gnutls-1.6.0/libextra/includes/gnutls/openssl.h 2006-12-12 15:07:26.032227000 +0100
+@@ -164,6 +164,11 @@
+
+ gnutls_transport_ptr_t rfd;
+ gnutls_transport_ptr_t wfd;
++
++ char *ssl_peek_buffer;
++ size_t ssl_peek_buffer_size;
++ size_t ssl_peek_avail;
++
+ };
+
+ #define rbio gnutls_state
diff --git a/meta/recipes-support/gnutls/gnutls-2.12.11/gnutls-texinfo-euro.patch b/meta/recipes-support/gnutls/gnutls-2.12.11/gnutls-texinfo-euro.patch
new file mode 100644
index 000000000..10e377407
--- /dev/null
+++ b/meta/recipes-support/gnutls/gnutls-2.12.11/gnutls-texinfo-euro.patch
@@ -0,0 +1,18 @@
+Upstream-Status: Backport
+
+The version of texinfo in Debian Sarge does not understand the @euro{} command.
+This patch replaces the @euro{} command with the word "euro".
+
+--- gnutls-1.3.5/doc/gnutls.texi.orig 2006-04-26 08:06:40.918268000 +0930
++++ gnutls-1.3.5/doc/gnutls.texi 2006-04-26 08:06:52.446515440 +0930
+@@ -11,8 +11,8 @@
+ long as it is difficult enough to generate two different messages with
+ the same hash algorithm output. In that case the same signature could
+ be used as a proof for both messages. Nobody wants to sign an innocent
+-message of donating 1 @euro{} to Greenpeace and find out that he
+-donated 1.000.000 @euro{} to Bad Inc.
++message of donating 1 euro to Greenpeace and find out that he
++donated 1.000.000 euro to Bad Inc.
+
+ For a hash algorithm to be called cryptographic the following three
+ requirements must hold