summaryrefslogtreecommitdiff
path: root/meta/recipes-tbd/pulseaudio/libcanberra
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2010-10-07 21:38:47 +0100
committerRichard Purdie <rpurdie@linux.intel.com>2010-10-07 21:38:47 +0100
commit519b7c0dd398aaa3e0f3b32fdacbc44759480aac (patch)
tree93b9dce1687b9e4bc47c4a42ba6de881c737ae8b /meta/recipes-tbd/pulseaudio/libcanberra
parent02445fca7b6d222c94a6bb3efd35d094025ae5fb (diff)
downloadopenembedded-core-519b7c0dd398aaa3e0f3b32fdacbc44759480aac.tar.gz
openembedded-core-519b7c0dd398aaa3e0f3b32fdacbc44759480aac.tar.bz2
openembedded-core-519b7c0dd398aaa3e0f3b32fdacbc44759480aac.tar.xz
openembedded-core-519b7c0dd398aaa3e0f3b32fdacbc44759480aac.zip
pulseaudio: Add back after it was lost in meta-moblin removal (and dependencies)
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'meta/recipes-tbd/pulseaudio/libcanberra')
-rw-r--r--meta/recipes-tbd/pulseaudio/libcanberra/autoconf_version.patch38
-rw-r--r--meta/recipes-tbd/pulseaudio/libcanberra/nofallbackfix.patch16
2 files changed, 54 insertions, 0 deletions
diff --git a/meta/recipes-tbd/pulseaudio/libcanberra/autoconf_version.patch b/meta/recipes-tbd/pulseaudio/libcanberra/autoconf_version.patch
new file mode 100644
index 000000000..73a2ea6e4
--- /dev/null
+++ b/meta/recipes-tbd/pulseaudio/libcanberra/autoconf_version.patch
@@ -0,0 +1,38 @@
+Allow a slightly older autoconf and disable the inbuild libltdl
+
+RP - 16/4/09
+
+Index: libcanberra-0.10/Makefile.am
+===================================================================
+--- libcanberra-0.10.orig/Makefile.am 2009-04-16 14:38:53.000000000 +0100
++++ libcanberra-0.10/Makefile.am 2009-04-16 14:39:04.000000000 +0100
+@@ -19,7 +19,7 @@
+ dist_doc_DATA = README
+
+ EXTRA_DIST = bootstrap.sh autogen.sh LGPL libcanberra.schemas
+-SUBDIRS = src gtkdoc libltdl doc
++SUBDIRS = src gtkdoc doc
+
+ MAINTAINERCLEANFILES = README
+ noinst_DATA = README
+Index: libcanberra-0.10/configure.ac
+===================================================================
+--- libcanberra-0.10.orig/configure.ac 2009-04-16 14:32:33.000000000 +0100
++++ libcanberra-0.10/configure.ac 2009-04-16 14:37:50.000000000 +0100
+@@ -19,7 +19,7 @@
+ # License along with libcanberra. If not, see
+ # <http://www.gnu.org/licenses/>.
+
+-AC_PREREQ(2.62)
++AC_PREREQ(2.61)
+
+ AC_INIT([libcanberra], 0.10, [mzyvopnaoreen (at) 0pointer (dot) de])
+ AC_CONFIG_SRCDIR([src/common.c])
+@@ -70,7 +70,6 @@
+ AC_PROG_LIBTOOL
+ AC_SUBST(LTDLINCL)
+ AC_SUBST(LIBLTDL)
+-AC_CONFIG_SUBDIRS(libltdl)
+
+ #### Determine build environment ####
+
diff --git a/meta/recipes-tbd/pulseaudio/libcanberra/nofallbackfix.patch b/meta/recipes-tbd/pulseaudio/libcanberra/nofallbackfix.patch
new file mode 100644
index 000000000..89a4fbf9f
--- /dev/null
+++ b/meta/recipes-tbd/pulseaudio/libcanberra/nofallbackfix.patch
@@ -0,0 +1,16 @@
+Index: libcanberra-0.10/src/sound-theme-spec.c
+===================================================================
+--- libcanberra-0.10.orig/src/sound-theme-spec.c 2009-05-22 17:08:23.000000000 +0100
++++ libcanberra-0.10/src/sound-theme-spec.c 2009-05-22 17:12:50.000000000 +0100
+@@ -398,9 +398,9 @@
+ if ((ret = load_theme_dir(t, name)) < 0)
+ goto fail;
+
++ /* The fallback theme may intentionally not exist so ignore failure */
+ if (!t->loaded_fallback_theme)
+- if ((ret = load_theme_dir(t, FALLBACK_THEME)) < 0)
+- goto fail;
++ load_theme_dir(t, FALLBACK_THEME);
+
+ if (*_t)
+ ca_theme_data_free(*_t);