summaryrefslogtreecommitdiff
path: root/meta
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2008-12-18 17:00:46 +0000
committerRichard Purdie <rpurdie@linux.intel.com>2008-12-18 17:00:46 +0000
commit01121bc89e0406cb3a651abe09c47bdfec10c566 (patch)
tree770350631e124f241e17479cc4dd559fb979bace /meta
parent0f918b445e48ff1d45929251697f476c1053bc43 (diff)
downloadopenembedded-core-01121bc89e0406cb3a651abe09c47bdfec10c566.tar.gz
openembedded-core-01121bc89e0406cb3a651abe09c47bdfec10c566.tar.bz2
openembedded-core-01121bc89e0406cb3a651abe09c47bdfec10c566.tar.xz
openembedded-core-01121bc89e0406cb3a651abe09c47bdfec10c566.zip
clutter: Fix enable_tests patch for recent changes
Diffstat (limited to 'meta')
-rw-r--r--meta/packages/clutter/clutter/enable-tests-r2990.patch50
-rw-r--r--meta/packages/clutter/clutter/enable_tests.patch44
-rw-r--r--meta/packages/clutter/clutter_git.bb6
3 files changed, 16 insertions, 84 deletions
diff --git a/meta/packages/clutter/clutter/enable-tests-r2990.patch b/meta/packages/clutter/clutter/enable-tests-r2990.patch
deleted file mode 100644
index 4f449b117..000000000
--- a/meta/packages/clutter/clutter/enable-tests-r2990.patch
+++ /dev/null
@@ -1,50 +0,0 @@
----
- tests/Makefile.am | 7 ++++++-
- tests/test-actors.c | 2 +-
- tests/test-text.c | 2 +-
- 3 files changed, 8 insertions(+), 3 deletions(-)
-
-Index: clutter/tests/Makefile.am
-===================================================================
---- clutter.orig/tests/Makefile.am 2008-06-26 16:46:26.000000000 +0100
-+++ clutter/tests/Makefile.am 2008-06-26 16:46:50.000000000 +0100
-@@ -1,4 +1,4 @@
--noinst_PROGRAMS = test-textures test-events test-offscreen test-scale \
-+bin_PROGRAMS = test-textures test-events test-offscreen test-scale \
- test-actors test-behave test-text test-entry test-project \
- test-perspective test-rotate test-depth \
- test-threads test-timeline test-timeline-dup-frames \
-@@ -17,8 +17,8 @@
- test-invariants
-
- if X11_TESTS
--noinst_PROGRAMS += test-pixmap
--noinst_PROGRAMS += test-devices
-+bin_PROGRAMS += test-pixmap
-+bin_PROGRAMS += test-devices
- endif
-
- INCLUDES = -I$(top_srcdir)/ -I$(top_srcdir)/clutter -I$(top_builddir)/clutter
-@@ -73,4 +73,9 @@
- test_invariants_SOURCES = test-invariants.c
- test_devices_SOURCES = test-devices.c
-
-+test_textdir = $(pkgdatadir)
-+test_text_DATA = test-text.c
-+test_actorsdir = $(pkgdatadir)
-+test_actors_DATA = redhand.png
-+
- EXTRA_DIST = redhand.png test-script.json
-Index: clutter/tests/test-actors.c
-===================================================================
---- clutter.orig/tests/test-actors.c 2008-06-26 16:46:26.000000000 +0100
-+++ clutter/tests/test-actors.c 2008-06-26 16:46:31.000000000 +0100
-@@ -195,7 +195,7 @@
- /* Create a texture from file, then clone in to same resources */
- if (i == 0)
- {
-- if ((oh->hand[i] = clutter_texture_new_from_file ("redhand.png",
-+ if ((oh->hand[i] = clutter_texture_new_from_file ("/usr/share/clutter/redhand.png",
- &error)) == NULL)
- {
- g_error ("image load failed: %s", error->message);
diff --git a/meta/packages/clutter/clutter/enable_tests.patch b/meta/packages/clutter/clutter/enable_tests.patch
index 4a99968fa..854461479 100644
--- a/meta/packages/clutter/clutter/enable_tests.patch
+++ b/meta/packages/clutter/clutter/enable_tests.patch
@@ -4,40 +4,24 @@
tests/test-text.c | 2 +-
3 files changed, 8 insertions(+), 3 deletions(-)
-Index: clutter/tests/Makefile.am
+Index: git/tests/interactive/Makefile.am
===================================================================
---- clutter.orig/tests/Makefile.am 2008-04-25 16:45:17.000000000 +0100
-+++ clutter/tests/Makefile.am 2008-04-25 16:47:12.000000000 +0100
-@@ -1,4 +1,4 @@
--noinst_PROGRAMS = test-textures test-events test-offscreen test-scale \
-+bin_PROGRAMS = test-textures test-events test-offscreen test-scale \
- test-actors test-behave test-text test-entry test-project \
- test-perspective test-rotate test-depth \
- test-threads test-timeline test-timeline-dup-frames \
-@@ -14,7 +14,7 @@
- test-cogl-tex-polygon test-stage-read-pixels
+--- git.orig/tests/interactive/Makefile.am 2008-12-18 16:50:45.000000000 +0000
++++ git/tests/interactive/Makefile.am 2008-12-18 16:57:36.000000000 +0000
+@@ -68,7 +68,7 @@
+ AM_CFLAGS = $(CLUTTER_CFLAGS)
+ AM_LDFLAGS = $(CLUTTER_LIBS)
- if X11_TESTS
--noinst_PROGRAMS += test-pixmap
-+bin_PROGRAMS += test-pixmap
- endif
+-noinst_PROGRAMS = test-interactive
++bin_PROGRAMS = test-interactive
- INCLUDES = -I$(top_srcdir)/ -I$(top_builddir)/clutter
-@@ -61,4 +61,9 @@
- test_cogl_offscreen_SOURCES = test-cogl-offscreen.c
- test_stage_read_pixels_SOURCES = test-stage-read-pixels.c
-
-+test_textdir = $(pkgdatadir)
-+test_text_DATA = test-text.c
-+test_actorsdir = $(pkgdatadir)
-+test_actors_DATA = redhand.png
-+
- EXTRA_DIST = redhand.png test-script.json
-Index: clutter/tests/test-actors.c
+ test_interactive_SOURCES = \
+ test-main.c \
+Index: git/tests/interactive/test-actors.c
===================================================================
---- clutter.orig/tests/test-actors.c 2008-04-25 16:45:17.000000000 +0100
-+++ clutter/tests/test-actors.c 2008-04-25 16:45:17.000000000 +0100
-@@ -184,7 +184,7 @@
+--- git.orig/tests/interactive/test-actors.c 2008-12-18 16:58:06.000000000 +0000
++++ git/tests/interactive/test-actors.c 2008-12-18 16:58:13.000000000 +0000
+@@ -189,7 +189,7 @@
/* Create a texture from file, then clone in to same resources */
if (i == 0)
{
diff --git a/meta/packages/clutter/clutter_git.bb b/meta/packages/clutter/clutter_git.bb
index 28b03a489..da6654b32 100644
--- a/meta/packages/clutter/clutter_git.bb
+++ b/meta/packages/clutter/clutter_git.bb
@@ -1,12 +1,10 @@
require clutter.inc
PV = "0.8.0+git${SRCREV}"
-PR = "r2"
+PR = "r3"
SRC_URI = "git://git.clutter-project.org/clutter.git;protocol=git;branch=master \
- file://enable_tests.patch;patch=1;maxrev=2989 \
- file://enable-tests-r2990.patch;patch=1;minrev=2990"
-
+ file://enable_tests.patch;patch=1 "
S = "${WORKDIR}/git"