summaryrefslogtreecommitdiff
path: root/meta
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openedhand.com>2008-04-08 15:15:09 +0000
committerMarcin Juszkiewicz <hrw@openedhand.com>2008-04-08 15:15:09 +0000
commit06976c635a486ec8412db552b6fb1193f650bf1f (patch)
tree8ecab72816b1542b90593f6ee2702c6f17e5114b /meta
parentb3dddcdde5d10f382f71413aad67f7ef2e2420a2 (diff)
downloadopenembedded-core-06976c635a486ec8412db552b6fb1193f650bf1f.tar.gz
openembedded-core-06976c635a486ec8412db552b6fb1193f650bf1f.tar.bz2
openembedded-core-06976c635a486ec8412db552b6fb1193f650bf1f.tar.xz
openembedded-core-06976c635a486ec8412db552b6fb1193f650bf1f.zip
fakeroot: merge 1.9.4 from OE
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@4205 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta')
-rw-r--r--meta/packages/fakeroot/fakeroot-native_1.9.4.bb (renamed from meta/packages/fakeroot/fakeroot-native_1.7.1.bb)8
-rw-r--r--meta/packages/fakeroot/fakeroot_1.9.4.bb (renamed from meta/packages/fakeroot/fakeroot_1.7.1.bb)11
-rw-r--r--meta/packages/fakeroot/files/autofoo.patch13
-rw-r--r--meta/packages/fakeroot/files/configure-libtool.patch18
4 files changed, 27 insertions, 23 deletions
diff --git a/meta/packages/fakeroot/fakeroot-native_1.7.1.bb b/meta/packages/fakeroot/fakeroot-native_1.9.4.bb
index 0eb101e6b..77d6f5865 100644
--- a/meta/packages/fakeroot/fakeroot-native_1.7.1.bb
+++ b/meta/packages/fakeroot/fakeroot-native_1.9.4.bb
@@ -1,11 +1,12 @@
-SECTION = "base"
require fakeroot_${PV}.bb
-inherit native
+
RDEPENDS="util-linux-native"
-SRC_URI += "file://fix-prefix.patch;patch=1"
+SRC_URI += "file://fix-prefix.patch;patch=1 "
S = "${WORKDIR}/fakeroot-${PV}"
+inherit native
+
EXTRA_OECONF = " --program-prefix="
# Compatability for the rare systems not using or having SYSV
@@ -17,3 +18,4 @@ python () {
do_stage_append () {
oe_libinstall -so libfakeroot ${STAGING_LIBDIR}/libfakeroot/
}
+
diff --git a/meta/packages/fakeroot/fakeroot_1.7.1.bb b/meta/packages/fakeroot/fakeroot_1.9.4.bb
index 6abf8a670..aaf696d79 100644
--- a/meta/packages/fakeroot/fakeroot_1.7.1.bb
+++ b/meta/packages/fakeroot/fakeroot_1.9.4.bb
@@ -1,19 +1,16 @@
DESCRIPTION = "Gives a fake root environment"
-HOMEPAGE = "http://joostje.op.het.net/fakeroot/index.html"
+HOMEPAGE = "http://fakeroot.alioth.debian.org/"
SECTION = "base"
LICENSE = "GPL"
# fakeroot needs getopt which is provided by the util-linux package
RDEPENDS = "util-linux"
-PR = "r2"
+PR = "r1"
SRC_URI = "${DEBIAN_MIRROR}/main/f/fakeroot/fakeroot_${PV}.tar.gz \
- file://autofoo.patch;patch=1"
-
+ file://configure-libtool.patch;patch=1"
+
inherit autotools
-# The fakeroot script requires the .so link to be present
-FILES_${PN} =+ "${libdir}/libfakeroot-*.so ${libdir}/libfakeroot.so"
-
do_stage() {
install -d ${STAGING_INCDIR}/fakeroot
install -m 644 *.h ${STAGING_INCDIR}/fakeroot
diff --git a/meta/packages/fakeroot/files/autofoo.patch b/meta/packages/fakeroot/files/autofoo.patch
deleted file mode 100644
index f3949386d..000000000
--- a/meta/packages/fakeroot/files/autofoo.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-Index: fakeroot-1.7.1/configure.ac
-===================================================================
---- fakeroot-1.7.1.orig/configure.ac 2007-04-13 16:57:48.000000000 +0000
-+++ fakeroot-1.7.1/configure.ac 2007-08-21 14:19:59.000000000 +0000
-@@ -7,8 +7,6 @@
- AC_CONFIG_HEADERS([config.h])
- AC_PROG_MAKE_SET
- AM_PROG_LIBTOOL
--LT_INIT
--LT_LANG(C)
-
- AC_ARG_WITH([ipc],
- AS_HELP_STRING([--with-ipc@<:@=IPCTYPE@:>@],
diff --git a/meta/packages/fakeroot/files/configure-libtool.patch b/meta/packages/fakeroot/files/configure-libtool.patch
new file mode 100644
index 000000000..8830328eb
--- /dev/null
+++ b/meta/packages/fakeroot/files/configure-libtool.patch
@@ -0,0 +1,18 @@
+--- fakeroot-1.8.3/configure.ac.orig 2007-10-31 00:17:27.000000000 -0500
++++ fakeroot-1.8.3/configure.ac 2007-10-31 00:18:12.000000000 -0500
+@@ -1,14 +1,12 @@
+ dnl Process this file with autoconf to produce a configure script.
+ AC_INIT([fakeroot],[FAKEROOT_VERSION],[schizo@debian.org],[fakeroot])
+ AC_PREREQ(2.61)
+-LT_PREREQ(2.1a)
+ AC_CANONICAL_TARGET
+ AM_INIT_AUTOMAKE
+ AM_MAINTAINER_MODE
+ AC_CONFIG_HEADERS([config.h])
+ AC_PROG_MAKE_SET
+-LT_INIT
+-LT_LANG(C)
++AC_PROG_LIBTOOL
+
+ AC_ARG_WITH([ipc],
+ AS_HELP_STRING([--with-ipc@<:@=IPCTYPE@:>@],