summaryrefslogtreecommitdiff
path: root/meta
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2009-06-12 15:58:37 +0100
committerRichard Purdie <rpurdie@linux.intel.com>2009-06-12 15:58:37 +0100
commit078d43d16aae16dd394d84ced5095dbe3f68a450 (patch)
tree193a04a39283689dac990ac7ecf6e3cdd827ee4a /meta
parentd950827961693b16587b6622c696aefebc349865 (diff)
downloadopenembedded-core-078d43d16aae16dd394d84ced5095dbe3f68a450.tar.gz
openembedded-core-078d43d16aae16dd394d84ced5095dbe3f68a450.tar.bz2
openembedded-core-078d43d16aae16dd394d84ced5095dbe3f68a450.tar.xz
openembedded-core-078d43d16aae16dd394d84ced5095dbe3f68a450.zip
telepathy-glib: Use autotools_stage_all now (its been fixed)
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'meta')
-rw-r--r--meta/packages/telepathy/telepathy-glib_0.7.29.bb32
1 files changed, 2 insertions, 30 deletions
diff --git a/meta/packages/telepathy/telepathy-glib_0.7.29.bb b/meta/packages/telepathy/telepathy-glib_0.7.29.bb
index 4d143bac1..44df34df6 100644
--- a/meta/packages/telepathy/telepathy-glib_0.7.29.bb
+++ b/meta/packages/telepathy/telepathy-glib_0.7.29.bb
@@ -2,40 +2,12 @@ DESCRIPTION = "Telepathy Framework: GLib-based helper library for connection man
HOMEPAGE = "http://telepathy.freedesktop.org/wiki/"
DEPENDS = "glib-2.0 dbus python-native-runtime dbus-native dbus-glib"
LICENSE = "LGPL"
+PR = "r1"
SRC_URI = "http://telepathy.freedesktop.org/releases/telepathy-glib/${P}.tar.gz \
file://prefer_python_2.5.patch;patch=1 "
-inherit autotools pkgconfig
+inherit autotools_stage pkgconfig
FILES_${PN} += "${datadir}/telepathy \
${datadir}/dbus-1"
-
-do_stage() {
- #
- # copied autotools_stage_all because telepathy-glib has one lib only built as static
- # so it can not be oe_libinstalled
- #
- rm -rf ${STAGE_TEMP}
- mkdir -p ${STAGE_TEMP}
- oe_runmake DESTDIR="${STAGE_TEMP}" install
- if [ -d ${STAGE_TEMP}/${includedir} ]; then
- cp -fpPR ${STAGE_TEMP}/${includedir}/* ${STAGING_INCDIR}
- fi
- if [ -d ${STAGE_TEMP}/${libdir} ]
- then
- for i in ${STAGE_TEMP}/${libdir}/*.la
- do
- if [ ! -f "$i" ]; then
- cp -fpPR ${STAGE_TEMP}/${libdir}/* ${STAGING_LIBDIR}
- break
- fi
- done
- oe_libinstall -so -C telepathy-glib/.libs libtelepathy-glib ${STAGING_LIBDIR}
- fi
- if [ -d ${STAGE_TEMP}/${datadir}/aclocal ]; then
- install -d ${STAGING_DATADIR}/aclocal
- cp -fpPR ${STAGE_TEMP}/${datadir}/aclocal/* ${STAGING_DATADIR}/aclocal
- fi
- rm -rf ${STAGE_TEMP}
-}