summaryrefslogtreecommitdiff
path: root/meta
diff options
context:
space:
mode:
authorRoss Burton <ross@openedhand.com>2007-05-04 15:23:09 +0000
committerRoss Burton <ross@openedhand.com>2007-05-04 15:23:09 +0000
commit11f5ec6e8962f74b6b2437030ab4b747a09f5a9c (patch)
tree34e996ddafdd1fce5464ec73b31ea79ceadbd382 /meta
parent0efc0dfc20f452ea25630b45aa5e13cf3e074e46 (diff)
downloadopenembedded-core-11f5ec6e8962f74b6b2437030ab4b747a09f5a9c.tar.gz
openembedded-core-11f5ec6e8962f74b6b2437030ab4b747a09f5a9c.tar.bz2
openembedded-core-11f5ec6e8962f74b6b2437030ab4b747a09f5a9c.tar.xz
openembedded-core-11f5ec6e8962f74b6b2437030ab4b747a09f5a9c.zip
Add libxslt for gnome-doc-utils
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@1596 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta')
-rw-r--r--meta/packages/libxslt/files/destdir.patch10
-rw-r--r--meta/packages/libxslt/libxslt_1.1.17.bb46
2 files changed, 56 insertions, 0 deletions
diff --git a/meta/packages/libxslt/files/destdir.patch b/meta/packages/libxslt/files/destdir.patch
new file mode 100644
index 000000000..8df1b206b
--- /dev/null
+++ b/meta/packages/libxslt/files/destdir.patch
@@ -0,0 +1,10 @@
+Index: libxslt-1.1.17/libxslt/Makefile.am
+===================================================================
+--- libxslt-1.1.17.orig/libxslt/Makefile.am 2005-10-02 11:25:21.000000000 +0200
++++ libxslt-1.1.17/libxslt/Makefile.am 2006-09-29 23:13:35.000000000 +0200
+@@ -61,4 +61,4 @@
+ @(cd ../xsltproc ; $(MAKE))
+
+ install-exec-hook:
+- $(mkinstalldirs) "$(libdir)/libxslt-plugins"
++ $(mkinstalldirs) "$(DESTDIR)$(libdir)/libxslt-plugins"
diff --git a/meta/packages/libxslt/libxslt_1.1.17.bb b/meta/packages/libxslt/libxslt_1.1.17.bb
new file mode 100644
index 000000000..7abd2c30b
--- /dev/null
+++ b/meta/packages/libxslt/libxslt_1.1.17.bb
@@ -0,0 +1,46 @@
+DESCRIPTION = "GNOME XSLT library"
+SECTION = "libs"
+PRIORITY = "optional"
+DEPENDS = "libxml2"
+LICENSE = "MIT"
+PR = "r2"
+
+SRC_URI = "ftp://xmlsoft.org/libxml2/libxslt-${PV}.tar.gz \
+ file://destdir.patch;patch=1"
+S = "${WORKDIR}/libxslt-${PV}"
+
+inherit autotools pkgconfig
+
+EXTRA_OECONF = "--without-python --without-debug --without-mem-debug --without-crypto"
+
+xsltheaders = "attributes.h documents.h extensions.h extra.h functions.h imports.h \
+ keys.h namespaces.h numbersInternals.h pattern.h preproc.h security.h \
+ templates.h transform.h variables.h xslt.h xsltInternals.h xsltconfig.h \
+ xsltexports.h xsltutils.h"
+exsltheaders = "exslt.h exsltconfig.h exsltexports.h"
+
+do_stage () {
+ oe_libinstall -C libxslt -so -a libxslt ${STAGING_LIBDIR}
+ oe_libinstall -C libexslt -so -a libexslt ${STAGING_LIBDIR}
+
+ mkdir -p ${STAGING_INCDIR}/libxslt
+ for i in ${xsltheaders}; do
+ install -m 0644 ${S}/libxslt/$i ${STAGING_INCDIR}/libxslt/$i
+ done
+ mkdir -p ${STAGING_INCDIR}/libexslt
+ for i in ${exsltheaders}; do
+ install -m 0644 ${S}/libexslt/$i ${STAGING_INCDIR}/libexslt/$i
+ done
+
+ cat xslt-config | sed -e "s,^prefix=.*,prefix=${STAGING_DIR}/${HOST_SYS}," \
+ -e "s,^exec_prefix=.*,exec_prefix=${STAGING_DIR}/${HOST_SYS}," \
+ -e "s,^includedir=.*,includedir=${STAGING_INCDIR}," \
+ -e "s,^libdir=.*,libdir=${STAGING_LIBDIR}," > ${STAGING_BINDIR_CROSS}/xslt-config
+ chmod a+rx ${STAGING_BINDIR_CROSS}/xslt-config
+ install -m 0644 libxslt.m4 ${STAGING_DATADIR}/aclocal/
+}
+
+PACKAGES = "${PN}-dbg ${PN}-dev ${PN}-utils ${PN} ${PN}-doc ${PN}-locale"
+
+FILES_${PN}-dev += "${bindir}/xslt-config"
+FILES_${PN}-utils += "${bindir}"