summaryrefslogtreecommitdiff
path: root/meta
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openedhand.com>2008-03-17 12:58:08 +0000
committerMarcin Juszkiewicz <hrw@openedhand.com>2008-03-17 12:58:08 +0000
commit23684b683f0af5c3496eb3cf1dbf65124a5cde8c (patch)
tree57cd6b0adafba4f531d75e14e7746e0429f9df2c /meta
parent7ed94682858a2bc067b9fb1376a0ae5d414d4a6b (diff)
downloadopenembedded-core-23684b683f0af5c3496eb3cf1dbf65124a5cde8c.tar.gz
openembedded-core-23684b683f0af5c3496eb3cf1dbf65124a5cde8c.tar.bz2
openembedded-core-23684b683f0af5c3496eb3cf1dbf65124a5cde8c.tar.xz
openembedded-core-23684b683f0af5c3496eb3cf1dbf65124a5cde8c.zip
opkg: moved common stuff to opkg.inc, added S98configure
Signed-off-by: Marcin Juszkiewicz <hrw@openedhand.com> git-svn-id: https://svn.o-hand.com/repos/poky/trunk@4022 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta')
-rw-r--r--meta/packages/opkg/opkg-native_svn.bb3
-rw-r--r--meta/packages/opkg/opkg_svn.bb42
2 files changed, 28 insertions, 17 deletions
diff --git a/meta/packages/opkg/opkg-native_svn.bb b/meta/packages/opkg/opkg-native_svn.bb
index c90c91dae..d5e20e14b 100644
--- a/meta/packages/opkg/opkg-native_svn.bb
+++ b/meta/packages/opkg/opkg-native_svn.bb
@@ -1,4 +1,4 @@
-require opkg_svn.bb
+require opkg.inc
DEPENDS = "curl-native"
@@ -7,4 +7,3 @@ target_libdir := "${libdir}"
inherit native
EXTRA_OECONF += "--with-opkglibdir=${target_libdir}/opkg -disable-gpg"
-
diff --git a/meta/packages/opkg/opkg_svn.bb b/meta/packages/opkg/opkg_svn.bb
index 149f3050c..30461ead4 100644
--- a/meta/packages/opkg/opkg_svn.bb
+++ b/meta/packages/opkg/opkg_svn.bb
@@ -1,21 +1,33 @@
-DESCRIPTION = "Open Package Manager"
-DESCRIPTION_libopkg = "Open Package Manager Library"
-SECTION = "base"
-LICENSE = "GPL"
-DEPENDS = "curl gpgme"
-PV = "0.0+svnr${SRCREV}"
-PR = "r1"
+require opkg.inc
-SRC_URI = "svn://svn.openmoko.org/trunk/src/target/;module=opkg;proto=http"
-S = "${WORKDIR}/opkg"
-
-inherit autotools pkgconfig
-
-do_stage() {
- autotools_stage_all
-}
+PR = "r2"
PACKAGES =+ "libopkg-dev libopkg"
FILES_libopkg-dev = "${libdir}/*.a ${libdir}/*.la ${libdir}/*.so"
FILES_libopkg = "${libdir}/*.so.*"
+
+# Define a variable to allow distros to run configure earlier.
+# (for example, to enable loading of ethernet kernel modules before networking starts)
+OPKG_INIT_POSITION = "98"
+OPKG_INIT_POSITION_slugos = "41"
+
+pkg_postinst_opkg () {
+#!/bin/sh
+if [ "x$D" != "x" ]; then
+ install -d ${IMAGE_ROOTFS}/${sysconfdir}/rcS.d
+ # this happens at S98 where our good 'ole packages script used to run
+ echo "#!/bin/sh
+opkg-cl configure
+" > ${IMAGE_ROOTFS}/${sysconfdir}/rcS.d/S${OPKG_INIT_POSITION}configure
+ chmod 0755 ${IMAGE_ROOTFS}/${sysconfdir}/rcS.d/S${OPKG_INIT_POSITION}configure
+fi
+
+update-alternatives --install ${bindir}/opkg opkg ${bindir}/opkg-cl 100
+}
+
+pkg_postrm_opkg () {
+#!/bin/sh
+update-alternatives --remove opkg ${bindir}/opkg-cl
+}
+