summaryrefslogtreecommitdiff
path: root/meta
diff options
context:
space:
mode:
authorDike, Jeffrey G <jeffrey.g.dike@intel.com>2010-06-16 14:32:49 -0700
committerJoshua Lock <josh@linux.intel.com>2010-06-17 12:33:10 +0100
commit30e98b4a0d85163acd5d33d252f8637bfd40b2ef (patch)
treedb967fbb52b56564835f3fe46cef21980ab12e8e /meta
parentc87bf0cfc656b4ae32b5e6ea926a71135b609a2e (diff)
downloadopenembedded-core-30e98b4a0d85163acd5d33d252f8637bfd40b2ef.tar.gz
openembedded-core-30e98b4a0d85163acd5d33d252f8637bfd40b2ef.tar.bz2
openembedded-core-30e98b4a0d85163acd5d33d252f8637bfd40b2ef.tar.xz
openembedded-core-30e98b4a0d85163acd5d33d252f8637bfd40b2ef.zip
linux-libc-headers: Remove ioctls for deleted driver
2.6.33 removed the Hayes ESP driver. The presence of these ioctls makes setserial believe that ESP support should be built in, breaking its build. Signed-off-by: Jeff Dike <jdike@linux.intel.com>
Diffstat (limited to 'meta')
-rw-r--r--meta/packages/linux-libc-headers/linux-libc-headers-2.6.33/hayes-gone.patch25
-rw-r--r--meta/packages/linux-libc-headers/linux-libc-headers_2.6.33.bb5
2 files changed, 28 insertions, 2 deletions
diff --git a/meta/packages/linux-libc-headers/linux-libc-headers-2.6.33/hayes-gone.patch b/meta/packages/linux-libc-headers/linux-libc-headers-2.6.33/hayes-gone.patch
new file mode 100644
index 000000000..dc6338a95
--- /dev/null
+++ b/meta/packages/linux-libc-headers/linux-libc-headers-2.6.33/hayes-gone.patch
@@ -0,0 +1,25 @@
+# 2.6.33 deleted the Hayes esp driver, so the ioctls to get and set its
+# configuration are no longer needed, and they break setserial by making it
+# believe that it should compile in the code that supports this modem.
+
+Index: linux-2.6.33/include/asm-generic/ioctls.h
+===================================================================
+--- linux-2.6.33.orig/include/asm-generic/ioctls.h
++++ linux-2.6.33/include/asm-generic/ioctls.h
+@@ -86,16 +86,6 @@
+ #define TIOCMIWAIT 0x545C /* wait for a change on serial input line(s) */
+ #define TIOCGICOUNT 0x545D /* read serial port inline interrupt counts */
+
+-/*
+- * some architectures define FIOQSIZE as 0x545E, which is used for
+- * TIOCGHAYESESP on others
+- */
+-#ifndef FIOQSIZE
+-# define TIOCGHAYESESP 0x545E /* Get Hayes ESP configuration */
+-# define TIOCSHAYESESP 0x545F /* Set Hayes ESP configuration */
+-# define FIOQSIZE 0x5460
+-#endif
+-
+ /* Used for packet mode */
+ #define TIOCPKT_DATA 0
+ #define TIOCPKT_FLUSHREAD 1
diff --git a/meta/packages/linux-libc-headers/linux-libc-headers_2.6.33.bb b/meta/packages/linux-libc-headers/linux-libc-headers_2.6.33.bb
index e70698807..4a63910e8 100644
--- a/meta/packages/linux-libc-headers/linux-libc-headers_2.6.33.bb
+++ b/meta/packages/linux-libc-headers/linux-libc-headers_2.6.33.bb
@@ -2,9 +2,10 @@ require linux-libc-headers.inc
INHIBIT_DEFAULT_DEPS = "1"
DEPENDS += "unifdef-native"
-PR = "r0"
+PR = "r1"
-SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-${PV}.tar.bz2"
+SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-${PV}.tar.bz2 \
+ file://hayes-gone.patch"
S = "${WORKDIR}/linux-${PV}"